Bug 1046619 - nfs-ganesha: returns error when IP of other node is given as input to startup script but actually nfs process is started
Summary: nfs-ganesha: returns error when IP of other node is given as input to startup...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: nfs-ganesha
Version: 2.1
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
: RHGS 2.1.2
Assignee: Meghana
QA Contact: Saurabh
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-26 10:49 UTC by Saurabh
Modified: 2016-01-19 06:13 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-25 08:13:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:0208 0 normal SHIPPED_LIVE Red Hat Storage 2.1 enhancement and bug fix update #2 2014-02-25 12:20:30 UTC

Description Saurabh 2013-12-26 10:49:27 UTC
Description of problem:
for /usr/lib/glusterfs/.unsupported/rhs-nfs_ganesha.sh ip of a node has to be given as input, the IP should be of the same system on which the script is executed. 

Presently trying to give IP input as IP of someother node, the script throws error, but the nfs process is started.


Version-Release number of selected component (if applicable):
nfs-ganesha-2.0.0.1-4.el6rhs.x86_64
glusterfs-3.4.0.52rhs-1.el6rhs.x86_64

How reproducible:
always

Steps to Reproduce:
1./usr/lib/glusterfs/.unsupported/rhs-nfs_ganesha.sh -l /root/nfs-ganesha/server.log -n NIV_FULL_DEBUG -v dist-rep -i <IP of some other node> -f /usr/lib/glusterfs/.unsupported/nfs-ganesha.conf -o start


Actual results:
[root@rhsauto016 ~]# /usr/lib/glusterfs/.unsupported/rhs-nfs_ganesha.sh -l /root/nfs-ganesha/server.log -n NIV_FULL_DEBUG -v dist-rep -i 10.70.37.4 -f /usr/lib/glusterfs/.unsupported/nfs-ganesha.conf -o start

NFS-ganesha server started.
============Volume exports============
clnt_create: RPC: Program not registered
======================================


[root@rhsauto016 ~]# ps -eaf | grep nfs
root     10629     1  0 10:35 ?        00:00:00 /usr/bin/ganesha.nfsd -f /usr/lib/glusterfs/.unsupported/nfs-ganesha.conf -L /root/nfs-ganesha/server.log -N NIV_FULL_DEBUG -d
root     10704 14606  0 10:39 pts/1    00:00:00 grep nfs

Expected results:
if the IP as input is required of same node then it should not start nfs process when a wrong IP is given.

Additional info:

Comment 2 Gowrishankar Rajaiyan 2014-01-20 05:30:01 UTC
Fixed in Version and patch URL ?

Comment 3 Meghana 2014-01-20 12:01:28 UTC
Fixed in nfs-ganesha-2.0.0.1-5.el6rhs.x86_64 rpms

Comment 4 Saurabh 2014-01-23 11:48:47 UTC
tested on nfs-ganesha-2.0.0.1-5.el6rhs.x86_64

Comment 6 errata-xmlrpc 2014-02-25 08:13:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html


Note You need to log in before you can comment on or make changes to this bug.