Bug 104671 - lock file not removed when stopped with the rc-script
lock file not removed when stopped with the rc-script
Status: CLOSED DUPLICATE of bug 88110
Product: Red Hat Linux
Classification: Retired
Component: spamassassin (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-18 14:04 EDT by Jeffrey C. Davis
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeffrey C. Davis 2003-09-18 14:04:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; RA; T312461)

Description of problem:
The lock file used in the rc-script (/etc/init.d/spamassassin) does not match 
betwen the 'start', 'stop', and 'condrestart' options.  'start' creates the 
incorrect file /var/lock/subsys/spamd and 'stop' tries to remove the 
file /var/lock/subsys/spamassassin.  The lock file is never removed when 
spamassassin is stopped with the rc-script.  Additionally, the 'condrestart' 
option will never work, because it looks for the 
file /var/lock/subsys/spamassassin.


Version-Release number of selected component (if applicable):
spamassassin-2.44-11.8.x

How reproducible:
Always

Steps to Reproduce:
1. # /etc/init.d/spamassassin start
2. # ls /var/lock/subsys
     (notice the spamd file)
3. # /etc/init.d/spamassassin stop
4. # ls /var/lock/subsys
     (notice the spamd file is still there)


Actual Results:  The file /var/lock/subsys/spamd is created (touched) but never 
is removed.


Expected Results:  The file /var/lock/subsys/spamassassin should be created 
(touched) when the rc-script is given the 'start' option, nad should be removed 
when given the 'stop' option.


Additional info:
Comment 1 Warren Togami 2004-02-29 01:19:10 EST

*** This bug has been marked as a duplicate of 88110 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:58:38 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.