Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1046717 - Cancel run or pull operation doesn't actually stop the ongoing task
Summary: Cancel run or pull operation doesn't actually stop the ongoing task
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: docker-io
Version: 20
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Matthew Heon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-26 18:06 UTC by Baptiste Mille-Mathias
Modified: 2015-04-15 12:18 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-15 12:18:25 UTC
Type: Bug


Attachments (Terms of Use)

Description Baptiste Mille-Mathias 2013-12-26 18:06:04 UTC
Description of problem:
I've downloaded a docker image using "docker pull bradrydzewski/mongodb:2.4"
and when I wanted to run it I did a "docker run bradrydzewski/mongodb" as the image name was named like that, and I saw docker pulling another image (the size was different), so I hit Ctrl+C thinking to going kill the operation.

However a ps fax showed me dockerd was still downloading something, certainly image bradrydzewski/mongodb

Version-Release number of selected component (if applicable):
docker-io-0.7.0-14.fc20.x86_64

How reproducible:
100 %

Steps to Reproduce:
1. docker pull bradrydzewski/mongodb:2.4 (let the complete operation happens)
2. docker run bradrydzewski/mongodb, and hit ctrl+c after few seconds

Actual results:
Dockerd still download image

Expected results:
docker client should ask Dockerd to cancel the download of the image

Comment 1 Marek Goldmann 2014-01-02 10:56:16 UTC
This was reported upstream: https://github.com/dotcloud/docker/issues/3136

Comment 2 Daniel Walsh 2014-06-27 15:38:33 UTC
Currently being discussed here.

https://github.com/dotcloud/docker/issues/3115

Comment 3 Daniel Walsh 2014-06-27 15:41:12 UTC
Looks like there is a partial fix but it does not look like it addresses this issue.

Comment 8 Daniel Walsh 2015-04-15 12:18:25 UTC
This needs to be fixed upstream.  Not something we need to be working on.


Note You need to log in before you can comment on or make changes to this bug.