Bug 104676 - Unable to compile kernel with shipped config file
Unable to compile kernel with shipped config file
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ernie Petrides
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-18 15:52 EDT by Stephen Drye
Modified: 2007-11-30 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-03 20:07:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Drye 2003-09-18 15:52:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507

Description of problem:
When I load the shipped configs/kernel-2.4.21-i686.config, save&exit and
"make dep bzImage", the kernel compile fails.

It seems to be related to the IPSec options under networking config.

The error is:
/usr/src/linux-2.4.21-1.1931.2.423.ent/include/net/esp.h:49:
'crypto_hmac_update' undeclared (first use in this function)
make[3]: *** [xfrm_algo.o] Error 1


Version-Release number of selected component (if applicable):
kernel-source-2.4.21-1.1931.2.423.ent

How reproducible:
Always

Steps to Reproduce:
1.make mrproper
2.make xconfig
3.load the kernel-2.4.21-i686.config
4. save and exit
5. make dep
6. make bzImage


Additional info:
Comment 1 Arjan van de Ven 2003-09-18 16:06:26 EDT
does it work if you do make oldconfig after make xconfig ?
(if so, make xconfig gets some dependency resolution wrong)
Comment 2 Stephen Drye 2003-09-18 16:50:44 EDT
I did:
- make mrproper
- make xconfig
- loaded the config
- save & exit
- make oldconfig (here it prompted me for a few items, which I just used the
default for)
- make dep

make bzImage completed successfully this time.
Comment 3 Ernie Petrides 2005-06-03 20:07:31 EDT
Hi, Stephen.

The correct build-from-source procedure is as follows:

  1) make mrproper
  2) cp configs/kernel-2.4.21-i686-smp.config .config  [or some other config]
  3) make oldconfig
  4) make dep
  5) make bzImage
  6) make modules

Using "make xconfig" is not supported.

Cheers.  -ernie

Note You need to log in before you can comment on or make changes to this bug.