Bug 1046858 - SELinux is preventing /usr/sbin/bumblebeed from 'execute' accesses on the file /usr/bin/kmod.
Summary: SELinux is preventing /usr/sbin/bumblebeed from 'execute' accesses on the fil...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:5dc6b9cd643ed3f6ee693ebd0f3...
: 1046854 1046856 1046859 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-27 07:11 UTC by Sayak Sarkar
Modified: 2014-01-16 07:11 UTC (History)
9 users (show)

Fixed In Version: selinux-policy-3.12.1-116.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-16 07:11:27 UTC
Type: ---


Attachments (Terms of Use)

Description Sayak Sarkar 2013-12-27 07:11:13 UTC
Description of problem:
SELinux is preventing /usr/sbin/bumblebeed from 'execute' accesses on the file /usr/bin/kmod.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that bumblebeed should be allowed execute access on the kmod file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep bumblebeed /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:bumblebee_t:s0
Target Context                system_u:object_r:insmod_exec_t:s0
Target Objects                /usr/bin/kmod [ file ]
Source                        bumblebeed
Source Path                   /usr/sbin/bumblebeed
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           bumblebee-3.2.1-4.fc20.x86_64
Target RPM Packages           kmod-15-1.fc20.x86_64
Policy RPM                    selinux-policy-3.12.1-106.fc20.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.12.5-302.fc20.x86_64 #1 SMP Tue
                              Dec 17 20:42:32 UTC 2013 x86_64 x86_64
Alert Count                   9
First Seen                    2013-12-19 18:30:36 IST
Last Seen                     2013-12-27 12:28:33 IST
Local ID                      ac76de18-10ea-404f-b2ba-38317c4dea5a

Raw Audit Messages
type=AVC msg=audit(1388127513.842:581): avc:  denied  { execute } for  pid=6054 comm="bumblebeed" name="kmod" dev="dm-1" ino=1180644 scontext=system_u:system_r:bumblebee_t:s0 tcontext=system_u:object_r:insmod_exec_t:s0 tclass=file


type=SYSCALL msg=audit(1388127513.842:581): arch=x86_64 syscall=access success=yes exit=0 a0=4094e0 a1=1 a2=14e51c0 a3=34ce53c680 items=0 ppid=1 pid=6054 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=bumblebeed exe=/usr/sbin/bumblebeed subj=system_u:system_r:bumblebee_t:s0 key=(null)

Hash: bumblebeed,bumblebee_t,insmod_exec_t,file,execute

Additional info:
reporter:       libreport-2.1.10
hashmarkername: setroubleshoot
kernel:         3.12.5-302.fc20.x86_64
type:           libreport

Comment 1 Miroslav Grepl 2014-01-06 13:52:18 UTC
Has been added.

Comment 2 Miroslav Grepl 2014-01-06 14:31:12 UTC
*** Bug 1046859 has been marked as a duplicate of this bug. ***

Comment 3 Miroslav Grepl 2014-01-06 14:31:25 UTC
*** Bug 1046856 has been marked as a duplicate of this bug. ***

Comment 4 Miroslav Grepl 2014-01-06 14:31:40 UTC
*** Bug 1046854 has been marked as a duplicate of this bug. ***

Comment 5 squirem 2014-01-07 16:54:46 UTC
Description of problem:
My system:
ASUS N53S 
Fedora 20 x86-64
3.12.6-300.fc20.x86_64 Kernel
Intel Core i7-2670QM
NVIDIA Geforce 630M
I installed Fedora 20 and immediately updated all the packages using yum. My laptop uses the NVIDIA Optimus technology, which cannot be disabled via BIOS.

I've previously used Fedora 16 and followed this guide:
http://duxyng.wordpress.com/2012/01/26/finally-working-nvidia-optimus-on-fedora/
to get bumblebee working. The guide worked flawlessly and I was successfully able to do CUDA development on my laptop with no issues at all.

For my Fedora 20 installation, the dyxyng guide did not work. 
With that guide, I was able to start up the bumblebee daemon, but GNOME wouldn't load up when I reboot.

I then used this official guide:
https://fedoraproject.org/wiki/Bumblebee

Bumblebee almost seems to work using these instructions. 
The discrete graphics is disabled, and can be enabled to run CUDA applications. 
I've managed to install CUDA 5.5 and was able to compile all the samples, including those using the driver api (cuda.so in /usr/lib64/nvidia-bumblebee). 
However, when I run any kind of graphical application, such as glxgears or a CUDA nbody simulation (from the SDK), SELinux goes nuts and starts throwing up dozens of warnings, about 55 alerts per run.

CUDA applications that are not windowed work perfectly fine. 
I should also mention that when I used Fedora 16 with bumblebee, executing a CUDA application would result in a switch to the NVIDIA GPU, which was nice. 
In my current Fedora 20 installation, executing a CUDA application will not work without the optirun command. Without optirun being used, CUDA applications will simply fail because of a lack of GPU.

Additional info:
reporter:       libreport-2.1.10
hashmarkername: setroubleshoot
kernel:         3.12.6-300.fc20.x86_64
type:           libreport

Comment 6 aferrero 2014-01-08 13:43:15 UTC
Description of problem:
I has 2 graphic cards and use bulmblebee to switch between the two cards.

This problem occurs when starting the S.O.


Additional info:
reporter:       libreport-2.1.10
hashmarkername: setroubleshoot
kernel:         3.12.6-300.fc20.x86_64
type:           libreport

Comment 7 Miroslav Grepl 2014-01-08 13:56:35 UTC
There are updated packages

http://koji.fedoraproject.org/koji/buildinfo?buildID=488941

for now.

Comment 8 Fedora Update System 2014-01-13 22:56:54 UTC
selinux-policy-3.12.1-116.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/selinux-policy-3.12.1-116.fc20

Comment 9 Fedora Update System 2014-01-15 05:58:30 UTC
Package selinux-policy-3.12.1-116.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.12.1-116.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-0806/selinux-policy-3.12.1-116.fc20
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2014-01-16 07:11:27 UTC
selinux-policy-3.12.1-116.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.