Bug 1046868 - SELinux is preventing /usr/sbin/httpd from 'search' accesses on the directory homepage.
Summary: SELinux is preventing /usr/sbin/httpd from 'search' accesses on the directory...
Keywords:
Status: CLOSED DUPLICATE of bug 1046867
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:357aa329555deda8112da02113f...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-27 07:23 UTC by Sayak Sarkar
Modified: 2014-01-03 19:43 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-03 19:43:29 UTC
Type: ---


Attachments (Terms of Use)

Description Sayak Sarkar 2013-12-27 07:23:13 UTC
Description of problem:
SELinux is preventing /usr/sbin/httpd from 'search' accesses on the directory homepage.

*****  Plugin catchall_boolean (47.5 confidence) suggests   ******************

If you want to allow httpd to read user content
Then you must tell SELinux about this by enabling the 'httpd_read_user_content' boolean.
You can read 'user_selinux' man page for more details.
Do
setsebool -P httpd_read_user_content 1

*****  Plugin catchall_boolean (47.5 confidence) suggests   ******************

If you want to allow httpd to read home directories
Then you must tell SELinux about this by enabling the 'httpd_enable_homedirs' boolean.
You can read 'user_selinux' man page for more details.
Do
setsebool -P httpd_enable_homedirs 1

*****  Plugin catchall (6.38 confidence) suggests   **************************

If you believe that httpd should be allowed search access on the homepage directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep /usr/sbin/httpd /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:httpd_t:s0
Target Context                unconfined_u:object_r:user_home_t:s0
Target Objects                homepage [ dir ]
Source                        /usr/sbin/httpd
Source Path                   /usr/sbin/httpd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           httpd-2.4.6-2.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-74.4.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.11.1-200.fc19.x86_64 #1 SMP Sat
                              Sep 14 15:04:51 UTC 2013 x86_64 x86_64
Alert Count                   6
First Seen                    2013-09-30 04:58:01 IST
Last Seen                     2013-09-30 04:59:48 IST
Local ID                      4dec32c3-6346-4f35-9056-469af1253156

Raw Audit Messages
type=AVC msg=audit(1380497388.871:588): avc:  denied  { search } for  pid=3832 comm="/usr/sbin/httpd" name="homepage" dev="dm-1" ino=1978373 scontext=system_u:system_r:httpd_t:s0 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=dir


type=SYSCALL msg=audit(1380497388.871:588): arch=x86_64 syscall=stat success=no exit=EACCES a0=7f3bf6f5e058 a1=7fff2c62cce0 a2=7fff2c62cce0 a3=7f3beadce152 items=0 ppid=1993 pid=3832 auid=4294967295 uid=48 gid=48 euid=48 suid=48 fsuid=48 egid=48 sgid=48 fsgid=48 ses=4294967295 tty=(none) comm=/usr/sbin/httpd exe=/usr/sbin/httpd subj=system_u:system_r:httpd_t:s0 key=(null)

Hash: /usr/sbin/httpd,httpd_t,user_home_t,dir,search

Additional info:
reporter:       libreport-2.1.10
hashmarkername: setroubleshoot
kernel:         3.12.5-302.fc20.x86_64
type:           libreport

Comment 1 Daniel Walsh 2014-01-03 19:43:29 UTC

*** This bug has been marked as a duplicate of bug 1046867 ***


Note You need to log in before you can comment on or make changes to this bug.