Bug 1047007 - Update extras/Ubuntu with latest upstart jobs from semiosis' PPA
Summary: Update extras/Ubuntu with latest upstart jobs from semiosis' PPA
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: scripts
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Ric Wheeler
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-28 05:15 UTC by Louis Zuckerman
Modified: 2014-04-17 13:15 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.4.3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-04-17 13:15:17 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 765014 None None None Never

Description Louis Zuckerman 2013-12-28 05:15:11 UTC
Not a bug.

I am submitting a patch with updated Ubuntu upstart job configs and wanted a BZ ID to reference.

Thank you.

Comment 1 Anand Avati 2013-12-28 05:35:35 UTC
REVIEW: http://review.gluster.org/6611 (Updating extras/Ubuntu with latest upstart configs (BUG: 1047007)) posted (#1) for review on master by Louis Zuckerman (me@louiszuckerman.com)

Comment 2 Louis Zuckerman 2013-12-28 05:55:12 UTC
I would like this patch to be merged into release branches 3.4 & 3.5 and included in both upcoming releases, 3.4.2 & 3.5.0.  Please advise if there's anything else I can do to help make that happen.

Thanks again.

Comment 3 Anand Avati 2013-12-30 07:04:02 UTC
COMMIT: http://review.gluster.org/6611 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit efcfb60f87f6d5ce4aa8ec7f4cd3bbe51a87f538
Author: Louis Zuckerman <me@louiszuckerman.com>
Date:   Sat Dec 28 00:34:47 2013 -0500

    Updating extras/Ubuntu with latest upstart configs (BUG: 1047007)
    
    Change-Id: Ia769589f6af1d7ca3577185fd4c56eb9f43b3e2e
    BUG: 1047007
    Signed-off-by: Louis Zuckerman <me@louiszuckerman.com>
    Reviewed-on: http://review.gluster.org/6611
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 4 Vijay Bellur 2013-12-30 07:06:00 UTC
(In reply to Louis Zuckerman from comment #2)
> I would like this patch to be merged into release branches 3.4 & 3.5 and
> included in both upcoming releases, 3.4.2 & 3.5.0.  Please advise if there's
> anything else I can do to help make that happen.
> 


Thanks for this patch. Would it be possible to send backports on release-3.4 and release-3.5 branches?

Comment 5 Anand Avati 2014-01-01 15:55:43 UTC
REVIEW: http://review.gluster.org/6621 (Updating extras/Ubuntu with latest upstart configs (BUG: 1047007)) posted (#1) for review on release-3.5 by Vijay Bellur (vbellur@redhat.com)

Comment 6 Anand Avati 2014-01-01 16:00:15 UTC
REVIEW: http://review.gluster.org/6622 (Updating extras/Ubuntu with latest upstart configs (BUG: 1047007)) posted (#1) for review on release-3.4 by Vijay Bellur (vbellur@redhat.com)

Comment 7 Anand Avati 2014-01-02 00:56:09 UTC
COMMIT: http://review.gluster.org/6621 committed in release-3.5 by Vijay Bellur (vbellur@redhat.com) 
------
commit c970913994b4c0d5f75b1e5e8e7913a90e45b111
Author: Louis Zuckerman <me@louiszuckerman.com>
Date:   Sat Dec 28 00:34:47 2013 -0500

    Updating extras/Ubuntu with latest upstart configs (BUG: 1047007)
    
    Change-Id: Ia769589f6af1d7ca3577185fd4c56eb9f43b3e2e
    BUG: 1047007
    Signed-off-by: Louis Zuckerman <me@louiszuckerman.com>
    Reviewed-on: http://review.gluster.org/6611
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
    Reviewed-on: http://review.gluster.org/6621

Comment 8 Anand Avati 2014-01-02 00:58:32 UTC
COMMIT: http://review.gluster.org/6622 committed in release-3.4 by Vijay Bellur (vbellur@redhat.com) 
------
commit bf770361e9e7121f2ba1524ba02f41fbf12d44e8
Author: Louis Zuckerman <me@louiszuckerman.com>
Date:   Sat Dec 28 00:34:47 2013 -0500

    Updating extras/Ubuntu with latest upstart configs (BUG: 1047007)
    
    Change-Id: Ia769589f6af1d7ca3577185fd4c56eb9f43b3e2e
    BUG: 1047007
    Signed-off-by: Louis Zuckerman <me@louiszuckerman.com>
    Reviewed-on: http://review.gluster.org/6611
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
    Reviewed-on: http://review.gluster.org/6622

Comment 10 Niels de Vos 2014-04-17 13:15:17 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.4.3, please reopen this bug report.

glusterfs-3.4.3 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should already be or become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

The fix for this bug likely to be included in all future GlusterFS releases i.e. release > 3.4.3. In the same line the recent release i.e. glusterfs-3.5.0 [3] likely to have the fix. You can verify this by reading the comments in this bug report and checking for comments mentioning "committed in release-3.5".

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/5978
[2] http://news.gmane.org/gmane.comp.file-systems.gluster.user
[3] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137


Note You need to log in before you can comment on or make changes to this bug.