Bug 104711 - (NET PCNET32) devices fail to detect link properly
Summary: (NET PCNET32) devices fail to detect link properly
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Garzik
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-19 15:49 UTC by Jp Robinson
Modified: 2013-07-03 02:14 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-14 17:17:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jp Robinson 2003-09-19 15:49:36 UTC
Description of problem:
PCnet32 devices fail to properly detect link and ifup with dhcp address. Can be
manually ifconfig'd. As a side effect, ethtool fails link detection as well.

Works during install with no discernable problems.

Also applies to Sveren

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Install with dhcp address
2.Boot up, no link when it does an ifup/network start

    
Actual results:
No link present

Expected results:


Additional info:
This is needed for vmware, as this is the network devices they use.

Comment 1 Jp Robinson 2003-09-29 19:35:57 UTC
As a note, I can comment out /etc/sysconfig/network-scripts/network-functions
"check_link_down()" function (except a return 1) and it comes up sucessfully. 

Comment 2 Omkhar Arasaratnam 2003-10-03 17:02:35 UTC
Fails with Taroon-RC1 as well

Comment 3 Omkhar Arasaratnam 2003-10-03 17:28:37 UTC
Sorry make that RC-2

Seems when we were sent the ISO's they were missnamed

Comment 4 Jp Robinson 2003-10-03 17:35:22 UTC
Agreed, tested there as well. My testing is currently happening in vmware.

Comment 5 Omkhar Arasaratnam 2003-10-03 17:39:28 UTC
so is mine :), I'll try and dig up a pcnet32 card, but the only ones I have in
the lab are e1000 or broadcom

Comment 6 Jp Robinson 2003-10-03 18:29:28 UTC
As a proposed fix, I would reccomend adding the following at line 246 in
network-functions:
if [ `cat /etc/modules.conf|grep $1|cut -d " " -f 3` = "pcnet32" ] 
 then 
   return 1
fi


That should eliminate the check and allow it to come up as normal.

Comment 7 Omkhar Arasaratnam 2003-10-03 18:39:21 UTC
how about

if [ `/bin/lsmod| cut -f1 -d " "` = "pcnet32" ] 
 then 
   return 1
fi

since it would only matter if the device were loaded

problem is still that it only works if the driver is "modulized". what if it is
part of the kernel? can we get the code fixed?

Comment 8 Billy Foss 2003-12-03 15:32:54 UTC
Problem also described in 100527
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=100527


Comment 9 Thomas M Steenholdt 2004-02-20 14:49:26 UTC
please check bug #100527, i submitted a patch for the kernel that
fixes this problem but would like to get some feedback on wether it
works or not!

Comment 10 Thomas M Steenholdt 2004-02-27 13:52:03 UTC
this is a duplicate of the issue described in bug #100527 albeit for
another product!

Comment 11 Thomas M Steenholdt 2004-02-29 20:51:40 UTC
fixed in rawhide kernel 2.6.3-1.116 - tested and works for me


Note You need to log in before you can comment on or make changes to this bug.