Bug 104718 - redhat-config-date should call "timeconfig" if ${DISPLAY} isn't set.
redhat-config-date should call "timeconfig" if ${DISPLAY} isn't set.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-date (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
: FutureFeature
: 98516 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-19 13:45 EDT by Jesse Keating
Modified: 2007-04-18 12:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-19 15:05:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2003-09-19 13:45:08 EDT
Description of problem:
redhat-config-date is an X11 application, but the package itself doesn't depend
on X11, mostly because it also includes "timeconfig" which is an ncurses app. 
This can confuse uses trying to use redhat-config-date w/out X11 installed,
especially since it seems that redhat-config-date doesn't have a "--help"
option.  To counter this, can't redhat-config-time call "timeconfig" if
${DISPLAY} isn't set?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install redhat-config-date, w/out X11 installed
2. Try to run redhat-config-date, get error about no X
3. Try to run redhat-config-date --help, still get error message.
    

Actual Results:  Error messages about no X

Expected Results:  Fall back to timeconfig.

Additional info:
Comment 1 Jesse Keating 2003-09-19 13:46:56 EDT
Another option would be to split "timeconfig" out of the package, and making
r-c-date depend on say pygtk2.
Comment 2 Brent Fox 2003-09-19 15:05:29 EDT
I've changed it to just call 'timeconfig' if the GUI can't be started up. 
Should be fixed in redhat-config-users-1.5.22-1.  Thanks for your report.
Comment 3 Brent Fox 2003-10-15 17:43:14 EDT
*** Bug 98516 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.