Bug 104724 - top occasionally consumes 1 CPU
top occasionally consumes 1 CPU
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: procps (Show other bugs)
2.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Smetana
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-19 16:04 EDT by aaron bos
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:24:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description aaron bos 2003-09-19 16:04:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)

Description of problem:
At random intervals, maybe once a month across 30 servers, I'm alerted to high 
CPU utilization on a server, and find a "top" command using 100% of a CPU.  
Typically the command has been running for several hours, and is running as a 
non-root user.


Version-Release number of selected component (if applicable):
procps-2.0.7-11

How reproducible:
Couldn't Reproduce

Steps to Reproduce:
1.  Can't reproduce.  Happens randomly, infrequently.
2.
3.
    

Additional info:

Servers are Compaq DL360-G2s w/ 2 CPUs, 4 GB RAM.  Running 2.4.9-e.9smp.
Comment 1 Daniel Walsh 2004-02-11 08:43:16 EST
Can you reproduce this using 3.1.15 version?

Dan
Comment 2 Albert Cahalan 2004-07-20 13:33:19 EDT
It appears that sometimes the kernel will fail to sent SIGHUP
to the foreground process group when the session leader dies.
I've seen it after doing "su" in an xterm and then killing
the xterm. This is one way to cause the problem you're seeing.
Comment 3 Kurtis D. Rader 2005-02-21 17:20:33 EST
This also happens with procps-2.0.17-10 from RHEL AS 3 U3.

The primary problem is that top(1) doesn't terminate when a read of stding
returns an EOF indication. Specifically, after a "read(0, buf, 1)" returns
zero top(1) continues running. The secondary problem is that certain login
shells (such as the real ksh, not pdksh) don't propagate SIGHUP correctly.
Comment 4 RHEL Product and Program Management 2007-10-19 15:24:05 EDT
This bug is filed against RHEL2.1, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products.  Since
this bug does not meet that criteria, it is now being closed.

For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/

If you feel this bug is indeed mission critical, please contact your
support representative.  You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.