Bug 1047290 - SELinux is preventing /usr/libexec/postfix/smtpd from using the 'execstack' accesses on a process.
Summary: SELinux is preventing /usr/libexec/postfix/smtpd from using the 'execstack' a...
Keywords:
Status: CLOSED DUPLICATE of bug 1045699
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:1943946bad4e54c7212b23b10af...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-30 10:22 UTC by Nicolas Mailhot
Modified: 2014-01-02 21:32 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-02 21:32:48 UTC
Type: ---


Attachments (Terms of Use)

Description Nicolas Mailhot 2013-12-30 10:22:54 UTC
Description of problem:
SELinux is preventing /usr/libexec/postfix/smtpd from using the 'execstack' accesses on a process.

*****  Plugin catchall (100. confidence) suggests   **************************

If vous pensez que smtpd devrait être autorisé à accéder execstack sur les processus étiquetés postfix_smtpd_t par défaut.
Then vous devriez rapporter ceci en tant qu'anomalie.
Vous pouvez générer un module de stratégie local pour autoriser cet accès.
Do
autoriser cet accès pour le moment en exécutant :
# grep smtpd /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:postfix_smtpd_t:s0
Target Context                system_u:system_r:postfix_smtpd_t:s0
Target Objects                 [ process ]
Source                        smtpd
Source Path                   /usr/libexec/postfix/smtpd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-10.fc21.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.13.0-0.rc3.git5.1.fc21.x86_64 #1
                              SMP Sat Dec 14 15:06:01 UTC 2013 x86_64 x86_64
Alert Count                   525
First Seen                    2013-12-30 02:35:04 CET
Last Seen                     2013-12-30 11:19:37 CET
Local ID                      b8927037-1c47-4e01-a96e-07d53f84c9f0

Raw Audit Messages
type=AVC msg=audit(1388398777.155:81993): avc:  denied  { execstack } for  pid=30658 comm="smtpd" scontext=system_u:system_r:postfix_smtpd_t:s0 tcontext=system_u:system_r:postfix_smtpd_t:s0 tclass=process


type=AVC msg=audit(1388398777.155:81993): avc:  denied  { execmem } for  pid=30658 comm="smtpd" scontext=system_u:system_r:postfix_smtpd_t:s0 tcontext=system_u:system_r:postfix_smtpd_t:s0 tclass=process


Hash: smtpd,postfix_smtpd_t,postfix_smtpd_t,process,execstack

Additional info:
reporter:       libreport-2.1.10
hashmarkername: setroubleshoot
kernel:         3.13.0-0.rc3.git5.1.fc21.x86_64
type:           libreport

Comment 1 Daniel Walsh 2014-01-02 21:32:48 UTC

*** This bug has been marked as a duplicate of bug 1045699 ***


Note You need to log in before you can comment on or make changes to this bug.