Bug 1047293 - SELinux is preventing /usr/libexec/postfix/qmgr from using the 'execstack' accesses on a process.
Summary: SELinux is preventing /usr/libexec/postfix/qmgr from using the 'execstack' ac...
Keywords:
Status: CLOSED DUPLICATE of bug 1045699
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:32999f8d9b6d35f6aca096dd7f6...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-30 10:23 UTC by Nicolas Mailhot
Modified: 2014-01-02 21:33 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-02 21:33:05 UTC
Type: ---


Attachments (Terms of Use)

Description Nicolas Mailhot 2013-12-30 10:23:35 UTC
Description of problem:
SELinux is preventing /usr/libexec/postfix/qmgr from using the 'execstack' accesses on a process.

*****  Plugin catchall (100. confidence) suggests   **************************

If vous pensez que qmgr devrait être autorisé à accéder execstack sur les processus étiquetés postfix_qmgr_t par défaut.
Then vous devriez rapporter ceci en tant qu'anomalie.
Vous pouvez générer un module de stratégie local pour autoriser cet accès.
Do
autoriser cet accès pour le moment en exécutant :
# grep qmgr /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:postfix_qmgr_t:s0
Target Context                system_u:system_r:postfix_qmgr_t:s0
Target Objects                 [ process ]
Source                        qmgr
Source Path                   /usr/libexec/postfix/qmgr
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           postfix-2.10.2-2.fc21.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-10.fc21.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.13.0-0.rc3.git5.1.fc21.x86_64 #1
                              SMP Sat Dec 14 15:06:01 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-12-30 11:19:43 CET
Last Seen                     2013-12-30 11:19:43 CET
Local ID                      e03a575c-3055-42d0-89b7-7719a270eff8

Raw Audit Messages
type=AVC msg=audit(1388398783.83:82002): avc:  denied  { execstack } for  pid=30820 comm="qmgr" scontext=system_u:system_r:postfix_qmgr_t:s0 tcontext=system_u:system_r:postfix_qmgr_t:s0 tclass=process


type=AVC msg=audit(1388398783.83:82002): avc:  denied  { execmem } for  pid=30820 comm="qmgr" scontext=system_u:system_r:postfix_qmgr_t:s0 tcontext=system_u:system_r:postfix_qmgr_t:s0 tclass=process


type=SYSCALL msg=audit(1388398783.83:82002): arch=x86_64 syscall=mprotect success=yes exit=0 a0=7fffa1c92000 a1=1000 a2=1000007 a3=0 items=0 ppid=30818 pid=30820 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=qmgr exe=/usr/libexec/postfix/qmgr subj=system_u:system_r:postfix_qmgr_t:s0 key=(null)

Hash: qmgr,postfix_qmgr_t,postfix_qmgr_t,process,execstack

Additional info:
reporter:       libreport-2.1.10
hashmarkername: setroubleshoot
kernel:         3.13.0-0.rc3.git5.1.fc21.x86_64
type:           libreport

Comment 1 Daniel Walsh 2014-01-02 21:33:05 UTC

*** This bug has been marked as a duplicate of bug 1045699 ***


Note You need to log in before you can comment on or make changes to this bug.