Bug 104734 - Building new kernel modules crash when reaching the loop and network block devices (loop.o and nbd.o)
Building new kernel modules crash when reaching the loop and network block d...
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-19 17:59 EDT by fbadescu
Modified: 2007-04-18 12:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:41:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description fbadescu 2003-09-19 17:59:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
I have tried to compile a custom kernel for my system. The configuration and
building of the kernel works OK. However, when I try to compile the modules, the
process stops at building the loop.o and nbd.o modules, with the following error:

loop.c: In function 'loop_change_fd':
loop.c:761: warning: label 'out_put_all' defined but not used
make[2]: *** [loop.o] Error 1
make[2]: Leaving directory '/usr/src/linux-2.4.20-20.9/drivers/block'
make[1]: *** [_modsubdir_block] Error 2
make[1]: Leaving directory '/usr/src/linux-2.4.20-20.9/drivers/'
make: *** [_mod_drivers] Error 2
[root@my_computer linux-2.4.20-20.9]#

The kernel built goes OK if I build the two drivers (loop and nbd) into the kernel. 

I have tried to build the kernel on two different systems: an Athlon-based, and
a Pentium III - based.

Version-Release number of selected component (if applicable):
kernel-source-2.4.20-20.9

How reproducible:
Always

Steps to Reproduce:
1. make clean (make mrproper for the first time)
2. make menuconfig or make xconfig (it does not matter which one)
3. make dep
4. make bzImage
5. make modules
    

Actual Results:  The compiler stopped building the modules.

Expected Results:  make modules should complete. 

Additional info:

Athlon system:
Athlon 1GHz, 256 MB RAM, SCSI controller AHA-2940U2W, Seagate Cheetah 10k 9.5GB
hard disc, no IDE drives, SCSI CD-ROM

Pentium III system:
P-III 500 MHz, 256 MB RAM, SCSI controller Tekram DC-390U3D, Maxtor Atlas 10k,
36GB hard disc, Maxtor 20GB IDE hard disc, IDE and SCSI CD-ROM.

I have downloaded kernel source 2.4.22 from www.kernel.org, installed,  built
the kernel and modules, and installed them without a hitch. I am running the
2.4.22 kernel for about 3 weeks by now, without any problem (no system shutdown
during this time, either).
Comment 1 Bugzilla owner 2004-09-30 11:41:32 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.