Bug 1047373 - [pa_IN] Rename Punjabi Fonts to Gurmukhi script
[pa_IN] Rename Punjabi Fonts to Gurmukhi script
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lohit-punjabi-fonts (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-12-30 13:53 EST by A S Alam
Modified: 2014-03-11 04:13 EDT (History)
5 users (show)

See Also:
Fixed In Version: lohit-gurmukhi-fonts-2.91.0-2.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-11 04:13:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description A S Alam 2013-12-30 13:53:40 EST
Description of problem:
As fonts are for script, so it will be good if we change Punjabi Font name to "Gurmukhi" for clear confusion regarding Punjabi. As Punjabi is Language, but there are two or three Scripts for it to Write.

1 - Gurmukhi (Eastern Punjab)
2 - Shahmukhi (Arabic based) - Western Punjabi


Following is Reference from Unicode, where it is clearly mentioned as "Gurmukhi"
 http://www.unicode.org/charts/PDF/U0A00.pdf


Version-Release number of selected component (if applicable):
lohit-punjabi-fonts-2.5.3-3.fc20.noarch

How reproducible:


Steps to Reproduce:
1. yum list lohit-punjabi-fonts
2.
3.

Actual results:
 Lohit font name is "lohit punjabi fonts"

Expected results:
Font should renames as "Lohit-gurmukhi-fonts"

Additional info:
http://en.wikipedia.org/wiki/Punjabi_language
http://en.wikipedia.org/wiki/Gurmukh%C4%AB_alphabet


As fedora 20 released, so we have time before Fedora 21 to find and fix bugs if changes are included.
Comment 1 Pravin Satpute 2013-12-31 00:58:44 EST
I am agree with this. 

Since there are multiple scripts are used for Punjabi language i think in long term it will be good to use script name rather than language name.

AFAIK Gurumukhi script is only used for Punjabi language so having font name with script will not make much difference.


As you know we are working on Lohit2 project and planning for Lohit Punjabi next month, so we will release new Lohit Punjabi with Gurumukhi name.
Comment 2 Shriramana Sharma 2013-12-31 02:06:24 EST
Hello Pravin. I also agree for the change to use script name rather than language name. But please note that while linguistically the name is indeed Gur*u*mukhi with "u" after "r" (the meaning being "received from the mukha = mouth of the guru = teacher"), however in common nomenclature the name doesn't have "u" after "r". Even in Unicode standard it is called Gurmukhi as mentioned by OP and also on http://www.unicode.org/charts/. So I recommend to use Lohit Gurmukhi.
Comment 3 Pravin Satpute 2013-12-31 02:16:40 EST
Good catch. I was not aware of the meaning of script name Gurmukhi. Thanks for information.
Comment 4 Pravin Satpute 2014-03-11 04:13:15 EDT
Added new package with name : lohit-gurmukhi-fonts-2.91.0-2.fc21
available in rawhide.

Note You need to log in before you can comment on or make changes to this bug.