Bug 1047389 - cheese fails to start, prints error message "One or more needed GStreamer elements are missing: cluttervideosink"
Summary: cheese fails to start, prints error message "One or more needed GStreamer ele...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: cheese
Version: 20
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-30 21:26 UTC by Mark T. Kennedy
Modified: 2014-09-10 14:23 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-10 14:23:16 UTC
Type: Bug


Attachments (Terms of Use)
A list of cheese/clutter/gstreamer rpm packages that are installed (3.05 KB, text/plain)
2013-12-30 21:26 UTC, Mark T. Kennedy
no flags Details
cheese stdout/stderr with DEBUGGING vars turned on (4.31 MB, text/plain)
2014-01-01 15:28 UTC, Mark T. Kennedy
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Bugzilla 721277 0 None None None Never

Description Mark T. Kennedy 2013-12-30 21:26:29 UTC
Created attachment 843543 [details]
A list of cheese/clutter/gstreamer rpm packages that are installed

Description of problem:

cheese fails to start with the error message "One or more needed GStreamer elements are missing: cluttervideosink".


Version-Release number of selected component (if applicable):


How reproducible:

always.


Steps to Reproduce:
1. run cheese
2.
3.

Actual results:

the cheese GUI appears with the above error message.


Expected results:

the normal cheese GUI should appear.


Additional info:

i thought i had every gstreamer plugin rpm installed.  i've attached the relevant package info.

Comment 1 Hans de Goede 2013-12-31 09:10:26 UTC
Hi,

Thanks for the bug report, in order to help you further we need some more info.

Does: "ldd -r /usr/lib64/gstreamer-1.0/libgstclutter.so" give any errors ?

Do you have working 3d / opengl support ?

Regards,

Hans

Comment 2 Mark T. Kennedy 2013-12-31 14:47:12 UTC
re: libclutter -no errors from 'ldd -r'.

re: working 3d / opengl - how do i test?  i'm using a four-display system where the displays are knitted together with xinerama.  kwin special effects, for example, won't work with that setup.  but cheese ran fine until recently.

Comment 3 Hans de Goede 2013-12-31 14:54:29 UTC
(In reply to Mark T. Kennedy from comment #2)
> re: libclutter -no errors from 'ldd -r'.
> 
> re: working 3d / opengl - how do i test?  i'm using a four-display system
> where the displays are knitted together with xinerama.  kwin special
> effects, for example, won't work with that setup. 

kwin special effects not working is a pretty good indicator that something is not working on your setup wrt 3D/opengl support.

> but cheese ran fine until recently.

I believe the clutter error you're getting is not due to a missing plugin, but due to the plugin failing to initialize, which is likely caused by it not liking your X / opengl setup. It is probably best to report a bug for this in the upstream clutter bugzilla:
https://bugzilla.gnome.org/enter_bug.cgi?product=clutter

Hopefully the upstream developers will be able to help debug this further.

Comment 4 Mark T. Kennedy 2013-12-31 14:57:18 UTC
no, this setup is unchanged. i've used it for 3-4 years.  cheese has *always* worked.  you're barking up the wrong tree.

Comment 5 Hans de Goede 2013-12-31 15:01:30 UTC
But cheese has not always used clutter, it used to use xvimagesink before, and in F-20 it switched from cluttervideosink to autocluttersink. This is very likely an incompatibility between clutter and your setup, please file a bug for this upstream where the proper people can help you further.

Comment 6 Mark T. Kennedy 2013-12-31 15:05:35 UTC
will do.

Comment 7 Hans de Goede 2014-01-01 08:44:12 UTC
Bug filed upstream, closing it here.

Comment 8 Mark T. Kennedy 2014-01-01 14:37:09 UTC
upstream said it is a packaging problem and referred it back to you.  i sent the same list of installed packages.  so now i'm high and dry (does that idiom translate?).

Comment 9 Hans de Goede 2014-01-01 15:16:04 UTC
Hi,

<sigh>

Can you please do from a terminal:
export GST_DEBUG=*:5
export GST_DEBUG_NO_COLOR=1
cheese &> log

And attach the generated log file here ?

Thanks,

Hans

Comment 10 Mark T. Kennedy 2014-01-01 15:28:32 UTC
Created attachment 844151 [details]
cheese stdout/stderr with DEBUGGING vars turned on

Comment 11 Mark T. Kennedy 2014-01-01 15:28:54 UTC
done.

Comment 12 Hans de Goede 2014-01-01 18:20:22 UTC
Hmm,

Can you try:

1) rm ~/.cache/gstreamer-1.0/registry.x86_64.bin
2) start cheese again
3) if 2 still fails try:
    gst-inspect-1.0 autocluttersink

And copy and paste any output here.

Comment 13 Mark T. Kennedy 2014-01-01 21:05:13 UTC
that worked.  when googling before contacting you, i found a suggestion to remove ~/.gstreamer-0.10/registry.x86_64.bin but that didn't work.  although something re-created that file.  in any event, thanks.

Comment 14 Brent R Brian 2014-02-26 12:02:46 UTC
rm ~/.cache/gstreamer-1.0/registry.x86_64.bin 

worked for me as well.

Comment 15 Shawn Starr 2014-03-08 16:30:36 UTC
I note I do see missing symbols:

Does: "ldd -r /usr/lib64/gstreamer-1.0/libgstclutter.so" give any errors ?

undefined symbol: wl_proxy_marshal_constructor  (/lib64/libclutter-1.0.so.0)

Looks like a wayland symbol... we're compiling against wrong ABI?

Comment 16 David King 2014-09-10 14:23:16 UTC
The original bug seems fixed by regenerating the GStreamer registry cache, as described in comment #13. In any case, the plugin cache is maintained by GStreamer, so if the problem persists, please file a bug against the GStreamer package.

(In reply to Shawn Starr from comment #15)
> I note I do see missing symbols:
> 
> Does: "ldd -r /usr/lib64/gstreamer-1.0/libgstclutter.so" give any errors ?
> 
> undefined symbol: wl_proxy_marshal_constructor  (/lib64/libclutter-1.0.so.0)

If this is still a problem (I do not have an F20 system to test, at the moment), please file a bug against the clutter package.


Note You need to log in before you can comment on or make changes to this bug.