Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1047421 - [RFE][nova]: Option to prevent dd on compute by deleting lv
Summary: [RFE][nova]: Option to prevent dd on compute by deleting lv
Keywords:
Status: CLOSED DUPLICATE of bug 1057371
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: Upstream M3
: 5.0 (RHEL 7)
Assignee: RHOS Maint
QA Contact: Ami Jeain
URL: https://blueprints.launchpad.net/nova...
Whiteboard: upstream_milestone_icehouse-3 upstrea...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-31 05:01 UTC by RHOS Integration
Modified: 2019-09-09 16:45 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-28 19:38:30 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description RHOS Integration 2013-12-31 05:01:14 UTC
Cloned from launchpad blueprint https://blueprints.launchpad.net/nova/+spec/lvm-clear-option.

Description:

To increase the performance of any instances I've tested in combination with libvirt and kvm some cases. KVM + Block devices seems to be the fastest but I've found a show stopper. Every time if i delete an instance nova will do a dd on the deleted volume and this takes a long time and consume a lot of power.

I've found in the code (https://github.com/openstack/nova/blob/master/nova/virt/libvirt/utils.py#L350) a comment to make this configurable as by cinder volumes (scure delete). This should be done otherwise is lvm on a compute in a production system in my cases not usable.

Cheers
Heiko


Specification URL (additional information):

None

Comment 2 Stephen Gordon 2014-01-28 19:38:30 UTC

*** This bug has been marked as a duplicate of bug 1057371 ***


Note You need to log in before you can comment on or make changes to this bug.