Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.

Bug 1047450

Summary: RFE: migration should work with q35 on rhel7
Product: Red Hat Enterprise Linux 7 Reporter: xhan
Component: qemu-kvmAssignee: Virtualization Maintenance <virt-maint>
Status: CLOSED DUPLICATE QA Contact: Virtualization Bugs <virt-bugs>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.0CC: acathrow, juzhang, michen, qzhang, virt-maint, xhan, xwei
Target Milestone: rcKeywords: FutureFeature
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-01-02 09:15:36 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description xhan 2013-12-31 07:37:12 UTC
Description of problem:

Test migration with -M pc-q35-rhel7.0.0. It could not work.
The error returned.
{"id": "0WuCCrQp", "error": {"class": "GenericError", "desc": "State blocked by non-migratable device '0000:00:1f.2/ich9_ahci'"}}

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-1.5.3-30.el7.x86_64
kernel-3.10.0-64.el7.x86_64


How reproducible:
100%

Steps to Reproduce:
1. start source guest  with -M pc-q35-rhel7.0.0
qemu-kvm \
    -name 'virt-tests-vm1'  \
    -sandbox off  \
    -M pc-q35-rhel7.0.0  \
    -nodefaults  \
    -vga qxl  \
    -global qxl-vga.vram_size=33554432 \
    -device intel-hda,bus=pcie.0,addr=02 \
    -device hda-duplex  \
    -monitor stdio \
    -qmp tcp:0:1234,server,nowait \
    -chardev socket,id=serial_id_serial0,path=/tmp/serial-serial0-20131227-193417-Utz1rgIo,server,nowait \
    -device isa-serial,chardev=serial_id_serial0 \
    -device virtio-serial-pci,id=virtio_serial_pci0,bus=pcie.0,addr=03  \
    -chardev socket,id=devvs,path=/tmp/virtio_port-vs-20131227-193417-Utz1rgIo,server,nowait \
    -device virtserialport,chardev=devvs,name=vs,id=vs,bus=virtio_serial_pci0.0  \
    -chardev socket,id=seabioslog_id_20131227-193417-Utz1rgIo,path=/tmp/seabios-20131227-193417-Utz1rgIo,server,nowait \
    -device isa-debugcon,chardev=seabioslog_id_20131227-193417-Utz1rgIo,iobase=0x402 \
    -device nec-usb-xhci,id=usb1,bus=pcie.0,addr=04 \
    -drive id=drive_image1,if=none,cache=unsafe,snapshot=off,aio=native,file=win2012r2-64-virtio.qcow2 \
    -device virtio-blk-pci,id=image1,drive=drive_image1,bootindex=0,bus=pcie.0,addr=05 \
    -device virtio-net-pci,mac=9a:83:84:85:86:87,id=idQ7Lzdx,netdev=idclbKA4,bus=pcie.0,addr=06  \
    -netdev tap,id=idclbKA4,vhost=on,script=qemu-ifup-switch  \
    -m 4096  \
    -smp 4,maxcpus=4,cores=2,threads=1,sockets=2  \
    -cpu 'SandyBridge' \
    -drive id=drive_cd1,if=none,snapshot=off,aio=native,media=cdrom,file=winutils.iso \
    -device ide-cd,id=cd1,drive=drive_cd1,bootindex=1,bus=ide.0,unit=0 \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1  \
    -spice port=3000,password=123456,addr=0,tls-port=3200,x509-dir=/tmp/spice_x509d,tls-channel=main,tls-channel=inputs,image-compression=auto_glz,zlib-glz-wan-compression=auto,streaming-video=all,agent-mouse=on,playback-compression=on,ipv4  \
    -rtc base=localtime,clock=host,driftfix=slew  \
    -boot order=cdn,once=c,menu=off \
    -enable-kvm

2. start destination guest with "-incoming tcp:0:5200 "

3. in source guest qmp session, launch migration
   {"execute": "client_migrate_info", "arguments": {"cert-subject": "\"C=CZ,L=BRNO,O=SPICE,CN=my Server10.66.11.230\"", "hostname": "10.66.11.230", "protocol": "spice", "port": 3001, "tls-port": 3201}, "id": "2pdjXX2d"}
  
{"execute": "migrate", "arguments": {"uri": "tcp:localhost:5200", "blk": false, "inc": false}, "id": "0WuCCrQp"}

Actual results:
The following error returns.
{"id": "0WuCCrQp", "error": {"class": "GenericError", "desc": "State blocked by non-migratable device '0000:00:1f.2/ich9_ahci'"}}

Expected results:
migration should work with q35 guests.


Additional info:

Comment 2 Xiaoqing Wei 2013-12-31 09:04:32 UTC
could be dup to https://bugzilla.redhat.com/show_bug.cgi?id=901631#c6 ?

Comment 3 Xiaoqing Wei 2014-01-02 09:15:36 UTC

*** This bug has been marked as a duplicate of bug 901631 ***

Comment 4 Red Hat Bugzilla 2023-09-14 01:56:13 UTC
The needinfo request[s] on this closed bug have been removed as they have been unresolved for 1000 days