Bug 1047570 - python3-webob1 prevents yum upgrade
Summary: python3-webob1 prevents yum upgrade
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-webob
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ricky Zhou
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-31 21:04 UTC by John Schmitt
Modified: 2014-03-07 06:36 UTC (History)
4 users (show)

Fixed In Version: python-webob-1.2.3-8.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-07 06:26:56 UTC


Attachments (Terms of Use)

Description John Schmitt 2013-12-31 21:04:25 UTC
Transaction check error:

  file /usr/lib/python3.3/site-packages/WebOb-1.2.3-py3.3.egg from install of python3-webob1.2-1.2.3-6.fc20.noarch conflicts with file from package python3-webob1.2-1.2.3-3.fc19.noarch

Comment 1 Toshio Ernie Kuratomi 2014-01-06 21:22:07 UTC
Analyzed and found that the root cause is that the updated python-setuptools in F20+ installs zipped eggs instead of unzipped eggs.  This causes problems for rpm which cannot replace a directory with a file.  The workaround is to use easy_install -Z when installing the egg.  I'll get the packaging guidelines updated to use that.

However, in looking at this I also noticed that python-webob1.2 is retired in f20.  Looks like the Obsoletes in the python-webob package is referencing too early a version of python-webob1.2  We should be able to fix that with an update to python-webob.  (to have Obsoletes: python-webob <  1.2.3-7 )

Comment 2 Fedora Update System 2014-01-06 22:24:18 UTC
python-webob-1.2.3-8.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/python-webob-1.2.3-8.fc20

Comment 3 Fedora Update System 2014-01-06 22:24:27 UTC
python-webob-1.2.3-8.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-webob-1.2.3-8.fc19

Comment 4 Fedora Update System 2014-01-07 09:41:42 UTC
Package python-webob-1.2.3-8.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-webob-1.2.3-8.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-0306/python-webob-1.2.3-8.fc20
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2014-03-07 06:26:56 UTC
python-webob-1.2.3-8.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2014-03-07 06:36:55 UTC
python-webob-1.2.3-8.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.