This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 104767 - RFE: please include ACPI compatible software suspend support
RFE: please include ACPI compatible software suspend support
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-20 15:30 EDT by Phillip Heller
Modified: 2015-01-04 17:03 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-26 13:58:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Phillip Heller 2003-09-20 15:30:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030728
Mozilla Firebird/0.6.1

Description of problem:
Certain laptops require ACPI support, and since ACPI and APM are mutually
exclusive, an alternative suspend method is required.

Please include the swsup kernel patches and related hibernation/suspend scripts.

http://swsusp.sourceforge.net


Version-Release number of selected component (if applicable):
kernel-2.4.20-20.9

How reproducible:
Always

Steps to Reproduce:
1. Laptops utilizing ACPI power management cannot use apm suspend functionality.

    

Additional info:
Comment 1 Dave Jones 2003-09-20 20:25:14 EDT
swsusp isn't being considered for inclusion in any 2.4 based Red Hat kernel at
this time, and is unlikely to change.
Comment 2 Aleksey Nogin 2003-12-10 03:34:54 EST
Rawhide includes a 2.6 pre-release now (without swsusp enabled). Time
to revisit this?

P.S. BTW, I am using swsusp-enabled kernel RPMs from
ftp://ftp.mat.univie.ac.at/pub/rpm - they work fine for me.
Comment 3 Dave Jones 2004-02-18 07:44:56 EST
swsusp isn't going to happen for FC2 either, due to concerns of code
quality. (And the fact that there's 3 half-arsed suspend solutions
instead of one good one right now).

CONFIG_ACPI_SLEEP=y in the current rawhide kernels, which some people
claim is enough for them, whilst others aren't having much luck with
it, so it's uncertain whether or not it'll be staying for the final
FC2 release.
Comment 4 Aleksey Nogin 2004-05-18 11:52:47 EDT
Hopefully this can finally happen for FC3. BTW, I have been
recompiling Raw Hide kernels with CONFIG_SOFTWARE_SUSPEND=y for a few
months now and after the 4G/4G split related problems were fixed, it
have been working perfectly.
Comment 5 Warren Togami 2004-06-14 21:26:42 EDT
Arjan said something about any software suspend implementation as
being highly problematic.  While it may work for you, it would be
dangerous to enable for all users.
Comment 6 Gerald Teschl 2004-06-15 10:57:26 EDT
Unless you enable it, it will do nothing. So if a user enables it,
the user knows what he/she is doing. So I don't see the danger,
its not like if you press the red button your computer will self
destruct;-)
Comment 7 Dave Jones 2004-10-26 13:58:38 EDT
your "if a user enables it, the user knows what he/she is doing"
is completely unfounded, given past experiences.
end-users see functionality, and they try it.

In the case of swsusp, this may work, it may not.
Personally, I'd rather not risk my data to this code, so it's staying
off until a miracle happens upstream.

Note You need to log in before you can comment on or make changes to this bug.