Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1047708 - [abrt] midori-0.5.5-2.fc20: Process /usr/bin/midori was killed by signal 4 (SIGILL)
Summary: [abrt] midori-0.5.5-2.fc20: Process /usr/bin/midori was killed by signal 4 (S...
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: midori
Version: 20
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:716cad8c8d820faf00203fe6a0e...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-01 22:07 UTC by wrona1380
Modified: 2015-06-30 00:49 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-30 00:49:18 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (28.99 KB, text/plain)
2014-01-01 22:07 UTC, wrona1380
no flags Details
File: cgroup (159 bytes, text/plain)
2014-01-01 22:07 UTC, wrona1380
no flags Details
File: core_backtrace (26.06 KB, text/plain)
2014-01-01 22:07 UTC, wrona1380
no flags Details
File: dso_list (13.63 KB, text/plain)
2014-01-01 22:07 UTC, wrona1380
no flags Details
File: environ (1.41 KB, text/plain)
2014-01-01 22:07 UTC, wrona1380
no flags Details
File: exploitable (151 bytes, text/plain)
2014-01-01 22:07 UTC, wrona1380
no flags Details
File: limits (1.29 KB, text/plain)
2014-01-01 22:07 UTC, wrona1380
no flags Details
File: maps (51.29 KB, text/plain)
2014-01-01 22:07 UTC, wrona1380
no flags Details
File: open_fds (1.71 KB, text/plain)
2014-01-01 22:07 UTC, wrona1380
no flags Details
File: proc_pid_status (785 bytes, text/plain)
2014-01-01 22:07 UTC, wrona1380
no flags Details
File: var_log_messages (202 bytes, text/plain)
2014-01-01 22:07 UTC, wrona1380
no flags Details
dmesg (41.50 KB, text/plain)
2014-01-02 12:37 UTC, wrona1380
no flags Details

Description wrona1380 2014-01-01 22:07:14 UTC
Description of problem:
Midori has been closed when i tried to open link by clicking on it on actual page. i have new installed fedora. same thing is happening with terminal emulator. just closed almost few seconds after i opened it.

Version-Release number of selected component:
midori-0.5.5-2.fc20

Additional info:
reporter:       libreport-2.1.9
backtrace_rating: 3
cmdline:        /usr/bin/midori
executable:     /usr/bin/midori
kernel:         3.11.10-301.fc20.i686+PAE
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 ??
 #1 JSC::JITCode::execute at /lib/libjavascriptcoregtk-1.0.so.0
 #2 JSC::Interpreter::execute at /lib/libjavascriptcoregtk-1.0.so.0
 #3 JSC::evaluate at /lib/libjavascriptcoregtk-1.0.so.0
 #4 WebCore::ScriptController::evaluateInWorld at /lib/libwebkitgtk-1.0.so.0
 #5 WebCore::ScriptController::executeScriptInWorld at /lib/libwebkitgtk-1.0.so.0
 #6 WebCore::ScheduledAction::execute at /lib/libwebkitgtk-1.0.so.0
 #8 WebCore::DOMTimer::fired at /lib/libwebkitgtk-1.0.so.0
 #9 WebCore::ThreadTimers::sharedTimerFiredInternal at /lib/libwebkitgtk-1.0.so.0
 #10 WebCore::ThreadTimers::sharedTimerFired at /lib/libwebkitgtk-1.0.so.0

Comment 1 wrona1380 2014-01-01 22:07:20 UTC
Created attachment 844292 [details]
File: backtrace

Comment 2 wrona1380 2014-01-01 22:07:22 UTC
Created attachment 844293 [details]
File: cgroup

Comment 3 wrona1380 2014-01-01 22:07:25 UTC
Created attachment 844294 [details]
File: core_backtrace

Comment 4 wrona1380 2014-01-01 22:07:27 UTC
Created attachment 844295 [details]
File: dso_list

Comment 5 wrona1380 2014-01-01 22:07:29 UTC
Created attachment 844296 [details]
File: environ

Comment 6 wrona1380 2014-01-01 22:07:31 UTC
Created attachment 844297 [details]
File: exploitable

Comment 7 wrona1380 2014-01-01 22:07:33 UTC
Created attachment 844298 [details]
File: limits

Comment 8 wrona1380 2014-01-01 22:07:35 UTC
Created attachment 844299 [details]
File: maps

Comment 9 wrona1380 2014-01-01 22:07:37 UTC
Created attachment 844300 [details]
File: open_fds

Comment 10 wrona1380 2014-01-01 22:07:43 UTC
Created attachment 844301 [details]
File: proc_pid_status

Comment 11 wrona1380 2014-01-01 22:07:46 UTC
Created attachment 844302 [details]
File: var_log_messages

Comment 12 Kevin Fenzi 2014-01-02 04:04:04 UTC
Can you attach 'dmesg' output? Is it just terminals and midori that are crashing? Or other things?

Comment 13 wrona1380 2014-01-02 12:37:06 UTC
Created attachment 844546 [details]
dmesg

dmesg printed by user, not root, hope its ok.

Comment 14 wrona1380 2014-01-02 12:53:59 UTC
i have some more info:

this is my second installation on not long time, and with this first, midori happend to close same way. i had to reinstall due to my not well maintained task on partitions (i am comletly fresh with linux).

and minute ago, i tried to open some other programs to check if it happend not only with midora and terminal. i opened Blender, and even didn't start: Process /usr/bin/blender killed by signal 4 (SIGILL).

maybe same problem. dont know: of course.

and one thing more. i think that with this first installation, when i used some more time, the problem has been less annoying. i mean, i think, probably badly, problem has disappear by self-repair.

ok. done it. sorry for my english. and i hope that i am doing it right to write this here not on pm.

regards
lukasz

Comment 15 Kevin Fenzi 2014-01-03 23:13:14 UTC
Hum. SIGILL seems more like it might be a hardware error. 

Perhaps check all the fans and heat sinks on your machine to see if there's any overheating going on?

Comment 16 wrona1380 2014-01-13 18:59:36 UTC
Hm. First, I upgraded Midori to latest version. Then, I changed few settings in BIOS related to temp, eg. disabled bios temp control of disk and cpu. It did not change a bit of working Midora. Still closing, specially with heavier loaded with pictures pages, even when dont show them.

Just before I installed Fedora I was using Windows Vista on this PC, and many times was cpu was heavy occupied and nothing was happend. Maybe You can show me a way to disable system temp checkin to check if it is really problem with overheating?

thks for really quick response, and sorry for my not so quick ;)

Comment 17 Kevin Fenzi 2014-01-17 23:48:37 UTC
No problem on the delay... ;)

Anyhow, I am not sure what to suggest next... there are some newer versions of midori available, so you could try just doing a full 'yum update' and see if things are better. 

Does the problem persist when you boot from a live media? That would tell us if it's hardware or something with your install.

Comment 18 Peter H. Jones 2014-09-15 00:57:34 UTC
Another user experienced a similar problem:

Normal surfing, nothing unusual.

reporter:       libreport-2.2.3
backtrace_rating: 3
cmdline:        midori
executable:     /usr/bin/midori
kernel:         3.15.10-201.fc20.i686+PAE
package:        midori-0.5.8-1.fc20
reason:         midori killed by SIGTRAP
runlevel:       N 5
type:           CCpp
uid:            3000

Comment 19 Fedora End Of Life 2015-05-29 10:17:01 UTC
This message is a reminder that Fedora 20 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 20. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '20'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 20 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 20 Fedora End Of Life 2015-06-30 00:49:18 UTC
Fedora 20 changed to end-of-life (EOL) status on 2015-06-23. Fedora 20 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.