Bug 104774 - Looping Linux guest
Looping Linux guest
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
s390x Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-20 20:28 EDT by Need Real Name
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-13 13:42:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-09-20 20:28:27 EDT
Description of problem:

I have experienced looping/hanging problems on the RedHat Linux guests.
The latest one occurred around 04:00am on 9/19 which is running EL 3
Beta 1 code.  I was unable to SSH to the guest or get any response from
the 3270 logon session.  It was consuming CPU cycles until I did a
IPL 200 CLEAR to reboot the Linux guest.

Only one message is found in the /var/log/messages.
Sep 15 04:02:20 mokcmtc01vipa-lnx00 syslogd 1.4.1: restart.
Sep 15 09:52:09 mokcmtc01vipa-lnx00 login(pam_unix)[908]: session opened
for user root by LOGIN(uid=0)

Is there any places I can look for more clues after rebooting the system?

Doing a MAN to some of the commands (i.e. man smbtar) also cause the
guest to hang.

Other than taking a VMDUMP of the guest, what other doc do we need to
capture for the problem?


Linux version 2.4.21-1.1931.2.349.2.2.ent (bhcompile@devel5.z900.redhat.com)
(gcc version 3.2.3 20030422 (Red Hat Linux 3.2.3-12)) #1
SMP Fri Jul 18 00:07:57 EDT 2003
Taroon-re0720[1].B1.0

The mainframe box is IBM 2064-1C3, and is running z/VM 3.1.0.

This memory size for this guest is at 64M, with a 200 3390-3 cylinder
for SWAP (140M).

Only RHEL AS packages was selected for initial install.  Samba was later
installed from the ISO image files.  HTTPD, NFSserver, and SAMBA are
chkconfig enabled. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:
Comment 1 Arjan van de Ven 2003-09-22 02:54:05 EDT
For x86, the minimum memory requirement is 256Mb; not sure abuot s390x. Pete ?
Comment 2 Need Real Name 2003-09-22 11:42:56 EDT
We increased the memory to 256Mb and ramdisk_size to 64Mb as per RedHat support 
because anaconda failed to continue the install process.  Then we lowered it to 
64Mb after a sucessfull install just like other Linux distributions.  We have 
no problem raising the memory size if we know the minimum. - Emil    
Comment 3 Pete Zaitcev 2003-09-22 14:40:20 EDT
There's a LOT of pressure to run with very small VM guest storage
sizes from clients who run "farms" of little VM guests. The final
official cutoff number is not set yet.

Personally, I do not think it's reasonable to set such numer.
It is load dependent. I can run a somewhat useable client on 24MB
in 31 bit mode. But it's almost never reasonable to go that low.

Emil needs serious front-line help with the sizing and failure
analysis for the hang. Bugzilla is not appropriate for this though.
Who is BoA's TAM? He needs to do something here.

I am taking the bug, because there may be a bug after all.
Impossible to tell now from the report, but I won't be surprised
if something fishy turns up with order-2 allocations, for instance...

Comment 4 Need Real Name 2003-09-22 19:04:24 EDT
I'm new to RedHat.  What is "order-2 allocatios"?  Thank you - Emil
Comment 5 Matt Wilson 2003-09-26 15:08:52 EDT
order-0 allocations are of 1 page.
order-1 allocations are of 2 contiguous pages.
order-2 allocations are of 4 contiguous pages.
right?


Comment 6 Need Real Name 2003-10-07 12:15:33 EDT
We have not seen any recurrence for two weeks after the memory size was 
increased to 128MB for the guests.  Again, there isn't any workload on these 
guests. 

Note You need to log in before you can comment on or make changes to this bug.