Bug 104778 - mozilla crashes while navigating specific url
mozilla crashes while navigating specific url
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux Beta
Classification: Retired
Component: mozilla (Show other bugs)
beta1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Christopher Aillon
Ben Levenson
http://www.bbc.co.uk/go/homepage/int/...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-21 08:31 EDT by Ashok Kumar
Modified: 2007-04-18 12:57 EDT (History)
1 user (show)

See Also:
Fixed In Version: firefox-1.5.0.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-07 16:38:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
the bug is reproduced from this index.html file. (43.74 KB, text/html)
2003-09-21 08:39 EDT, Ashok Kumar
no flags Details
url web page (134.93 KB, image/pjpeg)
2003-09-29 20:08 EDT, Ashok Kumar
no flags Details
bad font rendering.. (161.02 KB, image/jpeg)
2003-09-29 23:25 EDT, Ashok Kumar
no flags Details

  None (edit)
Description Ashok Kumar 2003-09-21 08:31:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
all instances of mozilla crash when above url is clicked. there are no
core dumps or stack trace when mozilla is executed from commandline.


the char set is unicode, but another url in the section with  unicode
renders correctly.
http://www.bbc.co.uk/go/homepage/int/ws/ur/-/urdu/

Version-Release number of selected component (if applicable):
mozilla-1.4-12

How reproducible:
Always

Steps to Reproduce:
1.visit bbc at http://www.bbc.co.uk/

2.Click on  "Hindi" from WORLD SERVICE section at bottom left.

3.
    

Actual Results:  all instances of mozilla browser disappeared.

Expected Results:  the page is rendered.

Additional info:

i saved the url using wget and when i viewed "index.html" using gvim,
i saw a warning. 
"Cannot open font file for font Raghindi 10". so it seems the font is 
missing, but that should not cause the browser to crash.

other intalled pkgs.

XFree86-4.3.0-32
Comment 1 Ashok Kumar 2003-09-21 08:39:17 EDT
Created attachment 94616 [details]
the bug is reproduced from this index.html file.
Comment 2 Christopher Blizzard 2003-09-29 17:01:39 EDT
I'm not having any problems loading this page, but I also suspect I don't have
any of the proper fonts installed.  Can you verify that this still crashes with
the most recent beta release and/or with the fonts in question installed?
Comment 3 Ashok Kumar 2003-09-29 20:08:47 EDT
Created attachment 94841 [details]
url web page

web page as rendered by mozilla 1.5 rc2 from mozilla.org and mozilla-1.4-0.7.3
from redhat. both of these were on redhat linux 7.3 with up2date 
patches.
Comment 4 Ashok Kumar 2003-09-29 23:25:00 EDT
Created attachment 94846 [details]
bad font rendering..

on redhat-release-9.0.93-4, the browser is no longer crashing, but the font
is not redered by mozilla-1.4-12. I have not installed any custom fonts. the
following font rpms are present.

bitmap-fonts-0.3-2
ghostscript-fonts-5.50-9
urw-fonts-2.1-5.1
XFree86-100dpi-fonts-4.3.0-33
XFree86-75dpi-fonts-4.3.0-33
XFree86-base-fonts-4.3.0-33
XFree86-truetype-fonts-4.3.0-33

mozilla 1.5 rc2 from mozilla.org renders properly as in attachment id 94841
Comment 5 Christopher Blizzard 2003-10-08 13:28:11 EDT
Ahh, ok.  This is probably a xfonts vs. xft issue.  We're working on something
that solves that problem.
Comment 6 Bill Nottingham 2006-08-07 11:44:11 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still running
Red Hat Linux, you are strongly advised to upgrade to a current Fedora Core
release or Red Hat Enterprise Linux or comparable. Some information on which
option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do want to
make sure that no important bugs slip through the cracks. Please check if this
issue is still present in a current Fedora Core release. If so, please change
the product and version to match, and check the box indicating that the
requested information has been provided. Note that any bug still open against
Red Hat Linux by the end of 2006 will be closed as 'CANTFIX'. Thanks again for
your help.
Comment 7 Ashok Kumar 2006-08-07 16:36:17 EDT
you can close this bug. the browser does not crash in firefox 1.5.0.6.
the font rendering problem is due to missing font files.

Note You need to log in before you can comment on or make changes to this bug.