Bug 1047794 - CLI : sc_param info command is failing
Summary: CLI : sc_param info command is failing
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Provisioning
Version: Nightly
Hardware: x86_64
OS: Linux
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Tomas Strachota
QA Contact: Tazim Kolhar
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-02 09:13 UTC by Tazim Kolhar
Modified: 2019-09-26 18:18 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-02 14:08:28 UTC
Target Upstream Version:


Attachments (Terms of Use)
foreman-debug (68.98 KB, application/x-xz)
2014-01-02 10:07 UTC, Tazim Kolhar
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 4129 0 None None None 2016-04-22 15:53:36 UTC

Description Tazim Kolhar 2014-01-02 09:13:58 UTC
Description of problem:
sc_param info command is failing

Version-Release number of selected component (if applicable):
# rpm -qa | grep foreman
rubygem-hammer_cli_foreman-0.0.15-1.el6.noarch
foreman-compute-1.4.0-0.develop.201401011454git1245d23.el6.noarch
foreman-installer-1.4.0-0.develop.201312272053gitbc2acd9.el6.noarch
foreman-release-1.4.0-0.develop.201401011454git1245d23.el6.noarch
foreman-1.4.0-0.develop.201401011454git1245d23.el6.noarch
foreman-ovirt-1.4.0-0.develop.201401011454git1245d23.el6.noarch
foreman-proxy-1.4.0-0.develop.201312091021git42bab91.el6.noarch
foreman-postgresql-1.4.0-0.develop.201401011454git1245d23.el6.noarch
rubygem-foreman_api-0.1.9-1.el6.noarch
foreman-libvirt-1.4.0-0.develop.201401011454git1245d23.el6.noarch
foreman-selinux-1.4.0-0.develop.201311220906gite342a0b.el6.noarch


How reproducible:
everytime

Steps to Reproduce:
1.# hammer sc_param info --id 18
Error: undefined method `[]' for nil:NilClass

2.
3.

Actual results:
sc_param throws some error

Expected results:
sc_params displays appropriate output

Additional info:

Comment 1 RHEL Program Management 2014-01-02 09:26:18 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Tazim Kolhar 2014-01-02 10:07:04 UTC
Created attachment 844471 [details]
foreman-debug

Comment 7 Og Maciel 2014-03-23 18:02:14 UTC
The command is no longer returning an error.

2014-03-23 13:50:46 - robottelo - DEBUG - Running test TestSmartClassParameter/test_bugzilla_1047794
2014-03-23 13:50:46 - robottelo - DEBUG - >>> puppet module install --force puppetlabs/ntp
2014-03-23 13:50:48 - robottelo - DEBUG - <<< [u'\x1b[mNotice: Preparing to install into /etc/puppet/modules ...', u'\x1b[mNotice: Downloading from https://forge.puppetlabs.com ...', u'\x1b[mNotice: Installing -- do not interrupt ...', u'/etc/puppet/modules', u'\u2514\u2500\u2500 puppetlabs-ntp (\x1b[0;36mv3.0.3)', u'']
2014-03-23 13:50:48 - robottelo - DEBUG - >>> LANG=en_US hammer -v -u admin -p changeme  --output csv sc-param list --per-page='10000'
2014-03-23 13:50:50 - robottelo - DEBUG - <<< [u'Id,Parameter,Default Value,Override,Puppet class', u'']
.
----------------------------------------------------------------------
Ran 1 test in 3.684s

OK

Also,

# hammer sc-param info --id=1
404 Resource Not Found

Comment 8 Bryan Kearney 2014-07-02 14:08:28 UTC
This was delivered with 6.0.3, which is the Satellite 6 Beta.

Comment 9 Bryan Kearney 2014-07-02 14:09:46 UTC
This was delivered in 6.0.3, the Beta version of Satellite 6.0


Note You need to log in before you can comment on or make changes to this bug.