Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1047834 - Displaylink adapters doesn't work anymore
Summary: Displaylink adapters doesn't work anymore
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-displaylink
Version: 20
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Orphan Owner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-02 10:47 UTC by Markus Haybach
Modified: 2015-06-29 14:06 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-29 14:06:10 UTC
Type: Bug


Attachments (Terms of Use)

Description Markus Haybach 2014-01-02 10:47:07 UTC
Description of problem:
The Displaylink adapters don't work anymore. I have two of them to connect two external displays, which worked fine on my actual Fedora 19 x64 MATE.

lsusb recognizes them:
Bus 001 Device 006: ID 17e9:0290 DisplayLink 
Bus 001 Device 005: ID 17e9:02ee DisplayLink

I tried with with a live USB with Fedora 20 GNOME and Korora 20 Cinnamon beta  and only the built in display of my Thinkpad T400 and one VGA and one DVI displays are detected and work.
Unfortunately I cannot upgrade to version 20 until this is fixed :(

Comment 1 Bert Rolston 2014-01-07 21:44:44 UTC
I have the same result with a clean install of F20 64Bit (DVD not Live Media), Gnome DM, on a Dell Latitude E6410.

See my posts http://www.forums.fedoraforum.org/showthread.php?p=1683511&posted=1#post1683511

Comment 2 Bert Rolston 2014-01-07 23:45:38 UTC
Further digging has uncovered some more info. I'm using a DisplayLink CERTIFIED device using the 3xxx DisplayLink chipset. 
This chipset has inbuilt content protection, so I suspect this is causing the problem.

Displaylink are not providing support for the 3xxx series chipsets, at present, because of content protection.

Comment 3 Mykola Dvornik 2014-01-14 11:06:47 UTC
The same issues here

ID 17e9:029d DisplayLink

Was working fine in F19. Tried kernel-3.13, no luck.

Comment 4 Jason Separovic 2014-04-24 08:34:35 UTC
I just installed Fedora 20 and have the same problem.

The device is found ok:

Bus 003 Device 039: ID 17e9:0360 DisplayLink

Just nothing in xrandr.

I thought I would attempt a "yum upgrade" to see if it helped as this was a fresh install. After upgrade X would not load up anything at all. Just a blank screen. Not sure if this issue is related. Going to try F19 now.

Comment 5 Mike 2014-06-10 00:33:19 UTC
I too have a fresh install of F20 from live CD ....

I see it in lsusb and dmesg shows [drm] Initialized udl 0.0.1 20120220 on minor 1...

its probably a need for a xorg.conf to be done ... but i dont know how.

I have a DL-163 and it does work (ubuntu 14.04 and win7)

Comment 6 Mike 2014-06-10 06:36:24 UTC
just did a upgrade and it seems to work now ...

Comment 7 Fedora End Of Life 2015-05-29 10:17:33 UTC
This message is a reminder that Fedora 20 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 20. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '20'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 20 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 8 Fedora End Of Life 2015-06-29 14:06:10 UTC
Fedora 20 changed to end-of-life (EOL) status on 2015-06-23. Fedora 20 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.