Bug 1047874 - Feedback action of "Unapplied changes" performs different from other options.
Summary: Feedback action of "Unapplied changes" performs different from other options.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager
Version: 7.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Giuseppe Scrivano
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 883726
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-02 12:30 UTC by zhengqin
Modified: 2016-04-26 13:54 UTC (History)
6 users (show)

Fixed In Version: virt-manager-1.1.0-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of: 883726
Environment:
Last Closed: 2015-03-05 10:03:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0427 0 normal SHIPPED_LIVE virt-manager bug fix and enhancement update 2015-03-05 14:38:46 UTC

Description zhengqin 2014-01-02 12:30:40 UTC
+++ This bug was initially created as a clone of Bug #883726 +++

Description
Feedback action of "Unapplied changes" performs different from other options.
For "Unapplied changes",on the confirmation box,tick "Don't ask me again", and click "no",then the confirmation box doesn't appear while for other options the confirmation box still shows.

Version
virt-manager-0.9.0-16.el6.x86_64

How reproducible:
100%

Steps
1. Launch virt-manager: #virt-manager.
2. Click  Edit->Preference on Virtual Machine Manager window.
3. Click Feedback tab on Preference window.
4. Enable "Force Poweroff". Close Preference.
5. On the View Manager page, select a running vm, click Force off on toolbar.
6. On the confirmation box, tick "Don't ask me again", and click "no".
7. Repeat step 5,the confimation box still displays.(Other options like Poweroff/Reboot/Save,Pause,Interface start/stop,Device removal perform the same as Force Poweroff).
8. When under preference enable "Unapplied changes",change graphic type:"VNC" to "SPICE" and don't press "APPLY",then confimation box shows,tick "Don't ask me again", and click "no".
9. Repeat step 8,the confimation box doesn't display.

Actual result
Feedback action of "Unapplied changes" performs different from other options.As step 7 and step 9 show.

Expect result
Feedback action of "Unapplied changes" performs the same as other options.

Additional info



This issue also occurs on RHEL7 with:
virt-manager-0.10.0-9.el7

Comment 1 Martin Kletzander 2014-01-07 14:44:31 UTC
Possible duplicate of Bug 1047875, isn't it?

Comment 2 tingting zheng 2014-01-08 02:40:50 UTC
(In reply to Martin Kletzander from comment #1)
> Possible duplicate of Bug 1047875, isn't it?

In this bug,the "Unapplied changes" works for guest virtual hardware options,but it performs different for these options.While in bug 1047875, "Unapplied changes" doesn't work for Connection Details.So I think these 2 bugs are different.

Comment 3 Giuseppe Scrivano 2014-07-28 17:23:22 UTC
upstream patch:

commit 92de2db42ba27c99208d179feec6fcfee8b2c4f8
Author: Giuseppe Scrivano <gscrivan@redhat.com>
Date:   Thu Jul 24 17:41:11 2014 +0200

    virtManager: always save "do not show again" setting
    
    Any other message box performs different than "Unapplied changes",
    which stores this information regardless of the user choice of
    Yes/No.
    
    Closes: https://bugzilla.redhat.com/show_bug.cgi?id=1047874
    
    Signed-off-by: Giuseppe Scrivano <gscrivan@redhat.com>

Comment 5 Cui Lei 2014-09-12 05:29:34 UTC
I can reproduce the issue with virt-manager-0.10.0-20.el7.

Verify the issue with virt-manager-1.1.0-1.el7

Steps
1. Launch virt-manager: #virt-manager.
2. Click  Edit->Preference on Virtual Machine Manager window.
3. Click Feedback tab on Preference window.
4. Enable "Force Poweroff". Close Preference.
5. On the View Manager page, select a running vm, click Force off on toolbar.
6. On the confirmation box, tick "Don't ask me again", and click "no".
7. Repeat step 5,the confimation box would not display.

So change the bug status from 'ON_QA' to 'VERIFIED'

Comment 8 errata-xmlrpc 2015-03-05 10:03:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0427.html


Note You need to log in before you can comment on or make changes to this bug.