Bug 1047930 - Cannot connect to ModeShape server
Summary: Cannot connect to ModeShape server
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Productization
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: CR2
: 6.0
Assignee: Julian Coleman
QA Contact:
URL:
Whiteboard:
Depends On: 1048240
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-02 15:37 UTC by Lucie Fabrikova
Modified: 2014-07-09 05:01 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
JBDS 7.1.0.CR2, JBDSIS 7.0.0CR1, DV6 CR1, fedora 18 x64, java oracle 1.6
Last Closed: 2014-02-06 15:37:22 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat One Jira Issue Tracker MODE-2127 Critical Closed Cannot connect to ModeShape server 2016-01-06 12:16:22 UTC
Red Hat One Jira Issue Tracker TEIIDDES-2011 Major Closed Designer connectivity feature needs include org.apache.commons.logging for Modeshape connection profile 2016-01-06 12:16:22 UTC

Description Lucie Fabrikova 2014-01-02 15:37:22 UTC
Description of problem:
Unable to connect to ModeShape server

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Start the DV6 CR1 server (with modeshape-*.properties set up)
2. In ModeShape view, create new server:
- URL: http://localhost:8080/modeshape-rest
- user/password: admin/admin
3. In the ModeShape view, select the modeshape server and click on "Reconnect to the selected server"

Actual results:
Unable to connect to ModeShape server
Obtaining the repositories from server "http://localhost:8080/modeshape-rest/v1" failed with HTTP response code of "500"

Expected results:


Additional info:

Comment 2 Horia Chiorean 2014-01-06 15:17:12 UTC
The SOLR module which is packaged in CR1 is incorrect and causes 500 errors atm. This may or may not be the cause of this issue.

See https://bugzilla.redhat.com/show_bug.cgi?id=1048240 for more information.

Comment 3 Randall Hauch 2014-01-06 21:02:24 UTC
Van and Dan Florian did verify that by making the changes described in https://bugzilla.redhat.com/show_bug.cgi?id=1048240 also fixes this issue. Therefore, there appear to be no changes to ModeShape or ModeShape Tools.

Comment 5 JBoss JIRA Server 2014-01-07 15:59:11 UTC
Barry LaFond <blafond@jboss.org> updated the status of jira TEIIDDES-2011 to Resolved

Comment 6 Lucie Fabrikova 2014-01-14 20:59:58 UTC
Verified in DV6 CR2 + JBDS 7.1.0.GA + JBDSIS 7.0.0.CR2

Comment 7 Lucie Fabrikova 2014-02-04 17:32:22 UTC
Verified in JBDSIS-7.0.0.GA-GA + DV 6.0.0.GA.

Comment 8 JBoss JIRA Server 2014-05-07 21:15:00 UTC
Barry LaFond <blafond@jboss.org> updated the status of jira TEIIDDES-2011 to Closed


Note You need to log in before you can comment on or make changes to this bug.