Bug 104794 - locks up during initializing
locks up during initializing
Status: CLOSED WONTFIX
Product: Red Hat Linux Beta
Classification: Retired
Component: gnome-core (Show other bugs)
beta1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Jay Turner
:
Depends On: 104793
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-21 22:01 EDT by Jim Cornette
Modified: 2015-01-07 19:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-24 22:49:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Cornette 2003-09-21 22:01:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
When launching gnome from the commandline (startx). Gnome fails during network,
keyboard, mouse initializing.  No ICONs are present in startup screen, just box
outline.

If I ctl-alt-backspace, the next gnome startup attempt would result i nly a
blank screen.

KDE finds all services and I have to use this until gnome starts up successfully.

Mozilla does not work while in KDE though.

Version-Release number of selected component (if applicable):
gnome-libs-1.4.1.2.90-34

How reproducible:
Always

Steps to Reproduce:
1. log into terminal
2.run startx
3.wait for gnome to start up. (initialize)
    

Actual Results:  1. no problem
2. computer changes to graphical mode
3. computer hangs while starting services.

Expected Results:  the gnome session would work properly.

Additional info:

Since when my computer boots up and does not think the cable to the ethernet
card is plugged in. I think that me having to manually run dhclient to get
connected to the Internet is not recognizing my IP address correctly for GNOME.
I haven't tried it wthout running dhclient.

Also mozilla locks up in KDE, which I use while gnome s down for me.
Comment 1 Jim Cornette 2003-09-23 12:53:33 EDT
I tried to start GNOME without running dhclient at the command line. When I
tried to start GNOME, it worked. I ran dhclient from a gnome-terminal and was
able to connect to the Internet. However, when I tried to log out of GNOME to a
terminal, it would not let me do so.
The problem with GNOME not starting is related to my initial startup thinking
that my ethernet cable is unplugged. (3com vortex boomerang)

Is there any way to prevent GNOME from locking up on startup or closing? (Short
of a properly working driver for the ethernet card)
Comment 2 Jim Cornette 2003-09-23 19:44:54 EDT
This bug was caused by a faulty NIC card. Refer to bug # 104793 for further
resolutions.
Comment 3 Jim Cornette 2003-09-24 22:49:43 EDT
There has to be some breakout from when the IP address is not resolving on
startup. Maybe adding output for the afflicted to know what process is hanging.
A message box or something would make it easier to diagnose.

Hopefully no one will run into a working IP that is detected by GNOME as
/dev/lockup.

Bug being closed as WONTFIX

Note You need to log in before you can comment on or make changes to this bug.