Bug 1047961 - [GSS] (6.2.x) Race condition during server start-up - RA not deployed
Summary: [GSS] (6.2.x) Race condition during server start-up - RA not deployed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: JCA
Version: 6.1.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: CR1
: EAP 6.2.1
Assignee: Brad Maxwell
QA Contact: Martin Simka
Russell Dickenson
URL:
Whiteboard:
Depends On: 984855 1292367
Blocks: eap62-cp01-blockers
TreeView+ depends on / blocked
 
Reported: 2014-01-02 18:00 UTC by Brad Maxwell
Modified: 2018-12-05 16:50 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
A race condition was found to be preventing custom Resource Adapters from being deployed in up some instances. The race condition was caused by `org.jboss.as.connector.subsystems.resourceadapters.ResourceAdapterService` not starting in time to deploy the resource adapter. This issue has been fixed in this release, and the ResourceAdapterService now starts in time to deploy custom resource adapters.
Clone Of:
Environment:
Last Closed: 2014-02-24 20:16:05 UTC
Type: Bug


Attachments (Terms of Use)

Comment 3 Martin Simka 2014-01-30 12:51:01 UTC
Verified on 6.2.1.CP.CR3

Comment 4 Lucas Costi 2014-01-31 02:27:21 UTC
Release note flag set for EAP 6.2.1

Comment 6 Brad Maxwell 2014-10-09 20:37:01 UTC
Description of problem:
A custom RA is not always deployed when the JBoss EAP server is restarted. There are no errors in the log file even at TRACE level and only indication that something went wrong is the message:

11:30:45,303 INFO  [org.jboss.as.controller] (Controller Boot Thread) JBAS014774: Service status report
JBAS014775:    New missing/unsatisfied dependencies:
      service jboss.ra.example-ra (missing) dependents: [service jboss.deployment.unit."example.jar".component.ExampleMDB.CREATE] 


I have attached two log files to the case one from a successful start up and one from a failed startup. The only difference as far as I can tell is the absence of any output from org.jboss.as.connector.deployers.RaXmlDeployer when the deployment fails.

I cannot not reproduce the issue in house on my machines. Customer can reproduce it in about 30% of his restarts. After the deployment fails he able to deploy the RA via JBoss cli without any problems.


Note You need to log in before you can comment on or make changes to this bug.