Bug 1047997 - New submodules puppet-certmonger, puppet-openstack-storage, puppet-nssdb, sync other modules
Summary: New submodules puppet-certmonger, puppet-openstack-storage, puppet-nssdb, syn...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-puppet-modules
Version: 4.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: z1
: 4.0
Assignee: Martin Magr
QA Contact: Ami Jeain
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-02 20:29 UTC by Steve Linabery
Modified: 2014-12-15 15:20 UTC (History)
7 users (show)

Fixed In Version: openstack-puppet-modules-2013.2-5.el6ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-23 14:22:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0046 0 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform 4 Bug Fix and Enhancement Advisory 2014-01-23 00:51:59 UTC

Description Steve Linabery 2014-01-02 20:29:26 UTC
Description of problem:
New submodules puppet-certmonger, puppet-openstack-storage, puppet-nssdb; need sync on additional existing modules.

Modules needing resync (from git diff on specfile):
+%global ceilometer_commit  0fb3b8f693ba4cc24bdcfb1f61de843343a13e75
+%global cinder_commit      5da2beb74d7dc73b4f050f5fb474c473688d206f
+%global glance_commit      5557c224f37c22b058c951d7494448981cb484a2
+%global horizon_commit     17ba6a73cec7f386922e6a914a120a829e225efc
+%global keystone_commit    bb67ef3e0a7c605cee97f9a8ccd13000290f9b39
+%global neutron_commit     3c3d3d52ae0d1a655c7f1b09158ad7c924f80279
+%global nova_commit        0d405fe5198cbd34f1bd2acb42e058a916f1d663
+%global openstack_commit   050fa67b230b320e096c3a66420f692cd1adf69b
+%global pacemaker_commit   0b16aea22c8a03ddadf42837bcf0990355f961ff
+%global qpid_commit        587b0b51e807ce787410133da0fe27ee466a4a72
+%global vswitch_commit     b642b844db6d7df1ced6f11abd641a0982e06363

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Ami Jeain 2014-01-12 15:06:49 UTC
Martin,

how do i go and verify this bug?
Can you plz provide more info?

Comment 3 Martin Magr 2014-01-12 22:19:56 UTC
You will have to download source RPM of openstack-puppet-modules and check openstack-puppet-modules.spec file if:

A. required new modules are in source list
B. required commits are the one which were required or newer.

So one example for module puppet-certmonger (new module) and puppet-ceilometer (updated module):

1. In spec file we have following line:

Source2:	git://github.com/rcritten/puppet-certmonger/archive/%{certmonger_commit}/certmonger-%{certmonger_commit}.tar.gz

Which means we have this module included. Also check if in source RPM file is certmonter-<commit_hash>.tar.gz included to be sure.

2. From the specific tar.gz file or from following line in spec file we can find out commit hash:

%global ceilometer_commit 0fb3b8f693ba4cc24bdcfb1f61de843343a13e75

So now you have to go to module link: https://github.com/stackforge/puppet-ceilometer and on that page click "163 commits". Now Ctrl+F and paste 0fb3b8f (which is few first characters of required commit). It will find you where in the list is required commit. Now in case lets suppose that hash in spec file (above example) is for example f8eea90cd9f1652ba927bfcc9bf8234af8983c11. So now Ctrl+F and paste f8eea90 and it will find you newer commit. It is ok if commit in is newer. It is not ok if commit is older.

Note in case you would not be able to find the commit, try to switch branch on github page to stable/havana.

Hope this helps.

Comment 7 Francesco Vollero 2014-01-20 14:56:02 UTC
About how I verified the bug:

1) I got the source rpm of the build in fixed in version
2) I executed this command, to get the commit id in the rpm: 
 cat openstack-puppet-modules.spec | grep global| grep commit | tr -s '\t'| cut -d$'\t' -f2
3) I moved to master of packstack and run: 
 git submodule | cut -d ' ' -f2 > master_submodule_commits 
4) I executed this command to verify that the spec file and the master was aligned:
   diff ../../packstack/master_submodule_commits <(cat openstack-puppet-modules.spec | grep global| grep commit | tr -s '\t'| cut -d$'\t' -f2) ; echo $?
 with exit code 0 that mean no difference.

Comment 10 Lon Hohberger 2014-02-04 17:19:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-0046.html

Comment 11 Mike Orazi 2014-12-15 15:20:01 UTC
Cleaning house.  This had been answered by Martin ages ago and I neglected to clear the flags.


Note You need to log in before you can comment on or make changes to this bug.