Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1048003 - Excess USB resets
Summary: Excess USB resets
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-02 21:12 UTC by Tom Horsley
Modified: 2014-03-31 01:30 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 01:30:13 UTC
Type: Bug


Attachments (Terms of Use)

Description Tom Horsley 2014-01-02 21:12:35 UTC
Description of problem:

I plug in my AVRISP mkII USB programmer device, and everything else on the same USB hub gets disconnected and reset (sometimes, anyway).


Version-Release number of selected component (if applicable):
kernel-3.12.5-200.fc19.x86_64

How reproducible:

It certainly seems to happen every time I plug in the device after I've rebooted the system. Once it has been plugged in and operated once I seem to be able to plug it in again without the same symptoms cropping up.


Steps to Reproduce:
1.reboot system
2.connect my AVRISP mkII to usb port on hub
3.also connect it to the solidoodle 3d printer motherboard I want to program
4.observe that my xinput settings have disappeared for the mouse on the hub.

Actual results:
see above

Expected results:
leave other usb devices alone.

Additional info:
Here's the /var/log/messages that show lots of things getting reset after I connect the programmer, then shows them coming back with different device numbers:

Jan  2 15:56:00 zooty kernel: [ 8626.919592] usb 3-6.1.2: new full-speed USB device number 10 using xhci_hcd
Jan  2 15:56:00 zooty kernel: [ 8626.932543] usb 3-6.1.2: New USB device found, idVendor=03eb, idProduct=2104
Jan  2 15:56:00 zooty kernel: [ 8626.932545] usb 3-6.1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Jan  2 15:56:00 zooty kernel: [ 8626.932546] usb 3-6.1.2: Product: AVRISP mkII
Jan  2 15:56:00 zooty kernel: [ 8626.932547] usb 3-6.1.2: Manufacturer: ATMEL
Jan  2 15:56:00 zooty kernel: [ 8626.932548] usb 3-6.1.2: SerialNumber: 000200122186
Jan  2 15:56:43 zooty kernel: [ 8669.860400] usb 3-6: USB disconnect, device number 3
Jan  2 15:56:43 zooty kernel: [ 8669.860403] usb 3-6.1: USB disconnect, device number 7
Jan  2 15:56:43 zooty kernel: [ 8669.860405] usb 3-6.1.2: USB disconnect, device number 10
Jan  2 15:56:43 zooty kernel: [ 8669.860858] usb 3-6.1.3: USB disconnect, device number 9
Jan  2 15:56:43 zooty acpid: input device has been disconnected, fd 10
Jan  2 15:56:43 zooty acpid: input device has been disconnected, fd 11
Jan  2 15:56:43 zooty kernel: [ 8669.902614] usb 3-6.3: USB disconnect, device number 8
Jan  2 15:56:43 zooty kernel: [ 8670.171383] usb 3-6: new high-speed USB device number 11 using xhci_hcd
Jan  2 15:56:43 zooty kernel: [ 8670.183673] usb 3-6: New USB device found, idVendor=05e3, idProduct=0608
Jan  2 15:56:43 zooty kernel: [ 8670.183675] usb 3-6: New USB device strings: Mfr=0, Product=1, SerialNumber=0
Jan  2 15:56:43 zooty kernel: [ 8670.183676] usb 3-6: Product: USB2.0 Hub
Jan  2 15:56:43 zooty kernel: [ 8670.184284] hub 3-6:1.0: USB hub found
Jan  2 15:56:43 zooty kernel: [ 8670.184536] hub 3-6:1.0: 4 ports detected
Jan  2 15:56:44 zooty kernel: [ 8670.442627] usb 3-11: new full-speed USB device number 12 using xhci_hcd
Jan  2 15:56:44 zooty kernel: [ 8670.455113] usb 3-11: New USB device found, idVendor=16c0, idProduct=0483
Jan  2 15:56:44 zooty kernel: [ 8670.455115] usb 3-11: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Jan  2 15:56:44 zooty kernel: [ 8670.455116] usb 3-11: Product: USB Serial
Jan  2 15:56:44 zooty kernel: [ 8670.455117] usb 3-11: Manufacturer: Teensyduino
Jan  2 15:56:44 zooty kernel: [ 8670.455118] usb 3-11: SerialNumber: 12345
Jan  2 15:56:44 zooty mtp-probe: checking bus 3, device 12: "/sys/devices/pci0000:00/0000:00:14.0/usb3/3-11"
Jan  2 15:56:44 zooty mtp-probe: bus: 3, device: 12 was not an MTP device
Jan  2 15:56:44 zooty kernel: [ 8670.460043] cdc_acm 3-11:1.0: This device cannot do calls on its own. It is not a modem.
Jan  2 15:56:44 zooty kernel: [ 8670.460061] cdc_acm 3-11:1.0: ttyACM0: USB ACM device
Jan  2 15:56:44 zooty kernel: [ 8670.460234] usbcore: registered new interface driver cdc_acm
Jan  2 15:56:44 zooty kernel: [ 8670.460235] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters
Jan  2 15:56:44 zooty su: (to root) root on none
Jan  2 15:56:44 zooty kernel: [ 8670.528877] usb 3-6.1: new high-speed USB device number 13 using xhci_hcd
Jan  2 15:56:44 zooty kernel: [ 8670.541001] usb 3-6.1: New USB device found, idVendor=05e3, idProduct=0608
Jan  2 15:56:44 zooty kernel: [ 8670.541003] usb 3-6.1: New USB device strings: Mfr=0, Product=1, SerialNumber=0
Jan  2 15:56:44 zooty kernel: [ 8670.541005] usb 3-6.1: Product: USB2.0 Hub
Jan  2 15:56:44 zooty kernel: [ 8670.541618] hub 3-6.1:1.0: USB hub found
Jan  2 15:56:44 zooty kernel: [ 8670.541864] hub 3-6.1:1.0: 4 ports detected
Jan  2 15:56:44 zooty kernel: [ 8670.616975] usb 3-6.3: new low-speed USB device number 14 using xhci_hcd
Jan  2 15:56:44 zooty kernel: [ 8670.633970] usb 3-6.3: New USB device found, idVendor=047d, idProduct=1020
Jan  2 15:56:44 zooty kernel: [ 8670.633972] usb 3-6.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Jan  2 15:56:44 zooty kernel: [ 8670.633973] usb 3-6.3: Product: Kensington Expert Mouse
Jan  2 15:56:44 zooty kernel: [ 8670.633974] usb 3-6.3: Manufacturer: Kensington     
Jan  2 15:56:44 zooty kernel: [ 8670.634088] usb 3-6.3: ep 0x81 - rounding interval to 64 microframes, ep desc says 80 microframes
Jan  2 15:56:44 zooty kernel: [ 8670.636777] input: Kensington      Kensington Expert Mouse as /devices/pci0000:00/0000:00:14.0/usb3/3-6/3-6.3/3-6.3:1.0/input/input19
Jan  2 15:56:44 zooty kernel: [ 8670.636964] hid-generic 0003:047D:1020.0005: input,hidraw1: USB HID v1.10 Mouse [Kensington      Kensington Expert Mouse] on usb-0000:00:14.0-6.3/input0
Jan  2 15:56:44 zooty mtp-probe: checking bus 3, device 14: "/sys/devices/pci0000:00/0000:00:14.0/usb3/3-6/3-6.3"
Jan  2 15:56:44 zooty mtp-probe: bus: 3, device: 14 was not an MTP device
Jan  2 15:56:44 zooty kernel: [ 8670.817155] usb 3-6.1.2: new full-speed USB device number 15 using xhci_hcd
Jan  2 15:56:44 zooty kernel: [ 8670.829910] usb 3-6.1.2: New USB device found, idVendor=03eb, idProduct=2104
Jan  2 15:56:44 zooty kernel: [ 8670.829912] usb 3-6.1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Jan  2 15:56:44 zooty kernel: [ 8670.829913] usb 3-6.1.2: Product: AVRISP mkII
Jan  2 15:56:44 zooty kernel: [ 8670.829914] usb 3-6.1.2: Manufacturer: ATMEL
Jan  2 15:56:44 zooty kernel: [ 8670.829915] usb 3-6.1.2: SerialNumber: 000200122186
Jan  2 15:56:44 zooty kernel: [ 8670.904231] usb 3-6.1.3: new full-speed USB device number 16 using xhci_hcd
Jan  2 15:56:44 zooty kernel: [ 8670.919335] usb 3-6.1.3: New USB device found, idVendor=046d, idProduct=c318
Jan  2 15:56:44 zooty kernel: [ 8670.919337] usb 3-6.1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Jan  2 15:56:44 zooty kernel: [ 8670.919338] usb 3-6.1.3: Product: Logitech Illuminated Keyboard
Jan  2 15:56:44 zooty kernel: [ 8670.919339] usb 3-6.1.3: Manufacturer: Logitech
Jan  2 15:56:44 zooty kernel: [ 8670.922008] input: Logitech Logitech Illuminated Keyboard as /devices/pci0000:00/0000:00:14.0/usb3/3-6/3-6.1/3-6.1.3/3-6.1.3:1.0/input/input20
Jan  2 15:56:44 zooty kernel: [ 8670.922137] hid-generic 0003:046D:C318.0006: input,hidraw2: USB HID v1.11 Keyboard [Logitech Logitech Illuminated Keyboard] on usb-0000:00:14.0-6.1.3/input0
Jan  2 15:56:44 zooty kernel: [ 8670.923966] input: Logitech Logitech Illuminated Keyboard as /devices/pci0000:00/0000:00:14.0/usb3/3-6/3-6.1/3-6.1.3/3-6.1.3:1.1/input/input21
Jan  2 15:56:44 zooty kernel: [ 8670.924074] hid-generic 0003:046D:C318.0007: input,hiddev0,hidraw3: USB HID v1.11 Device [Logitech Logitech Illuminated Keyboard] on usb-0000:00:14.0-6.1.3/input1
Jan  2 15:56:44 zooty kernel: [ 8670.924348] usb 3-11: USB disconnect, device number 12
Jan  2 15:56:44 zooty su: (to root) root on none
Jan  2 15:56:44 zooty kernel: [ 8671.181296] usb 3-11: new full-speed USB device number 17 using xhci_hcd
Jan  2 15:56:44 zooty kernel: [ 8671.193774] usb 3-11: New USB device found, idVendor=16c0, idProduct=0483
Jan  2 15:56:44 zooty kernel: [ 8671.193776] usb 3-11: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Jan  2 15:56:44 zooty kernel: [ 8671.193777] usb 3-11: Product: USB Serial
Jan  2 15:56:44 zooty kernel: [ 8671.193778] usb 3-11: Manufacturer: Teensyduino
Jan  2 15:56:44 zooty kernel: [ 8671.193779] usb 3-11: SerialNumber: 12345
Jan  2 15:56:44 zooty kernel: [ 8671.194248] cdc_acm 3-11:1.0: This device cannot do calls on its own. It is not a modem.
Jan  2 15:56:44 zooty kernel: [ 8671.194267] cdc_acm 3-11:1.0: ttyACM0: USB ACM device
Jan  2 15:56:44 zooty mtp-probe: checking bus 3, device 16: "/sys/devices/pci0000:00/0000:00:14.0/usb3/3-6/3-6.1/3-6.1.3"
Jan  2 15:56:44 zooty mtp-probe: bus: 3, device: 16 was not an MTP device
Jan  2 15:56:44 zooty mtp-probe: checking bus 3, device 17: "/sys/devices/pci0000:00/0000:00:14.0/usb3/3-11"
Jan  2 15:56:44 zooty mtp-probe: bus: 3, device: 17 was not an MTP device

Comment 1 Tom Horsley 2014-01-02 21:24:27 UTC
I take the part about only happening after reboot back. It has now happened several times in a row with no reboot in between.

I get the impression the mkII resets itself when power appears on the cable connected to the 3d printer motherboard, and that reset always seems to take the rest of the devices on the hub with it.

Comment 2 Josh Boyer 2014-01-06 14:39:55 UTC
I'm not sure there is anything we can really do here if the device you're plugging in draws too much power for the hub to handle.  Do the resets happen if you plug it directly into the machine?

Comment 3 Tom Horsley 2014-01-06 18:18:49 UTC
I wouldn't think it was a power issue since the hub is a powered hub, and the Atmel product page says it conforms to USB 2.0 standards for USB powered devices.
I'll try it on a separate port and see what comes out in the log.

Comment 4 Tom Horsley 2014-01-13 23:32:03 UTC
I finally tried a different USB port. I had an available USB 3 port with no external hub involved, and I didn't see anything else get reset this time. The only messages that showed up were:

Jan 13 18:23:03 zooty kernel: [422447.200510] usb 3-9: new full-speed USB device number 12 using xhci_hcd
Jan 13 18:23:03 zooty kernel: [422447.213303] usb 3-9: New USB device found, idVendor=03eb, idProduct=2104
Jan 13 18:23:03 zooty kernel: [422447.213306] usb 3-9: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Jan 13 18:23:03 zooty kernel: [422447.213307] usb 3-9: Product: AVRISP mkII
Jan 13 18:23:03 zooty kernel: [422447.213308] usb 3-9: Manufacturer: ATMEL
Jan 13 18:23:03 zooty kernel: [422447.213309] usb 3-9: SerialNumber: 000200122186

I guess I'll just leave the cable plugged in the new port, but resetting everything on the hub is still kinda mysterious.

Comment 5 Justin M. Forbes 2014-03-10 14:48:56 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.13.5-100.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.

Comment 6 Tom Horsley 2014-03-31 01:30:13 UTC
This was either fixed by a kernel update, or by me swapping out the powered hub for a new USB 3.0 hub. In any case, it no longer resets the mouse and keyboard when I use the Atmel programmer via the same hub as the mouse and keyboard. I guess I'll call this closed.


Note You need to log in before you can comment on or make changes to this bug.