Bug 1048007 - BPM Suite installer asks for existing eap 6 location (or location for new install), does not recognize existing eap 6
Summary: BPM Suite installer asks for existing eap 6 location (or location for new ins...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss BPMS Platform 6
Classification: Retired
Component: Installer
Version: 6.0.0
Hardware: x86_64
OS: Mac OS
medium
medium
Target Milestone: CR1
: 6.0.1
Assignee: Thomas Hauser
QA Contact: Tomas Livora
URL:
Whiteboard:
Depends On:
Blocks: 1062411
TreeView+ depends on / blocked
 
Reported: 2014-01-02 21:18 UTC by Eric D. Schabell
Modified: 2014-08-06 20:04 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-06 20:04:06 UTC
Type: Bug


Attachments (Terms of Use)
Pointing installer to existing EAP 6.1.1 (139.60 KB, image/png)
2014-01-02 21:18 UTC, Eric D. Schabell
no flags Details
Pop up showing going to install new eap + bpm suite inside existing install (146.47 KB, image/png)
2014-01-02 21:21 UTC, Eric D. Schabell
no flags Details
New Installer warning (9.37 KB, image/png)
2014-03-18 18:18 UTC, Thomas Hauser
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1067650 0 unspecified MODIFIED Installer does not detect an existing EAP installation. 2021-02-22 00:41:40 UTC

Description Eric D. Schabell 2014-01-02 21:18:56 UTC
Created attachment 844742 [details]
Pointing installer to existing EAP 6.1.1

Description of problem:
Attached screenshots showing installer asking for a new location or an existing eap 6 to install BPM Suite (ER7), point to a new location installs EAP 6.1.1 + BPM suite fine, point to existing EAP 6.x it pops up saying it will install a new eap 6 one level deeper into the existing installed EAP 6.

Version-Release number of selected component (if applicable):
ER7 installer

How reproducible:
see above.

Steps to Reproduce:
1. see above
2.
3.

Actual results:
Tries to install into existing EAP 6 one level deeper a new EAP 6 + BPM Suite.

Expected results:
Recognise existing EAP 6, test it for EAP 6.1.1 (only one that works), fail if not right version, check for installed BPM Suite and only proceed if not yet installed.

Additional info:
see screenshots attached.

Comment 2 Eric D. Schabell 2014-01-02 21:21:41 UTC
Created attachment 844743 [details]
Pop up showing going to install new eap + bpm suite inside existing install

Comment 3 Ryan Zhang 2014-01-06 11:09:14 UTC
If you have EAP at /dir/jboss-eap-6.1, please input /dir instead of /dir/jboss-eap-6.1 into installer as existed path.

I think that this behaviour is not intuitive enough. 
Let's see if we can checkout both /dir and /dir/jboss-eap-6.1 or add more intiutive instuctions into the UI.

Comment 4 Thomas Hauser 2014-03-17 18:30:54 UTC
What is the decision regarding this issue?

Comment 5 Rajesh Rajasekaran 2014-03-17 20:09:40 UTC
(In reply to Thomas Hauser from comment #4)
> What is the decision regarding this issue?

It's highly likely that the user is going to select 'jboss-eap-x.x' directory for an existing EAP installation. The installer should identify this EAP installation and use it. 
It would be nice to preserve the current behavior (scan for jboss-eap-x.x in any /dir/) as well if customers are used to it. 

Short term we can indicate this more clearly through text/examples on the installer screen for choosing an existing EAP.

Comment 6 Thomas Hauser 2014-03-18 16:26:56 UTC
At this stage, we've decided to display a more verbose message to the user when they specify a directory that the installer considers not to contain EAP.

Comment 7 Thomas Hauser 2014-03-18 18:18:08 UTC
Created attachment 876063 [details]
New Installer warning

New installer warning. Any comments / further clarifications?

Comment 8 Tomas Livora 2014-03-24 10:42:17 UTC
I would recommend adding a note explaining which folder is expected as an input. It can be placed above the installation path field so a user does not need to proceed to the next step to find out the answer. It will also be compatible with bug 1062411. When it is resolved only this note will need to be rewritten.

Comment 9 Thomas Hauser 2014-03-24 21:37:00 UTC
Due to a bug in IzPack, the previous solution was created. We have gone ahead and fixed the bug preventing us from doing what you detailed in your comment, Tomas. The new note appears directly on the panel instead of in a warning after clicking the next button.


Note You need to log in before you can comment on or make changes to this bug.