Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1048058 - [abrt] livecd-tools: yumRepo.py:554:check:RepoError: Cannot find a valid baseurl for repo: fedora
Summary: [abrt] livecd-tools: yumRepo.py:554:check:RepoError: Cannot find a valid base...
Keywords:
Status: CLOSED DUPLICATE of bug 1044675
Alias: None
Product: Fedora
Classification: Fedora
Component: livecd-tools
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:9a8aa1205aad775a0de0e635229...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-03 03:03 UTC by Dominicusin Montessori
Modified: 2014-01-07 19:21 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-07 19:21:49 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (3.72 KB, text/plain)
2014-01-03 03:03 UTC, Dominicusin Montessori
no flags Details
File: dso_list (61 bytes, text/plain)
2014-01-03 03:03 UTC, Dominicusin Montessori
no flags Details
File: environ (2.10 KB, text/plain)
2014-01-03 03:03 UTC, Dominicusin Montessori
no flags Details

Description Dominicusin Montessori 2014-01-03 03:03:31 UTC
Version-Release number of selected component:
livecd-tools-20.1-1.fc20

Additional info:
reporter:       libreport-2.1.10
cmdline:        /usr/bin/python -tt /bin/livecd-creator --config=/usr/share/spin-kickstarts/fedora-livecd-desktop.ks --fslabel=Fedora-LiveCD --cache=/var/cache/live
executable:     /bin/livecd-creator
kernel:         3.12.5-302.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
yumRepo.py:554:check:RepoError: Cannot find a valid baseurl for repo: fedora

Traceback (most recent call last):
  File "/bin/livecd-creator", line 237, in <module>
    sys.exit(main())
  File "/bin/livecd-creator", line 218, in main
    creator.install()
  File "/usr/lib/python2.7/site-packages/imgcreate/creator.py", line 642, in install
    ayum.setup(yum_conf, self._instroot)
  File "/usr/lib/python2.7/site-packages/imgcreate/yuminst.py", line 105, in setup
    self.doTsSetup()
  File "/usr/lib/python2.7/site-packages/yum/depsolve.py", line 129, in doTsSetup
    return self._getTs()
  File "/usr/lib/python2.7/site-packages/yum/depsolve.py", line 137, in _getTs
    if not remove_only and self._tsInfo.pkgSack is None:
  File "/usr/lib/python2.7/site-packages/yum/transactioninfo.py", line 140, in <lambda>
    pkgSack = property(fget=lambda self: self._getPkgSack(),
  File "/usr/lib/python2.7/site-packages/yum/transactioninfo.py", line 137, in _getPkgSack
    self._pkgSack = self._pkgSackCtor()
  File "/usr/lib/python2.7/site-packages/yum/depsolve.py", line 76, in __call__
    return self.ayum.pkgSack
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1071, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 776, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 383, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 224, in populate
    if self._check_db_version(repo, mydbtype):
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 316, in _check_db_version
    return repo._check_db_version(mdtype)
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1484, in _check_db_version
    repoXML = self.repoXML
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1670, in <lambda>
    repoXML = property(fget=lambda self: self._getRepoXML(),
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1666, in _getRepoXML
    self._loadRepoXML(text=self.ui_id)
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1657, in _loadRepoXML
    return self._groupLoadRepoXML(text, self._mdpolicy2mdtypes())
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1631, in _groupLoadRepoXML
    if self._commonLoadRepoXML(text):
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1456, in _commonLoadRepoXML
    result = self._getFileRepoXML(local, text)
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1234, in _getFileRepoXML
    size=102400) # setting max size as 100K
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1014, in _getFile
    result = self.grab.urlgrab(misc.to_utf8(relative), local,
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 694, in <lambda>
    grab = property(lambda self: self._getgrab())
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 689, in _getgrab
    self._setupGrab()
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 627, in _setupGrab
    urls = self.urls
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 871, in <lambda>
    urls = property(fget=lambda self: self._geturls(),
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 868, in _geturls
    self._baseurlSetup()
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 834, in _baseurlSetup
    self.check()
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 554, in check
    'Cannot find a valid baseurl for repo: %s' % self.ui_id
RepoError: Cannot find a valid baseurl for repo: fedora

Local variables in innermost frame:
self: <yum.yumRepo.YumRepository object at 0x1dcd510>

Potential duplicate: bug 962183

Comment 1 Dominicusin Montessori 2014-01-03 03:03:35 UTC
Created attachment 844804 [details]
File: backtrace

Comment 2 Dominicusin Montessori 2014-01-03 03:03:37 UTC
Created attachment 844805 [details]
File: dso_list

Comment 3 Dominicusin Montessori 2014-01-03 03:03:39 UTC
Created attachment 844806 [details]
File: environ

Comment 4 Brian Lane 2014-01-07 19:21:49 UTC

*** This bug has been marked as a duplicate of bug 1044675 ***


Note You need to log in before you can comment on or make changes to this bug.