Bug 1048068 - backup to s3 fails with traceback
Summary: backup to s3 fails with traceback
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: duplicity
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Rahul Sundaram
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-03 03:52 UTC by Dave Allan
Modified: 2016-04-26 17:04 UTC (History)
2 users (show)

Fixed In Version: duplicity-0.6.22-5.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-31 04:25:49 UTC


Attachments (Terms of Use)
traceback from failed backup (1.37 KB, text/plain)
2014-01-03 03:52 UTC, Dave Allan
no flags Details
duplicity s3 patch (1.45 KB, patch)
2014-01-17 15:14 UTC, Michael Wagner
no flags Details | Diff

Description Dave Allan 2014-01-03 03:52:57 UTC
Created attachment 844831 [details]
traceback from failed backup

Description of problem:
I back up to Amazon s3 using duplicity, and today the backup failed with the following error:

InvalidUriError: new_key on object-less URI (s3://dpallan.com-idril-gen0-vol1/)

I will attach the full traceback to the BZ.

Version-Release number of selected component (if applicable):
duplicity-0.6.22-1.fc19.x86_64

How reproducible:
100%

Downgrading to duplicity-0.6.21-1.fc19.x86_64 fixes the problem.

Comment 1 Dave Allan 2014-01-09 03:38:29 UTC
Ugh, I picked up the broken package in an upgrade again tonight and of course my backup failed; downgrade still fixes the problem, but things that cause my backups to fail make me more than a little nervous.  Anything I can do to help here?  If someone can give me a pointer on where to look in the source I'm willing to have a go at patching it.

Comment 2 Rahul Sundaram 2014-01-09 04:01:49 UTC
Not sure how to debug this since I don't use Amazon s3 but if you are willing to work on patching it up, I recommend filing this issue upstream and get involved there.  If you do file a bug report upstream, please post a link here so I can keep track of it

https://bugs.launchpad.net/duplicity

Comment 3 Michael Wagner 2014-01-17 15:14:06 UTC
Created attachment 851671 [details]
duplicity s3 patch

Backups to the bucket root are broken in v. 0.6.22. See:

https://bugs.launchpad.net/duplicity/+bug/1218425

The following patch did work for me.

Comment 4 Fedora Update System 2014-01-17 21:13:05 UTC
duplicity-0.6.22-5.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/duplicity-0.6.22-5.fc20

Comment 5 Fedora Update System 2014-01-17 21:23:09 UTC
duplicity-0.6.22-5.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/duplicity-0.6.22-5.fc20

Comment 6 Fedora Update System 2014-01-17 21:29:56 UTC
duplicity-0.6.22-5.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/duplicity-0.6.22-5.fc19

Comment 7 Fedora Update System 2014-01-19 04:02:19 UTC
Package duplicity-0.6.22-5.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing duplicity-0.6.22-5.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-1099/duplicity-0.6.22-5.fc19
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2014-01-31 04:25:49 UTC
duplicity-0.6.22-5.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2014-01-31 04:27:32 UTC
duplicity-0.6.22-5.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.