Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1048072 - Possible SEGV crash in Gluster NFS while DRC is OFF
Summary: Possible SEGV crash in Gluster NFS while DRC is OFF
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: nfs
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Niels de Vos
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-03 04:55 UTC by santosh pradhan
Modified: 2014-11-11 08:26 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.6.0beta1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-11 08:26:25 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description santosh pradhan 2014-01-03 04:55:00 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Start NFS server
2. Start some I/O e.g. dbench or iozone 
3. Set the DRC to OFF

It would crash.

Actual results:
SEGV  crash

Expected results:
No crash

Additional info:

In rpcsvc_submit_generic() in rpc/rpc-lib/src/rpcsvc.c, while caching the reply (DRC) the code does not check if DRC is ON and goes ahead assuming DRC is on and try to take a LOCK on drc.

Comment 1 Anand Avati 2014-01-03 05:06:25 UTC
REVIEW: http://review.gluster.org/6632 (gNFS: Possible SEGV crash in NFS while DRC is OFF) posted (#1) for review on master by Santosh Pradhan (spradhan@redhat.com)

Comment 2 Anand Avati 2014-01-04 06:15:10 UTC
COMMIT: http://review.gluster.org/6632 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 311e3868bfdb3f2c1535d5a7cb8f759195457612
Author: Santosh Kumar Pradhan <spradhan@redhat.com>
Date:   Fri Jan 3 10:32:16 2014 +0530

    gNFS: Possible SEGV crash in NFS while DRC is OFF
    
    In rpcsvc_submit_generic(), FILE: rpc/rpc-lib/src/rpcsvc.c, while caching
    the reply (DRC), the code does not check if DRC is ON and goes ahead
    assuming DRC is on and try to take a LOCK on drc.
    
    FIX: Put a check on svc->drc by rpcsvc_need_drc().
    
    Change-Id: I52c57280487e6061c68fd0b784e1cafceb2f3690
    BUG: 1048072
    Signed-off-by: Santosh Kumar Pradhan <spradhan@redhat.com>
    Reviewed-on: http://review.gluster.org/6632
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 5 Niels de Vos 2014-09-22 12:34:27 UTC
A beta release for GlusterFS 3.6.0 has been released. Please verify if the release solves this bug report for you. In case the glusterfs-3.6.0beta1 release does not have a resolution for this issue, leave a comment in this bug and move the status to ASSIGNED. If this release fixes the problem for you, leave a note and change the status to VERIFIED.

Packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update (possibly an "updates-testing" repository) infrastructure for your distribution.

[1] http://supercolony.gluster.org/pipermail/gluster-users/2014-September/018836.html
[2] http://supercolony.gluster.org/pipermail/gluster-users/

Comment 6 Niels de Vos 2014-11-11 08:26:25 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.6.1, please reopen this bug report.

glusterfs-3.6.1 has been announced [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://supercolony.gluster.org/pipermail/gluster-users/2014-November/019410.html
[2] http://supercolony.gluster.org/mailman/listinfo/gluster-users


Note You need to log in before you can comment on or make changes to this bug.