Bug 10481 - linuxconf creates syntax errors in named.conf
Summary: linuxconf creates syntax errors in named.conf
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: linuxconf   
(Show other bugs)
Version: 6.2
Hardware: sparc Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-03-31 16:00 UTC by Jason Costomiris
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:47:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jason Costomiris 2000-03-31 16:00:22 UTC
Yesterday, I installed 6.2 on a Sparc 20 (clean, formatted the
filesystems), which was previously running 6.0, w/bind 8.2.2_p3.

When using linuxconf to add secondaries to DNS on this box, even if you
leave the fields blank for fields such as allow-transfer, allow-query,
allow-update and also-notify, linuxconf creates empty stanzas in the
named.conf, such as:

zone "foo.com"{
        type slave;
        file "sec/foo.com";
        masters{
                1.2.3.4;
        };
        notify no;
        allow-transfer{
        };
        allow-query{
        };
        allow-update{
        };
        also-notify{
        };
};

bind notes syntax errors in the syslog when it loads.  named starts, but
just whines about the syntax errors.  Previous versions did not do this...

Comment 1 Brent Fox 2002-06-05 16:12:27 UTC
Closing because we don't ship linuxconf anymore

Comment 2 Red Hat Bugzilla 2006-02-21 18:47:39 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.