Bug 1048137 - iSCSI boot (BFS) is dropping to dracut
Summary: iSCSI boot (BFS) is dropping to dracut
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dracut
Version: 7.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: dracut-maint
QA Contact: Bruno Goncalves
URL:
Whiteboard:
Depends On:
Blocks: 1050845
TreeView+ depends on / blocked
 
Reported: 2014-01-03 09:32 UTC by Bruno Goncalves
Modified: 2014-11-10 12:28 UTC (History)
6 users (show)

Fixed In Version: dracut-033-86.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-13 09:32:13 UTC
Target Upstream Version:


Attachments (Terms of Use)
rdsosreport.txt with rd.debug (6.55 MB, text/plain)
2014-01-07 14:56 UTC, Bruno Goncalves
no flags Details
rdsosreport.txt with rd.debug from the first boot with bnx2i (7.50 MB, text/plain)
2014-01-09 22:42 UTC, Eddie Wai
no flags Details
rdsosreport_dracut-033-85.txt (5.33 MB, text/plain)
2014-01-22 13:33 UTC, Bruno Goncalves
no flags Details

Description Bruno Goncalves 2014-01-03 09:32:28 UTC
Description of problem:
Trying to boot an iSCSI boot server with bnx2i as BFS fails and it drops to dracut.
The installation works fine.

It also takes long time to bring the interface up, not sure if it is related.

[   19.974834] bnx2 0000:04:00.1 em2: using MSIX
[   19.977498] IPv6: ADDRCONF(NETDEV_UP): em2: link is not ready
[   19.983241] bnx2i [04:00.01]: ISCSI_INIT passed
[   23.152176] bnx2 0000:04:00.1 em2: NIC Copper Link is Up, 1000 Mbps full duplex
[   23.155917] 
[   23.156859] IPv6: ADDRCONF(NETDEV_CHANGE): em2: link becomes ready
[  921.613351] bnx2 0000:05:00.0 em3: using MSIX
[  921.615719] IPv6: ADDRCONF(NETDEV_UP): em3: link is not ready
[  921.621526] bnx2i [05:00.00]: ISCSI_INIT passed
[ 1823.844585] bnx2 0000:04:00.0 em1: using MSIX
[ 1823.846980] IPv6: ADDRCONF(NETDEV_UP): em1: link is not ready
[ 1823.852526] bnx2i [04:00.00]: ISCSI_INIT passed
[ 1827.002048] bnx2 0000:04:00.0 em1: NIC Copper Link is Up, 1000 Mbps full duplex
[ 1827.005716] 
[ 1827.006650] IPv6: ADDRCONF(NETDEV_CHANGE): em1: link becomes ready
[ 1830.360623] scsi8 : iSCSI Initiator over TCP/IP
[ 1830.629405] scsi 8:0:0:0: Direct-Access     NETAPP   LUN              811a PQ: 0 ANSI: 5
[ 1830.635089] sd 8:0:0:0: [sdb] 41943040 512-byte logical blocks: (21.4 GB/20.0 GiB)
1830.639076] sd 8:0:0:0: [sdb] 4096-byte physical blocks
[ 1830.643135] sd 8:0:0:0: [sdb] Write Protect is off
[ 1830.646109] sd 8:0:0:0: [sdb] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
[ 1830.656886]  sdb: sdb1 sdb2
[ 1830.663240] sd 8:0:0:0: [sdb] Attached SCSI disk
[ 1831.107779] bio: create slab <bio-1> at 1

Generating "/run/initramfs/rdsosreport.txt"

Version-Release number of selected component (if applicable):
dracut-033-67.el7

How reproducible:
100%

Steps to Reproduce:
1.Install RHEL7 on a BFS server.
2.Try to boot the newly installed server

Comment 2 Bruno Goncalves 2014-01-03 09:34:04 UTC
Kernel command line for booting up.

Kernel command line: BOOT_IMAGE=/vmlinuz-3.10.0-64.el7.x86_64 root=/dev/mapper/rhel_storageqe--11-root ro ifname=em1:e8:39:35:20:de:ca iscsi_firmware rd.lvm.lv=rhel_storageqe-11/root vconsole.font=latarcyrheb-sun16 crashkernel=auto rd.lvm.lv=rhel_storageqe-11/swap console=ttyS1,115200 ip=em1:dhcp vconsole.keymap=us LANG=en_US.UTF-8

Comment 3 Bruno Goncalves 2014-01-03 09:50:36 UTC
Last lines from dracut debug messages.

/bin/dracut-emergency@15(): export _rdshell_name=dracut action=Boot hook=emergency 
/bin/dracut-emergency@15(): _rdshell_name=dracut 
/bin/dracut-emergency@15(): action=Boot 
/bin/dracut-emergency@15(): hook=emergency 
/bin/dracut-emergency@17(): source_hook emergency 
/lib/dracut-lib.sh@402(source_hook): local _dir 
/lib/dracut-lib.sh@403(source_hook): _dir=emergency 
/lib/dracut-lib.sh@403(source_hook): shift 
/lib/dracut-lib.sh@404(source_hook): source_all /lib/dracut/hooks/emergency 
/lib/dracut-lib.sh@391(source_all): local f 
/lib/dracut-lib.sh@392(source_all): local _dir 
/lib/dracut-lib.sh@393(source_all): _dir=/lib/dracut/hooks/emergency 
/lib/dracut-lib.sh@393(source_all): shift 
/lib/dracut-lib.sh@394(source_all): '[' /lib/dracut/hooks/emergency ']' 
/lib/dracut-lib.sh@394(source_all): '[' -d //lib/dracut/hooks/emergency ']' 
/lib/dracut-lib.sh@395(source_all): for f in '"/$_dir"/*.sh' 
/lib/dracut-lib.sh@395(source_all): '[' -e //lib/dracut/hooks/emergency/50-plymouth-emergency.sh ']' 
/lib/dracut-lib.sh@395(source_all): . //lib/dracut/hooks/emergency/50-plymouth-emergency.sh 
///lib/dracut/hooks/emergency/50-plymouth-emergency.sh@4(source): plymouth --hide-splash 
///lib/dracut/hooks/emergency/50-plymouth-emergency.sh@4(source): : 
/lib/dracut-lib.sh@395(source_all): for f in '"/$_dir"/*.sh' 
/lib/dracut-lib.sh@395(source_all): '[' -e '//lib/dracut/hooks/emergency/80-\x2fdev\x2fdisk\x2fby-uuid\x2fc3efa0bc-4cf6-49dc-972b-2d6593e71001.sh' ']' 
/lib/dracut-lib.sh@395(source_all): . '//lib/dracut/hooks/emergency/80-\x2fdev\x2fdisk\x2fby-uuid\x2fc3efa0bc-4cf6-49dc-972b-2d6593e71001.sh' 
///lib/dracut/hooks/emergency/80-\x2fdev\x2fdisk\x2fby-uuid\x2fc3efa0bc-4cf6-49dc-972b-2d6593e71001'[' -e /dev/disk/by-uuid/c3efa0bc-4cf6-49dc-972b-2d6593e71001 ']' 
/lib/dracut-lib.sh@395(source_all): for f in '"/$_dir"/*.sh' 
/lib/dracut-lib.sh@395(source_all): '[' -e '//lib/dracut/hooks/emergency/80-\x2fdev\x2fmapper\x2frhel_storageqe--11-root.sh' ']' 
/lib/dracut-lib.sh@395(source_all): . '//lib/dracut/hooks/emergency/80-\x2fdev\x2fmapper\x2frhel_storageqe--11-root.sh' 
///lib/dracut/hooks/emergency/80-\x2fdev\x2fmapper\x2frhel_storageqe--11-root.sh@1(source): '[' -e /dev/mapper/rhel_storageqe--11-root ']' 
/lib/dracut-lib.sh@395(source_all): for f in '"/$_dir"/*.sh' 
/lib/dracut-lib.sh@395(source_all): '[' -e '//lib/dracut/hooks/emergency/80-\x2fdev\x2fmapper\x2frhel_storageqe--11-swap.sh' ']' 
/lib/dracut-lib.sh@395(source_all): . '//lib/dracut/hooks/emergency/80-\x2fdev\x2fmapper\x2frhel_storageqe--11-swap.sh' 
///lib/dracut/hooks/emergency/80-\x2fdev\x2fmapper\x2frhel_storageqe--11-swap.sh@1(source): '[' -e /dev/mapper/rhel_storageqe--11-swap ']' 
/lib/dracut-lib.sh@395(source_all): for f in '"/$_dir"/*.sh' 
/lib/dracut-lib.sh@395(source_all): '[' -e '//lib/dracut/hooks/emergency/80-\x2fdev\x2frhel_storageqe-11\x2froot.sh' ']' 
/lib/dracut-lib.sh@395(source_all): . '//lib/dracut/hooks/emergency/80-\x2fdev\x2frhel_storageqe-11\x2froot.sh' 
///lib/dracut/hooks/emergency/80-\x2fdev\x2frhel_storageqe-11\x2froot.sh@1(source): '[' -e /dev/rhel_storageqe-11/root ']' 
/lib/dracut-lib.sh@395(source_all): for f in '"/$_dir"/*.sh' 
/lib/dracut-lib.sh@395(source_all): '[' -e '//lib/dracut/hooks/emergency/80-\x2fdev\x2frhel_storageqe-11\x2fswap.sh' ']' 
/lib/dracut-lib.sh@395(source_all): . '//lib/dracut/hooks/emergency/80-\x2fdev\x2frhel_storageqe-11\x2fswap.sh' 
///lib/dracut/hooks/emergency/80-\x2fdev\x2frhel_storageqe-11\x2fswap.sh@1(source): '[' -e /dev/rhel_storageqe-11/swap ']' 
/bin/dracut-emergency@20(): getargbool 1 rd.shell -d -y rdshell 
/lib/dracut-lib.sh@215(getargbool): local _b 
/lib/dracut-lib.sh@216(getargbool): unset _b 
/lib/dracut-lib.sh@217(getargbool): local _default 
/lib/dracut-lib.sh@218(getargbool): _default=1 
/lib/dracut-lib.sh@218(getargbool): shift 
//lib/dracut-lib.sh@219(getargbool): getarg rd.shell -d -y rdshell 
//lib/dracut-lib.sh@164(getarg): debug_off 
//lib/dracut-lib.sh@9(debug_off): set +x 
//lib/dracut-lib.sh@204(getarg): return 1 
/lib/dracut-lib.sh@219(getargbool): _b= 
/lib/dracut-lib.sh@220(getargbool): '[' 1 -ne 0 -a -z '' ']' 
/lib/dracut-lib.sh@220(getargbool): _b=1 
/lib/dracut-lib.sh@221(getargbool): '[' -n 1 ']' 
/lib/dracut-lib.sh@222(getargbool): '[' 1 = 0 ']' 
/lib/dracut-lib.sh@223(getargbool): '[' 1 = no ']' 
/lib/dracut-lib.sh@224(getargbool): '[' 1 = off ']' 
/lib/dracut-lib.sh@226(getargbool): return 0 
/bin/dracut-emergency@21(): echo 
 
/bin/dracut-emergency@22(): rdsosreport 
Generating "/run/initramfs/rdsosreport.txt"

Comment 5 Bruno Goncalves 2014-01-07 14:56:37 UTC
Created attachment 846726 [details]
rdsosreport.txt with rd.debug

Comment 6 Eddie Wai 2014-01-09 22:42:52 UTC
Created attachment 847900 [details]
rdsosreport.txt with rd.debug from the first boot with bnx2i

With RHEL7.0 ss1, I'm seeing the same problem as Bruno reported for iSCSI BFS via bnx2i.

Once it drops to the shell, I see that the ip link from the corresponding ethernet interface is UP with the iSCSI disk established.  Running iscsistart -b again fails:

dracut:/# iscsistart -b
iscsistart: version 6.2.0.873-14
iscsistart: Logging into iqn.2013.com.broadcom.t710:rhel.ram2 172.16.1.1:3260,1
iscsistart: initiator reported error (15 - session exists)

I've confirmed that the session is indeed present in the /sys/class/iscsi_session.

The error seems to be unrelated to the iSCSI disk establishment.

Comment 7 Bruno Goncalves 2014-01-17 07:49:24 UTC
I could reproduce this issue on both iSCSI boot servers (BFS bnx2i and BFS L2), the problem seems to be with invalid LVM partitions.

On BFS bnx2i I installed RHEL-6.5 and then I could delete the invalid data, after this I could boot RHEL-7 on the server.
On BFS L2 I didn't clean the LVM because I'd like to have a server to try the fix.

Comment 9 Harald Hoyer 2014-01-20 14:18:33 UTC
dracut-033-85.el7

Comment 11 Bruno Goncalves 2014-01-22 13:31:48 UTC
Tested with dracut-033-85.el7 and now it seems not even iSCSI session is established

Comment 12 Bruno Goncalves 2014-01-22 13:33:21 UTC
Created attachment 853880 [details]
rdsosreport_dracut-033-85.txt

Comment 15 Harald Hoyer 2014-01-23 08:44:38 UTC
dracut-033-86.el7

Comment 16 Bruno Goncalves 2014-01-27 12:15:32 UTC
The problem seems to be fixed on dracut-033-88.el7, now we are hitting bz#1058270.

Comment 17 Ludek Smid 2014-06-13 09:32:13 UTC
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.


Note You need to log in before you can comment on or make changes to this bug.