Bug 104815 - up2date refuses to install perl-5.8.0-88.3 with bad require for perl-NDBM_File
Summary: up2date refuses to install perl-5.8.0-88.3 with bad require for perl-NDBM_File
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: perl   
(Show other bugs)
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chip Turner
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: Security
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-22 15:24 UTC by Frank Swasey
Modified: 2007-04-18 16:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-03 14:39:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Frank Swasey 2003-09-22 15:24:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
up2date -u fails with the following message:

Unresolvable chain of dependencies:
perl-5.8.0-88.3                          requires perl-NDBM_File <= 1:1.75-34.99.6

# rpm -q perl-NDBM_File
perl-NDBM_File-1.75-34.99.6

Apparently a "1:" got prefixed to the require string in the perl spec file.


Version-Release number of selected component (if applicable):
perl-5.8.0-88.3

How reproducible:
Always

Steps to Reproduce:
1.up2date -u
2.
3.
    

Actual Results:  Fetching package list for channel: redhat-linux-i386-9...
########################################
 
Fetching Obsoletes list for channel: redhat-linux-i386-9...
########################################
 
Testing package set / solving RPM inter-dependencies...
There was a package dependency problem. The message was:
 
Unresolvable chain of dependencies:
perl-5.8.0-88.3                          requires perl-NDBM_File <= 1:1.75-34.99.6


Expected Results:  The updated perl packages should have been installed.

Additional info:

perl-5.8.0-88.3 was released to fix a security bug -- that makes this a security
problem.

Comment 1 Chip Turner 2003-09-24 17:36:17 UTC
this is caused by the perl-NDBM_File not being removed on an upgrade from RH7.x
to RH8 or RH9.  The solution is to rpm -e perl-NDBM_File by hand; up2date should
then work.

Comment 2 Frank Swasey 2003-09-24 17:41:32 UTC
Ah.  Yes, removing the perl-NDBM_File rpm did allow the up2date to work.


Note You need to log in before you can comment on or make changes to this bug.