Bug 1048187 - Switch User does not work from cinnamon when gdm is the active display manager
Summary: Switch User does not work from cinnamon when gdm is the active display manager
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: cinnamon
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: leigh scott
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-03 11:01 UTC by Tim Wegener
Modified: 2014-01-08 22:55 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-03 13:42:19 UTC
Type: Bug


Attachments (Terms of Use)

Description Tim Wegener 2014-01-03 11:01:58 UTC
When using the cinnamon desktop in conjunction with the gdm display manager:

1. Go to the main menu.
2. Click the "Logout" button ("Leave the sesion")
3. Click the "Switch User" button.

Nothing happens.
Nothing new appears in ~/.xsession-errors nor in /var/log/ either.

Instead, it should return to the gdm login screen and allow switching to a different user session.


cinnamon-2.0.14-4.fc20.x86_64
gdm-3.10.0.1-1.fc20.x86_64
systemd-208-9.fc20.x86_64


This is consistently reproducible.

This used to work in Fedora 18, so is a regression.

Note that by contrast, Switch User does work if using lightdm instead of gdm.
(Unfortunately lightdm does not look as pretty as gdm.)

Comment 1 leigh scott 2014-01-03 11:53:46 UTC
Cinnamon doesn't fully support gdm.

< This used to work in Fedora 18, so is a regression.

F18 cinnamon used gnome components, cinnamon-2 uses it's own cinnamon components.
There has also been major changes to gdm, gdm is no longer a standalone program and requires gnome-shell to function.

Comment 2 leigh scott 2014-01-03 12:03:46 UTC
*** Bug 1048192 has been marked as a duplicate of this bug. ***

Comment 3 Tim Wegener 2014-01-03 13:12:40 UTC
(In reply to leigh scott from comment #1)
> Cinnamon doesn't fully support gdm.
> 
> < This used to work in Fedora 18, so is a regression.
> 
> F18 cinnamon used gnome components, cinnamon-2 uses it's own cinnamon
> components.
> There has also been major changes to gdm, gdm is no longer a standalone
> program and requires gnome-shell to function.


This doesn't change the objective fact that this is a regression, whether or not it was a deliberate decision.

gdm still works in combination with cinnamon, except for this.
Nothing prevents cinnamon being used with gdm, nor warns that it is an unsupported combination.
The button is still present, but silently does nothing.

Therefore it clearly *is* a bug.

=> Changing resolution status from "NOTABUG" to "WONTFIX".

Comment 4 Tim Wegener 2014-01-03 13:22:19 UTC
(In reply to Tim Wegener from comment #3)
> (In reply to leigh scott from comment #1)
> > Cinnamon doesn't fully support gdm.
> > 
> > < This used to work in Fedora 18, so is a regression.
> > 
> > F18 cinnamon used gnome components, cinnamon-2 uses it's own cinnamon
> > components.
> > There has also been major changes to gdm, gdm is no longer a standalone
> > program and requires gnome-shell to function.
> 
> 
> This doesn't change the objective fact that this is a regression, whether or
> not it was a deliberate decision.
> 
> gdm still works in combination with cinnamon, except for this.
> Nothing prevents cinnamon being used with gdm, nor warns that it is an
> unsupported combination.
> The button is still present, but silently does nothing.
> 
> Therefore it clearly *is* a bug.
> 
> => Changing resolution status from "NOTABUG" to "WONTFIX".


In fact I'm going to reopen this, since the Switch User button should at least issue a message saying why it does not work in this situation, i.e. that this is not supported with gdm, rather than silently doing nothing.

Comment 5 leigh scott 2014-01-03 13:42:19 UTC
Patches exist but I'm not willing to risk introducing any regression to lightdm support.
https://github.com/linuxmint/cinnamon-session/pull/9

The patch is too messed up to use eg: uneeded changes to indents and the way it supports lightdm

Comment 6 m.oliver 2014-01-08 13:12:30 UTC
Until F19, it used to be possible to change users via the "User Applet".  Now however, in F20, Change User from the User Applet simply locks the screen.

This is getting worse.  So far, the behavior was simply inconsistent.  Now I don't know how to switch the user from with cinnamon.

Should this be filed as a bug against gdm then?  Probably nothing will result from it, but I believe the distribution default login manager should play nicely with other window managers as well, after all it did for a while, so there is no reason why it should not continue to do so...

Comment 7 m.oliver 2014-01-08 22:55:05 UTC
Sorry, after update to latest cinnamon, switching the user via the User Applet works again as it did in F19.  Sorry for the noise.


Note You need to log in before you can comment on or make changes to this bug.