Bug 1048217 - CMIS WAR for CR1 is cannot be deployed
Summary: CMIS WAR for CR1 is cannot be deployed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: ModeShape
Version: 6.0.0
Hardware: All
OS: All
unspecified
urgent
Target Milestone: CR2
: 6.0
Assignee: Horia Chiorean
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1034553
TreeView+ depends on / blocked
 
Reported: 2014-01-03 12:13 UTC by Filip Nguyen
Modified: 2014-07-09 05:00 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-14 03:05:00 UTC
Type: Bug


Attachments (Terms of Use)
The new CMIS war that cannot be deployed (8.78 MB, application/zip)
2014-01-03 12:15 UTC, Filip Nguyen
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1034553 1 None None None 2021-01-20 06:05:38 UTC
Red Hat Issue Tracker MODE-2129 0 Blocker Closed CMIS web application cannot be deployed in EAP 6.1.1 2014-02-14 03:04:04 UTC

Internal Links: 1034553

Description Filip Nguyen 2014-01-03 12:13:23 UTC
This blocks 1034553.

The modeshape in CR1 bundeled new version of modeshape-cmis.war which fails to depoy (to neither CR1 nor ER5). Exception:

13:13:03,193 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-2) MSC000001: Failed to start service jboss.deployment.unit."modeshape-cmis-new.war".INSTALL: org.jboss.msc.service.StartException in service jboss.deployment.unit."modeshape-cmis-new.war".INSTALL: JBAS018733: Failed to process phase INSTALL of deployment "modeshape-cmis-new.war"
	at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:127) [jboss-as-server-7.2.1.Final-redhat-10.jar:7.2.1.Final-redhat-10]
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) [rt.jar:1.7.0_07]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) [rt.jar:1.7.0_07]
	at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_07]
Caused by: javax.xml.ws.WebServiceException: org.apache.cxf.jaxws.JaxWsConfigurationException: The @javax.jws.WebMethod(exclude=true) cannot be used on a service endpoint interface. Method: createType
	at org.apache.cxf.jaxws.EndpointImpl.doPublish(EndpointImpl.java:368)
	at org.jboss.wsf.stack.cxf.deployment.EndpointImpl.doPublish(EndpointImpl.java:66)
	at org.apache.cxf.jaxws.EndpointImpl.publish(EndpointImpl.java:250)
	at org.apache.cxf.jaxws.EndpointImpl.publish(EndpointImpl.java:536)
	at org.jboss.wsf.stack.cxf.configuration.NonSpringBusHolder.configure(NonSpringBusHolder.java:116)
	at org.jboss.wsf.stack.cxf.deployment.aspect.BusDeploymentAspect.startDeploymentBus(BusDeploymentAspect.java:128)
	at org.jboss.wsf.stack.cxf.deployment.aspect.BusDeploymentAspect.start(BusDeploymentAspect.java:67)
	at org.jboss.as.webservices.deployers.AspectDeploymentProcessor.deploy(AspectDeploymentProcessor.java:74)
	at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:120) [jboss-as-server-7.2.1.Final-redhat-10.jar:7.2.1.Final-redhat-10]
	... 5 more
Caused by: org.apache.cxf.jaxws.JaxWsConfigurationException: The @javax.jws.WebMethod(exclude=true) cannot be used on a service endpoint interface. Method: createType
	at org.apache.cxf.jaxws.support.JaxWsServiceConfiguration.isOperation(JaxWsServiceConfiguration.java:202)
	at org.apache.cxf.service.factory.ReflectionServiceFactoryBean.isValidMethod(ReflectionServiceFactoryBean.java:1935)
	at org.apache.cxf.service.factory.ReflectionServiceFactoryBean.createInterface(ReflectionServiceFactoryBean.java:983)
	at org.apache.cxf.service.factory.ReflectionServiceFactoryBean.buildServiceFromClass(ReflectionServiceFactoryBean.java:469)
	at org.apache.cxf.jaxws.support.JaxWsServiceFactoryBean.buildServiceFromClass(JaxWsServiceFactoryBean.java:690)
	at org.apache.cxf.service.factory.ReflectionServiceFactoryBean.initializeServiceModel(ReflectionServiceFactoryBean.java:540)
	at org.apache.cxf.service.factory.ReflectionServiceFactoryBean.create(ReflectionServiceFactoryBean.java:252)
	at org.apache.cxf.jaxws.support.JaxWsServiceFactoryBean.create(JaxWsServiceFactoryBean.java:205)
	at org.apache.cxf.frontend.AbstractWSDLBasedEndpointFactory.createEndpoint(AbstractWSDLBasedEndpointFactory.java:101)
	at org.apache.cxf.frontend.ServerFactoryBean.create(ServerFactoryBean.java:159)
	at org.apache.cxf.jaxws.JaxWsServerFactoryBean.create(JaxWsServerFactoryBean.java:211)
	at org.apache.cxf.jaxws.EndpointImpl.getServer(EndpointImpl.java:453)
	at org.apache.cxf.jaxws.EndpointImpl.doPublish(EndpointImpl.java:333)
	... 13 more

13:13:03,206 ERROR [org.jboss.as.server] (DeploymentScanner-threads - 1) JBAS015870: Deploy of deployment "modeshape-cmis-new.war" was rolled back with the following failure message: 
{"JBAS014671: Failed services" => {"jboss.deployment.unit.\"modeshape-cmis-new.war\".INSTALL" => "org.jboss.msc.service.StartException in service jboss.deployment.unit.\"modeshape-cmis-new.war\".INSTALL: JBAS018733: Failed to process phase INSTALL of deployment \"modeshape-cmis-new.war\"
    Caused by: javax.xml.ws.WebServiceException: org.apache.cxf.jaxws.JaxWsConfigurationException: The @javax.jws.WebMethod(exclude=true) cannot be used on a service endpoint interface. Method: createType
    Caused by: org.apache.cxf.jaxws.JaxWsConfigurationException: The @javax.jws.WebMethod(exclude=true) cannot be used on a service endpoint interface. Method: createType"}}

Comment 1 Filip Nguyen 2014-01-03 12:15:06 UTC
Created attachment 844933 [details]
The new CMIS war that cannot be deployed

Comment 2 Horia Chiorean 2014-01-03 12:26:15 UTC
According to https://issues.apache.org/jira/browse/CMIS-738 it seems Apache Chemistry (which is what ModeShape uses for CMIS) does not work with CXF.

I don't know if the statement "Disable CXF for this webapp and add the Sun JAX-WS RI jars." is something that can be done in the context of EAP 6.1.1 & modeshape-cmis.war. 

If this is not an option, the only solution I see is to remove the webapp from the ModeShape kit altogether.

Comment 3 Horia Chiorean 2014-01-03 12:37:34 UTC
In the context of DV, the CMIS web application *is not configured up front* (it was not part of the DV requirements). The only reason it's in the kit afaik. is to "offer extra functionality" in case clients want this.

So this would impact DV only if a client performed a manual deploy via CLI of the modeshape-cmis web application which is bundled atm.

Comment 5 JBoss JIRA Server 2014-01-07 17:45:25 UTC
Randall Hauch <rhauch@jboss.org> updated the status of jira MODE-2129 to Closed

Comment 6 belong 2014-01-08 06:22:29 UTC
Horia confirmed not required to be documented as a known issue in Release Notes - "CMIS isn't officially part of specs" - setting to requires_doc_text- accordingly.


Note You need to log in before you can comment on or make changes to this bug.