Bug 1048291 - nodejs-0.6 npm broken due to invalid cert
Summary: nodejs-0.6 npm broken due to invalid cert
Keywords:
Status: CLOSED DUPLICATE of bug 1046851
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Image
Version: 2.x
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Andy Goldstein
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-03 15:53 UTC by Ben Parees
Modified: 2015-05-15 00:36 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-04 01:40:32 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Ben Parees 2014-01-03 15:53:06 UTC
Description of problem:
nodejs cartridges fail during git push:

remote: npm info retry registry request attempt 3 at 10:31:49
remote: npm http GET https://registry.npmjs.org/express
remote: npm ERR! Error: SSL Error: CERT_UNTRUSTED
remote: npm ERR!     at ClientRequest.<anonymous> (/usr/lib/node_modules/npm/node_modules/request/main.js:440:26)

further discussion here:
https://github.com/isaacs/npm/issues/4379

Comment 1 Ben Parees 2014-01-03 18:17:56 UTC
Over to agoldste to pursue the packaging update.

Comment 2 Andy Goldstein 2014-01-03 19:39:47 UTC
The updated nodejs rpm (nodejs-0.6.20-3.el6oso.x86_64) is in the candidate repo now and can be tested.

Comment 3 Peter Ruan 2014-01-04 00:13:55 UTC
Still failed with devenv_4180

1 file changed, 1 insertion(+), 1 deletion(-)
[peter@unused-16-138 <CUCUSHIFT_ORIGIN> app1]# git push
Counting objects: 5, done.
Delta compression using up to 4 threads.
Compressing objects: 100% (3/3), done.
Writing objects: 100% (3/3), 294 bytes | 0 bytes/s, done.
Total 3 (delta 2), reused 0 (delta 0)
remote: Stopping NodeJS cartridge
remote: Saving away previously installed Node modules
remote: Building git ref 'master', commit fc572cf
remote: Building NodeJS cartridge
remote: npm info it worked if it ends with ok
remote: npm info using npm@1.1.37
remote: npm info using node@v0.6.20
remote: npm info preinstall OpenShift-Sample-App@1.0.0
remote: npm info retry registry request attempt 1 at 19:08:19
remote: npm http GET https://registry.npmjs.org/express
remote: npm info retry will retry, error on last attempt: Error: SSL Error: CERT_UNTRUSTED
remote: npm info retry registry request attempt 2 at 19:08:29
remote: npm http GET https://registry.npmjs.org/express
remote: npm info retry will retry, error on last attempt: Error: SSL Error: CERT_UNTRUSTED
remote: npm info retry registry request attempt 3 at 19:09:30
remote: npm http GET https://registry.npmjs.org/express
remote: npm ERR! Error: SSL Error: CERT_UNTRUSTED
remote: npm ERR!     at ClientRequest.<anonymous> (/usr/lib/node_modules/npm/node_modules/request/main.js:440:26)
remote: npm ERR!     at ClientRequest.g (events.js:156:14)
remote: npm ERR!     at ClientRequest.emit (events.js:67:17)
remote: npm ERR!     at HTTPParser.parserOnIncomingClient [as onIncoming] (http.js:1256:7)
remote: npm ERR!     at HTTPParser.parserOnHeadersComplete [as onHeadersComplete] (http.js:91:29)
remote: npm ERR!     at CleartextStream.socketOnData [as ondata] (http.js:1288:20)
remote: npm ERR!     at CleartextStream._push (tls.js:375:27)
remote: npm ERR!     at SecurePair.cycle (tls.js:734:20)
remote: npm ERR!     at EncryptedStream.write (tls.js:130:13)
remote: npm ERR!     at Socket.ondata (stream.js:38:26)
remote: npm ERR!  [Error: SSL Error: CERT_UNTRUSTED]
remote: npm ERR! You may report this log at:
remote: npm ERR!     <http://github.com/isaacs/npm/issues>
remote: npm ERR! or email it to:
remote: npm ERR!     <npm-@googlegroups.com>
remote: 
remote: npm ERR! System Linux 2.6.32-431.1.2.el6.x86_64
remote: npm ERR! command "node" "/usr/bin/npm" "install" "-d"
remote: npm ERR! cwd /var/lib/openshift/52c7501598725e4953000007/app-root/runtime/repo
remote: npm ERR! node -v v0.6.20
remote: npm ERR! npm -v 1.1.37
remote: npm ERR! message SSL Error: CERT_UNTRUSTED
remote: npm ERR! 
remote: npm ERR! Additional logging details can be found in:
remote: npm ERR!     /var/lib/openshift/52c7501598725e4953000007/app-root/runtime/repo/npm-debug.log
remote: npm ERR! not ok code undefined
remote: npm ERR! not ok code 1
remote: An error occurred executing 'gear postreceive' (exit code: 1)
remote: Error message: Failed to execute: 'control build' for /var/lib/openshift/52c7501598725e4953000007/nodejs
remote: 
remote: For more details about the problem, try running the command again with the '--trace' option.
To ssh://52c7501598725e4953000007@app1-pruan12.dev.rhcloud.com/~/git/app1.git/
   be4377b..fc572cf  master -> master

Comment 4 Dan McPherson 2014-01-04 01:40:32 UTC

*** This bug has been marked as a duplicate of bug 1046851 ***

Comment 5 Ben Parees 2014-01-04 04:22:45 UTC
appears to be working in devenv_4182


Note You need to log in before you can comment on or make changes to this bug.