Bug 1048541 - [rfe] [plugins] manage local repo (yum-utils repomanage)
Summary: [rfe] [plugins] manage local repo (yum-utils repomanage)
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf-plugins-extras   
(Show other bugs)
Version: rawhide
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
Assignee: Igor Gnatenko
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-04 23:23 UTC by Frank Murphy
Modified: 2015-02-23 23:27 UTC (History)
6 users (show)

Fixed In Version: dnf-plugins-extras-0.0.4-1.fc21
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-23 23:27:31 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Frank Murphy 2014-01-04 23:23:43 UTC
Description of problem: no repomanage equivalent (yum-utilis)
to manage "local.repo" number of foo.rpm rpms 
eg repomanage --keep=4 (keep 4 copied foo-1.1, foo1.2, etc..

Comment 1 Ales Kozumplik 2014-01-13 07:24:12 UTC
Depriortizing.

Comment 2 Honza Silhan 2014-11-24 12:36:16 UTC
*** Bug 991014 has been marked as a duplicate of this bug. ***

Comment 3 Igor Gnatenko 2015-01-21 14:54:33 UTC
I will implement this during February or early.

Comment 5 Igor Gnatenko 2015-01-25 14:50:26 UTC
https://github.com/rpm-software-management/dnf-plugins-extras/commit/a8d87c2fa322fd00abe8330ad4651a2d490a0370

Pushed to dnf-plugins-extras.

You can install this plugin by `dnf install dnf-plugins-extras-repomanage` when dnf-plugins-extras-0.0.2 will be in repos.

Comment 6 Fedora Update System 2015-01-25 18:55:14 UTC
dnf-plugins-extras-0.0.2-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/dnf-plugins-extras-0.0.2-1.fc21

Comment 7 Fedora Update System 2015-01-27 03:09:38 UTC
Package dnf-plugins-extras-0.0.2-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-extras-0.0.2-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-1266/dnf-plugins-extras-0.0.2-1.fc21
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2015-01-29 13:12:00 UTC
dnf-plugins-extras-0.0.3-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/dnf-plugins-extras-0.0.3-1.fc21

Comment 9 Fedora Update System 2015-02-13 11:00:52 UTC
dnf-plugins-extras-0.0.4-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/dnf-plugins-extras-0.0.4-1.fc21

Comment 10 Fedora Update System 2015-02-23 23:27:31 UTC
dnf-plugins-extras-0.0.4-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.