Bug 1048572 - dnf resolve failure
dnf resolve failure
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
20
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-05 05:31 EST by Germano Massullo
Modified: 2014-09-30 19:42 EDT (History)
5 users (show)

See Also:
Fixed In Version: dnf-0.4.11-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-11 03:47:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Germano Massullo 2014-01-05 05:31:13 EST
Description of problem:
I needed to know which packages provide:
- sandbox;
- seunshare
In both cases "dnf resolve" failed, instead yum successfully returned the name of the package.

Version-Release number of selected component (if applicable):
dnf-0.4.9-1.fc20.noarch


Actual results:
# dnf provides sandbox
No Matches found


# yum provides sandbox
[...]
policycoreutils-python-2.2.2-3.fc20.x86_64 : SELinux policy core python utilities
Repo         : fedora
Corrispondenza trovata in:
Nome file   : /usr/bin/sandbox

policycoreutils-python-2.2.4-5.fc20.x86_64 : SELinux policy core python utilities
Repo         : updates
Corrispondenza trovata in:
Nome file   : /usr/bin/sandbox


# dnf provides seunshare
No Matches found


# yum provides seunshare
[...]
policycoreutils-sandbox-2.2.2-3.fc20.x86_64 : SELinux sandbox utilities
Repo         : fedora
Corrispondenza trovata in:
Nome file   : /usr/sbin/seunshare

policycoreutils-sandbox-2.2.4-5.fc20.x86_64 : SELinux sandbox utilities
Repo         : updates
Corrispondenza trovata in:
Nome file   : /usr/sbin/seunshare
Comment 1 Ales Kozumplik 2014-01-06 02:26:08 EST
this is mainly a documentation issue, the 'yum provides sandbox' etc. command only succeeds because of a hidden/undocumented feature in Yum.
Comment 2 Ales Kozumplik 2014-01-06 04:27:21 EST
The different behavior is documented in 0d39e95, will be published along with the release of dnf-0.4.11.
Comment 3 Fedora Update System 2014-01-09 09:39:41 EST
dnf-0.4.11-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dnf-0.4.11-1.fc20
Comment 4 lnie 2014-01-10 01:23:53 EST
dnf-0.4.11-1.fc20 still unable to do the provides
Comment 5 Fedora Update System 2014-01-10 02:59:53 EST
Package dnf-0.4.11-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-0.4.11-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-0573/dnf-0.4.11-1.fc20
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2014-01-11 03:47:48 EST
dnf-0.4.11-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.