Bug 1048656 - duplicity prints a non-fatal error message
Summary: duplicity prints a non-fatal error message
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: duplicity
Version: 20
Hardware: Unspecified
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Rahul Sundaram
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1052319 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-06 02:58 UTC by Cristian Ciupitu
Modified: 2014-01-31 04:27 UTC (History)
4 users (show)

Fixed In Version: duplicity-0.6.22-5.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-31 04:25:53 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1267339 None None None Never

Description Cristian Ciupitu 2014-01-06 02:58:44 UTC
Description of problem:
duplicity prints a non-fatal error message.

Version-Release number of selected component (if applicable):
duplicity-0.6.22-1.fc20.x86_64

How reproducible:
At least once, but it probably happens every time.

Steps to Reproduce:
1. duplicity restore --file-to-restore xxx file:///yyy/ /tmp/zzz/

Actual results:
Import of duplicity.backends.dpbxbackend Failed: No module named dropbox

Expected results:
No message. No news is good news.

Additional info:
I don't think it matters, but the backup was create under Fedora 19.

Comment 1 Dave Allan 2014-01-09 03:35:39 UTC
FWIW, I'm seeing this on the latest F19 package as well.  Installing the python-dropbox package makes it go away, so it looks like a missing rpm dep to me.

Comment 2 Cristian Ciupitu 2014-01-09 04:10:50 UTC
That's good to know, although I disagree on making that package a
dependency. If the program is modular, it should remain modular, so that
the user doesn't have to install all the modules (for Dropbox, Amazon S3
etc.).

Comment 3 Rahul Sundaram 2014-01-09 05:32:01 UTC
[I only recently took over this package]

The python modules are pretty small and duplicity isn't based on sub packages that can be added or removed at will and the error when one of the modules aren't installed isn't very gracious so I am going to look at adding all the necessary modules as dependencies which is what other distributions have already done.

Many of them such as python-boto for Amazon s3 services are unconditionally installed regardless of whether that particular user is using that backend, so this isn't really a major change and shouldn't add any real significant size difference to the install. I don't intend to push such a change to the existing release however.  Let me know if anyone has other suggestions on handling this.

Comment 4 Cristian Ciupitu 2014-01-09 05:47:59 UTC
(In reply to Rahul Sundaram from comment #3)
> Let me know if anyone has other suggestions on handling this.

Why not ask upstream to remove that message or at least make it
friendlier? If I don't need Dropbox, I shouldn't care if that module is
not available.

Comment 5 Rahul Sundaram 2014-01-09 05:55:08 UTC
Feel free to file that upstream directly.  Thanks!

Comment 6 Cristian Ciupitu 2014-01-09 06:36:30 UTC
https://bugs.launchpad.net/duplicity/+bug/1267339

Comment 7 Rahul Sundaram 2014-01-13 18:34:47 UTC
*** Bug 1052319 has been marked as a duplicate of this bug. ***

Comment 8 Miro Hrončok 2014-01-13 18:47:28 UTC
As this already depends on python-boto, I'd suggest to add python-dropbox to requires even for current Fedora release to silent this error message.

Later, if someone actually cares, you can solve such dependencies in more proper way.

Comment 9 Fedora Update System 2014-01-13 22:31:45 UTC
duplicity-0.6.22-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/duplicity-0.6.22-4.fc20

Comment 10 Fedora Update System 2014-01-13 23:01:56 UTC
duplicity-0.6.22-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/duplicity-0.6.22-4.fc19

Comment 11 lnie 2014-01-14 03:16:57 UTC
duplicity-0.6.22-4.fc20 works

Comment 12 Fedora Update System 2014-01-15 05:53:40 UTC
Package duplicity-0.6.22-4.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing duplicity-0.6.22-4.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-0789/duplicity-0.6.22-4.fc20
then log in and leave karma (feedback).

Comment 13 Fedora Update System 2014-01-17 21:13:09 UTC
duplicity-0.6.22-5.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/duplicity-0.6.22-5.fc20

Comment 14 Fedora Update System 2014-01-17 21:29:10 UTC
duplicity-0.6.22-5.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/duplicity-0.6.22-5.fc20

Comment 15 Fedora Update System 2014-01-17 21:30:02 UTC
duplicity-0.6.22-5.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/duplicity-0.6.22-5.fc19

Comment 16 Fedora Update System 2014-01-31 04:25:53 UTC
duplicity-0.6.22-5.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2014-01-31 04:27:35 UTC
duplicity-0.6.22-5.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.