Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1048674 - Jenkins build failed due to an error occurred executing 'gear postreceive' for all cartridges
Summary: Jenkins build failed due to an error occurred executing 'gear postreceive' fo...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Image
Version: 2.x
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Ben Parees
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-06 05:33 UTC by Lei Zhang
Modified: 2018-12-06 15:38 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-30 00:54:50 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Lei Zhang 2014-01-06 05:33:06 UTC
Description of problem:
Create one app embedded with jenkins client(e.g.,myjbossas7), do something change in local repo and git push, found jenkins build failed.

[rayzhang@ray myjbossas7]$ git add -A &&git commit -amp&&git push
[master f40ca2e] p
 1 file changed, 2 insertions(+), 2 deletions(-)
warning: push.default is unset; its implicit value is changing in
Git 2.0 from 'matching' to 'simple'. To squelch this message
and maintain the current behavior after the default changes, use:
  git config --global push.default matching
To squelch this message and adopt the new behavior now, use:
  git config --global push.default simple
See 'git help config' and search for 'push.default' for further information.
(the 'simple' mode was introduced in Git 1.7.11. Use the similar mode
'current' instead of 'simple' if you sometimes use older versions of Git)
Counting objects: 11, done.
Delta compression using up to 8 threads.
Compressing objects: 100% (5/5), done.
Writing objects: 100% (6/6), 441 bytes, done.
Total 6 (delta 4), reused 0 (delta 0)
remote: Executing Jenkins build.
remote: 
remote: You can track your build at https://jenkins-chunchen.dev.rhcloud.com/job/myjbossas7-build
remote: 
remote: Waiting for build to schedule.......
remote: **BUILD FAILED/CANCELLED**
remote: Please see the Jenkins log for more details via 'rhc tail'
remote: !!!!!!!!
remote: Deployment Halted!
remote: If the build failed before the deploy step, your previous
remote: build is still running.  Otherwise, your application may be
remote: partially deployed or inaccessible.
remote: Fix the build and try again.
remote: !!!!!!!!
remote: An error occurred executing 'gear postreceive' (exit code: 1)
remote: Error message: Failed to execute: 'control post-receive' for /var/lib/openshift/52ca122771f4a4807a0000de/jenkins-client
remote: 
remote: For more details about the problem, try running the command again with the '--trace' option.
To ssh://52ca122771f4a4807a0000de@myjbossas7-chunchen.dev.rhcloud.com/~/git/myjbossas7.git/
   9be9705..f40ca2e  master -> master

----------------Check jenkins.log---------------------- 
[jenkins-chunchen.dev.rhcloud.com 52ca127e71f4a4807a0000f7]\> cat  ./jenkins/logs/jenkins.log
Jan 05, 2014 9:55:01 PM hudson.plugins.openshift.OpenShiftCloud provision
INFO: Provisioning new node for workload = 2 and label = myjbossas7-build
Jan 05, 2014 9:55:01 PM hudson.plugins.openshift.OpenShiftCloud getOpenShiftConnection
INFO: Initiating Java Client Service - Configured for OpenShift Server https://localhost
Jan 05, 2014 9:55:01 PM com.openshift.internal.client.RestService request
INFO: Requesting GET with protocol 1.2 on https://localhost/broker/rest/api
Jan 05, 2014 9:55:01 PM com.openshift.internal.client.RestService request
INFO: Requesting GET with protocol 1.2 on https://localhost/broker/rest/user
Jan 05, 2014 9:55:01 PM com.openshift.internal.client.RestService request
INFO: Requesting GET with protocol 1.2 on https://localhost/broker/rest/domains
Jan 05, 2014 9:55:01 PM com.openshift.internal.client.RestService request
INFO: Requesting GET with protocol 1.2 on https://localhost/broker/rest/domain/chunchen/applications?include=cartridges
Jan 05, 2014 9:55:01 PM hudson.plugins.openshift.OpenShiftCloud getSlaves
INFO: Found existing slave for: myjbossas7bldr
Jan 05, 2014 9:55:01 PM hudson.plugins.openshift.OpenShiftCloud getSlave
INFO: slaveExists myjbossas7bldr myjbossas7bldr
Jan 05, 2014 9:55:01 PM hudson.plugins.openshift.OpenShiftCloud builderExists
INFO: Capacity remaining - checking for existing type...
Jan 05, 2014 9:55:01 PM hudson.plugins.openshift.OpenShiftCloud builderExists
INFO: Found an existing builder.  Not provisioning...
Jan 05, 2014 9:55:01 PM hudson.plugins.openshift.OpenShiftCloud provisionSlave
INFO: Slave exists. Not provisioning
Jan 05, 2014 9:55:01 PM hudson.plugins.openshift.OpenShiftCloud provision
INFO: Provisioned 0 new nodes
Jan 05, 2014 9:55:01 PM hudson.plugins.openshift.OpenShiftCloud cancelItem
INFO: Cancelling Item 
Jan 05, 2014 9:55:01 PM hudson.plugins.openshift.OpenShiftCloud cancelItem
WARNING: Build myjbossas7-build myjbossas7bldr has been canceled

Version-Release number of selected component (if applicable):
devenv_4185
devenv_4187

How reproducible:
always

Steps to Reproduce:
1.create one app and embed with jenkins-client
#rhc app create myjbossas7 jbossas-7 --enable-jenkins
2.change something in local git repo and git push
#sed -i 's/Welcome to/HI/g' src/main/webapp/index.html
#git add -A &&git commit -amp&&git push
3.

Actual results:
Jenkins build failed due to an error occurred executing 'gear postreceive'

Expected results:
Jenkins build should succeed without any error

Additional info:

Comment 1 Jhon Honce 2014-01-13 23:23:20 UTC
I could not reproduce with the directions given on latest devenv

Comment 2 Lei Zhang 2014-01-14 04:43:24 UTC
Still can reproduce this issue on INT(devenv_4217) and devenv_4219

==========Failed to git push:==========
remote: Syncing git content to other proxy gears
remote: Executing Jenkins build.
remote: 
remote: You can track your build at https://jenkins-chunchen.dev.rhcloud.com/job/myruby18s-build
remote: 
remote: Waiting for build to schedule...................................
remote: **BUILD FAILED/CANCELLED**
remote: Please see the Jenkins log for more details via 'rhc tail'
remote: !!!!!!!!
remote: Deployment Halted!
remote: If the build failed before the deploy step, your previous
remote: build is still running.  Otherwise, your application may be
remote: partially deployed or inaccessible.
remote: Fix the build and try again.
remote: !!!!!!!!
remote: An error occurred executing 'gear postreceive' (exit code: 1)
remote: Error message: Failed to execute: 'control post-receive' for /var/lib/openshift/52d4be8aa3d9bd378c000007/jenkins-client
remote: 
remote: For more details about the problem, try running the command again with the '--trace' option.
To ssh://52d4be8aa3d9bd378c000007@myruby18s-chunchen.dev.rhcloud.com/~/git/myruby18s.git/
   888a08b..f2aa0c3  master -> master

==========./jenkins/logs/jenkins.log==========
Jan 13, 2014 11:38:58 PM hudson.plugins.openshift.OpenShiftCloud createConnection
INFO: Using credentials system_builder:rtYRtqiSbSIT
Jan 13, 2014 11:38:58 PM hudson.plugins.openshift.OpenShiftCloud reloadConfig
INFO: Reload ResponseCode: 200
Jan 13, 2014 11:38:58 PM hudson.plugins.openshift.OpenShiftCloud reloadConfig
INFO: Config reload result: 
Jan 13, 2014 11:38:58 PM hudson.plugins.openshift.OpenShiftSlave <init>
INFO: Creating slave with 15mins time-to-live
Jan 13, 2014 11:38:58 PM com.openshift.internal.client.RestService request
INFO: Requesting GET with protocol 1.2 on https://localhost/broker/rest/cartridges
Jan 13, 2014 11:38:59 PM hudson.plugins.openshift.OpenShiftSlave createApp
INFO: Creating builder application ruby-1.8 myruby18sbldr chunchen of size small ...
Jan 13, 2014 11:38:59 PM com.openshift.internal.client.RestService request
INFO: Requesting POST with protocol 1.2 on https://localhost/broker/rest/domain/chunchen/applications?include=cartridges
Jan 13, 2014 11:39:27 PM hudson.plugins.openshift.OpenShiftSlave createApp
INFO: Stopping application on builder gear ...
Jan 13, 2014 11:39:27 PM com.openshift.internal.client.RestService request
INFO: Requesting POST with protocol 1.2 on https://localhost/broker/rest/domain/chunchen/application/myruby18sbldr/events
Jan 13, 2014 11:39:28 PM hudson.plugins.openshift.OpenShiftSlave connect
INFO: Connecting to slave myruby18sbldr...
Jan 13, 2014 11:39:28 PM com.openshift.internal.client.RestService request
INFO: Requesting GET with protocol 1.2 on https://localhost/broker/rest/domain/chunchen/application/myruby18sbldr/gear_groups
Jan 13, 2014 11:39:28 PM hudson.plugins.openshift.OpenShiftSlave connect
INFO: Established UUID = 52d4bf63a3d9bd378c000057
Jan 13, 2014 11:39:33 PM hudson.plugins.openshift.OpenShiftSlave connect
INFO: Checking to see if slave DNS for myruby18sbldr-chunchen.dev.rhcloud.com is resolvable ... (timeout: 300000ms)
Jan 13, 2014 11:39:33 PM hudson.plugins.openshift.OpenShiftSlave connect
INFO: Slave DNS resolved - myruby18sbldr-chunchen.dev.rhcloud.com/10.137.72.75
Jan 13, 2014 11:39:33 PM hudson.plugins.openshift.OpenShiftCloud provision
INFO: Provisioned 1 new nodes
Jan 13, 2014 11:39:33 PM hudson.slaves.NodeProvisioner update
INFO: Started provisioning myruby18s-build from OpenShift Cloud with 2 executors. Remaining excess workload:-1.0
Jan 13, 2014 11:39:33 PM hudson.plugins.openshift.OpenShiftComputer <init>
INFO: Creating Computer
Jan 13, 2014 11:39:33 PM hudson.plugins.openshift.OpenShiftComputerLauncher launch
INFO: Launching slave...
Jan 13, 2014 11:39:33 PM hudson.plugins.openshift.OpenShiftComputerLauncher launch
INFO: Checking availability of computer hudson.plugins.openshift.OpenShiftSlave@85ed673e
Jan 13, 2014 11:39:33 PM hudson.plugins.openshift.OpenShiftComputerLauncher launch
INFO: Checking SSH access to application myruby18sbldr-chunchen.dev.rhcloud.com
Jan 13, 2014 11:39:33 PM hudson.plugins.openshift.OpenShiftComputerLauncher launch
INFO: Connecting via SSH '52d4bf63a3d9bd378c000057' 'myruby18sbldr-chunchen.dev.rhcloud.com' '/var/lib/openshift/52d4bec2a3d9bd378c000028/app-root/data/.ssh/jenkins_id_rsa'
Jan 13, 2014 11:39:33 PM hudson.slaves.NodeProvisioner update
INFO: myruby18s-build provisioning successfully completed. We have now 1 computer(s)
Jan 13, 2014 11:39:35 PM hudson.plugins.openshift.OpenShiftComputerLauncher launch
INFO: Connected via SSH.
Jan 13, 2014 11:39:35 PM hudson.plugins.openshift.OpenShiftComputerLauncher launch
INFO: Exec mkdir -p $OPENSHIFT_DATA_DIR/jenkins && cd $OPENSHIFT_DATA_DIR/jenkins && rm -f slave.jar && wget -q --no-check-certificate https://jenkins-chunchen.dev.rhcloud.com/jnlpJars/slave.jar
Jan 13, 2014 11:39:37 PM hudson.plugins.openshift.OpenShiftCloud provision
INFO: Provisioning new node for workload = 2 and label = myruby18s-build
Jan 13, 2014 11:39:37 PM hudson.plugins.openshift.OpenShiftCloud getOpenShiftConnection
INFO: Initiating Java Client Service - Configured for OpenShift Server https://localhost
Jan 13, 2014 11:39:37 PM com.openshift.internal.client.RestService request
INFO: Requesting GET with protocol 1.2 on https://localhost/broker/rest/api
Jan 13, 2014 11:39:37 PM com.openshift.internal.client.RestService request
INFO: Requesting GET with protocol 1.2 on https://localhost/broker/rest/user
Jan 13, 2014 11:39:37 PM com.openshift.internal.client.RestService request
INFO: Requesting GET with protocol 1.2 on https://localhost/broker/rest/domains
Jan 13, 2014 11:39:37 PM com.openshift.internal.client.RestService request
INFO: Requesting GET with protocol 1.2 on https://localhost/broker/rest/domain/chunchen/applications?include=cartridges
Jan 13, 2014 11:39:37 PM hudson.plugins.openshift.OpenShiftCloud getSlaves
INFO: Found existing slave for: myruby18sbldr
Jan 13, 2014 11:39:37 PM hudson.plugins.openshift.OpenShiftCloud getSlave
INFO: slaveExists myruby18sbldr myruby18sbldr
Jan 13, 2014 11:39:37 PM hudson.plugins.openshift.OpenShiftCloud builderExists
INFO: Capacity remaining - checking for existing type...
Jan 13, 2014 11:39:37 PM hudson.plugins.openshift.OpenShiftCloud builderExists
INFO: Found an existing builder.  Not provisioning...
Jan 13, 2014 11:39:37 PM hudson.plugins.openshift.OpenShiftCloud provisionSlave
INFO: Slave exists. Not provisioning
Jan 13, 2014 11:39:37 PM hudson.plugins.openshift.OpenShiftCloud provision
INFO: Provisioned 0 new nodes
Jan 13, 2014 11:39:37 PM hudson.plugins.openshift.OpenShiftCloud cancelItem
INFO: Cancelling Item 
Jan 13, 2014 11:39:37 PM hudson.plugins.openshift.OpenShiftCloud cancelItem
WARNING: Build myruby18s-build myruby18sbldr has been canceled

===========./app-root/data/logs/slaves/myruby18sbldr/slave.log================
Attempting to connect slave...
Transferring slave.jar file...
Executing slave jar to make connection...
ERROR: Unexpected error in launching a slave. This is probably a bug in Jenkins
ha:AAAAWB+LCAAAAAAAAABb85aBtbiIQSmjNKU4P08vOT+vOD8nVc8DzHWtSE4tKMnMz/PLL0ldFVf2c+b/lb5MDAwVRQxSaBqcITRIIQMEMIIUFgAAckCEiWAAAAA=java.io.EOFException: unexpected stream termination
	at hudson.remoting.ClassicCommandTransport.create(ClassicCommandTransport.java:100)
	at hudson.remoting.Channel.<init>(Channel.java:392)
	at hudson.remoting.Channel.<init>(Channel.java:388)
	at hudson.remoting.Channel.<init>(Channel.java:349)
	at hudson.remoting.Channel.<init>(Channel.java:345)
	at hudson.slaves.SlaveComputer.setChannel(SlaveComputer.java:338)
	at hudson.slaves.SlaveComputer.setChannel(SlaveComputer.java:315)
	at hudson.plugins.openshift.OpenShiftComputerLauncher.launch(OpenShiftComputerLauncher.java:120)
	at hudson.slaves.SlaveComputer$1.call(SlaveComputer.java:222)
	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at java.lang.Thread.run(Thread.java:744)

Comment 3 Jhon Honce 2014-01-14 16:17:45 UTC
Saw same error in slave.log using devenv_4221

Comment 4 Ben Parees 2014-01-14 18:00:28 UTC
known issue, new jenkins plugin 0.6.28 should resolve it.

Comment 5 Ben Parees 2014-01-15 14:23:59 UTC
this should be working again w/ the new builds.

Comment 6 Lei Zhang 2014-01-16 03:01:02 UTC
Verified on INT(devenv_4227)

[master 862dec2] t
2 files changed, 4 insertions(+), 2 deletions(-)
create mode 100644 jenkins_trigger.txt
remote: Executing Jenkins build.
remote:
remote: You can track your build at https://jenkinsy5637-b7kwk7e0bh.int.rhcloud.com/job/jbossewsvr62aok-build
remote:
remote: Waiting for build to schedule..........................................................Done
remote: Waiting for job to complete.........................................................................................................................Done
remote: SUCCESS
remote: New build has been deployed.
remote: Result: success
remote: Deployment completed with status: success
To ssh://52d739626cec0e4e670003ab@jbossewsvr62aok-b7kwk7e0bh.int.rhcloud.com/~/git/jbossewsvr62aok.git/
7581b79..862dec2 master -> master
Command Return: 0


Note You need to log in before you can comment on or make changes to this bug.