Bug 1048681 - VGA will show any information after comment splashimage in /boot/EFI/redhat/grub.cfg when using EFI
Summary: VGA will show any information after comment splashimage in /boot/EFI/redhat/g...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: grub
Version: 6.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jan Grulich
QA Contact: Release Test Team
URL:
Whiteboard:
: 888195 (view as bug list)
Depends On:
Blocks: 1094978
TreeView+ depends on / blocked
 
Reported: 2014-01-06 05:52 UTC by Luan Jianhai
Modified: 2018-12-09 17:23 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Switch to EFI platform, comment the option parameter splashimage in /boot/EFI/redhat/grub.cfg. Consequence: No information will be shown when using VGA. Fix: If option parameter splashimage not be set, grub will not initiation graphic backend and kernel will use vesafb driver at EFI platform. We should always initiation graphic backend even no splashimage, so kernel will probe correct frambuffer driver to use. Because grub use command-driver to operation script, no special location to process the graphic. The command boot will always be executed after other command, and only be execute once. So I add judge code and inition graphic code into boot_func to completion the mission. Result: When splashimage is present both serial and graphical console can work and show boot progress and login on tty. When splashimage is ommited both serial and graphical console can work and show boot progress and login on tty.
Clone Of:
: 1094978 (view as bug list)
Environment:
Last Closed: 2014-10-14 06:43:42 UTC
Target Upstream Version:


Attachments (Terms of Use)
Kernel should use efifb even no option parameter splashimage When using EFI (1.34 KB, patch)
2014-01-06 05:54 UTC, Luan Jianhai
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1476 0 normal SHIPPED_LIVE grub bug fix update 2014-10-14 01:28:40 UTC

Description Luan Jianhai 2014-01-06 05:52:05 UTC
Description of problem:
  - Change Legacy BIOS to EFI platform.
  - Comment the option parameter splashimage in /boot/EFI/redhat/grub.cfg
  - No Any information will be shown at VGA. 

Version-Release number of selected component (if applicable):
  - RHEL6.1
  - RHEL6.2
  - RHEL6.3
  - RHEL6.4
  - RHEL6.5

How reproducible:

Steps to Reproduce:
1. Change Legacy BIOS to EFI platform.
2. Comment the option parameter splashimage in /boot/EFI/redhat/grub.cfg
3. No any information will be shown at VGA

Actual results:
  No any information will be shown at VGA.

Expected results:
  No splshimage be shown at grub stage. But Kernel shoule use efifb replaced with vesafb, and kernel information should be shown at VGA.

Additional info:
  (None)

Comment 1 Luan Jianhai 2014-01-06 05:54:48 UTC
Created attachment 845928 [details]
Kernel should use efifb even no option parameter splashimage When using EFI

Kernel should use efifb even no option parameter splashimage When using EFI 

If option parameter splashimage not be set, grub will not initiation graphic 
backend and kernel will use vesafb driver at EFI platform. We should always
initiation graphic backend even no splashimage, so kernel will probe correct
frambuffer driver to use. 

Because grub use command-driver to operation script, no special location to  
process the graphic. The command boot will always be executed after other 
command, and only be execute once. So I add judge code and inition graphic 
code into boot_func to completion the mission.

Comment 3 Jan Grulich 2014-05-12 10:59:12 UTC
Here [1] is a scratch build with the proposed patch from Luan Jianhai, so would be great if someone could test it and confirm whether it fixes this issue.

[1] - https://brewweb.devel.redhat.com/taskinfo?taskID=7442453

Comment 4 Jan Grulich 2014-05-19 08:42:16 UTC
Should be fixed in grub-0.97-84.el6.

Comment 6 Jan Grulich 2014-07-02 07:24:32 UTC
*** Bug 888195 has been marked as a duplicate of this bug. ***

Comment 8 errata-xmlrpc 2014-10-14 06:43:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1476.html


Note You need to log in before you can comment on or make changes to this bug.