Bug 1048727 - Unable to unregister with error “Unable to verify server's identity: timed out” [NEEDINFO]
Unable to unregister with error “Unable to verify server's identity: timed ...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: candlepin-bugs
John Sefler
: Reopened
Depends On:
Blocks: 1338516 rhsm-rhel70
  Show dependency treegraph
 
Reported: 2014-01-06 04:14 EST by spandey
Modified: 2016-05-22 08:00 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-25 10:52:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jsefler: needinfo? (alikins)


Attachments (Terms of Use)

  None (edit)
Description spandey 2014-01-06 04:14:49 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
4/4

Prerequisites:
Rhel7 with following subscription-manager rpm 
 subscription-manager-migration-data-2.0.5-1.git.0.3be2ad4.el7.noarch
subscription-manager-gui-1.10.9-1.git.3.5cfb3a0.el7.x86_64
subscription-manager-firstboot-1.10.9-1.git.3.5cfb3a0.el7.x86_64
subscription-manager-migration-1.10.9-1.git.3.5cfb3a0.el7.x86_64
subscription-manager-1.10.9-1.git.3.5cfb3a0.el7.x86_64


Steps to Repro :
Register to katello server .
Now unregister client using unregister command . 

Expected Result : 
Client should successfully unregistered . 

Actual Result : 
Unable to unregister client with error “Unable to verify server's identity: timed out
”
[root@dhcp201-181 sm]# subscription-manager register --u admin --password admin --org redhat
The system has been registered with ID: f3bc639a-6e3e-4f13-ac18-ca8fd3adce6c 
[root@dhcp201-181 sm]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 1.4.15-1.el6-Katello
subscription-manager: 1.10.9-1.git.3.5cfb3a0.el7
python-rhsm: 1.10.9-1.git.0.e05ee04.el7
[root@dhcp201-181 sm]# subscription-manager unregister
Unable to verify server's identity: timed out


rhsm.log output 

014-01-06 14:26:07,205 [DEBUG] subscription-manager @connection.py:418 - Loaded CA certificates from /etc/rhsm/ca/: candlepin-ca.pem, katellosach.pem, candlepin-stage.pem, redhat-uep.pem
2014-01-06 14:26:07,205 [DEBUG] subscription-manager @connection.py:450 - Making request: DELETE /katello/api/consumers/869cfeef-72ee-43da-afaa-5375dafdd01f
2014-01-06 14:27:07,280 [ERROR] subscription-manager @managercli.py:157 - Unregister failed
2014-01-06 14:27:07,281 [ERROR] subscription-manager @managercli.py:158 - timed out
Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/managercli.py", line 1162, in _do_command
    managerlib.unregister(self.cp, consumer)
  File "/usr/share/rhsm/subscription_manager/managerlib.py", line 809, in unregister
    uep.unregisterConsumer(consumer_uuid)
  File "/usr/lib64/python2.7/site-packages/rhsm/connection.py", line 883, in unregisterConsumer
    return self.conn.request_delete(method)
  File "/usr/lib64/python2.7/site-packages/rhsm/connection.py", line 566, in request_delete
    return self._request("DELETE", method, params)
  File "/usr/lib64/python2.7/site-packages/rhsm/connection.py", line 464, in _request
    response = conn.getresponse()
  File "/usr/lib64/python2.7/httplib.py", line 1045, in getresponse
    response.begin()
  File "/usr/lib64/python2.7/httplib.py", line 409, in begin
    version, status, reason = self._read_status()
  File "/usr/lib64/python2.7/httplib.py", line 365, in _read_status
    line = self.fp.readline(_MAXLINE + 1)
  File "/usr/lib64/python2.7/socket.py", line 476, in readline
    data = self._sock.recv(self._rbufsize)
  File "/usr/lib64/python2.7/site-packages/M2Crypto/SSL/Connection.py", line 228, in read
    return self._read_bio(size)
  File "/usr/lib64/python2.7/site-packages/M2Crypto/SSL/Connection.py", line 213, in _read_bio
    return m2.ssl_read(self.ssl, size, self._timeout)
SSLTimeoutError: timed out
Comment 2 Carter Kozak 2014-01-23 08:24:00 EST
We decided the problem was the vm running sam, not in fact candlepin.

I'm not sure why it was so slow, perhaps no visualization support turned on?  If the issue can be reproduced, feel free to reopen.
Comment 4 RHEL Product and Program Management 2014-12-18 01:47:08 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 John Matthews 2015-03-25 19:23:29 EDT
Our team has hit this problem on a RHEL-7 VM several times, it appears to be intermittent.

"Unable to verify server's identity: timed out
Error trying to auto attach pool"


subscription-manager-1.10.14-7.el7.x86_64


2015-03-25 19:13:20,864 [DEBUG] subscription-manager @cache.py:290 - Started thread to write cache: /var/lib/rhsm/cache/content_overrides.json
2015-03-25 19:13:20,866 [DEBUG] subscription-manager @connection.py:418 - Loaded CA certificates from /etc/rhsm/ca/: candlepin-stage.pem, redhat-uep.pem
2015-03-25 19:13:20,867 [DEBUG] subscription-manager @connection.py:450 - Making request: GET /subscription/consumers/8adac238-17e0-4689-b3fb-d999c90bc785/release
2015-03-25 19:13:22,812 [DEBUG] subscription-manager @connection.py:473 - Response: status=200
2015-03-25 19:13:22,814 [INFO] subscription-manager @repolib.py:193 - repos updated: 0
2015-03-25 19:13:22,839 [DEBUG] subscription-manager @hwprobe.py:554 - cpu info: {'cpu.cpu(s)': 2, 'cpu.core(s)_per_socket': 1, 'cpu.thread(s)_per_core': 1, 'cpu.topology_source': 'kernel /sys cpu sibling lists', 'cpu.cpu_socket(s)': 2}
2015-03-25 19:13:22,847 [DEBUG] subscription-manager @hwprobe.py:773 - Running 'virt-what'
2015-03-25 19:13:22,875 [DEBUG] subscription-manager @hwprobe.py:777 - virt-what stdout: kvm

2015-03-25 19:13:22,875 [DEBUG] subscription-manager @hwprobe.py:778 - virt-what stderr: 
2015-03-25 19:13:22,875 [INFO] subscription-manager @hwprobe.py:766 - virt.is_guest: True
2015-03-25 19:13:22,875 [INFO] subscription-manager @hwprobe.py:767 - virt.host_type: kvm
2015-03-25 19:13:22,885 [INFO] subscription-manager @hwprobe.py:822 - virt.uuid: d10e44c5-e679-4dbd-8091-8a4213dfb2d1
2015-03-25 19:13:22,886 [INFO] subscription-manager @factlib.py:57 - Facts have not changed, skipping upload.
2015-03-25 19:13:22,887 [INFO] subscription-manager @cache.py:374 - Server does not support packages, skipping profile upload.
2015-03-25 19:13:22,890 [INFO] subscription-manager @cache.py:169 - Checking current system info against cache: /var/lib/rhsm/cache/installed_products.json
2015-03-25 19:13:22,890 [INFO] subscription-manager @cache.py:186 - No changes.
2015-03-25 19:13:22,891 [DEBUG] subscription-manager @connection.py:418 - Loaded CA certificates from /etc/rhsm/ca/: candlepin-stage.pem, redhat-uep.pem
2015-03-25 19:13:22,892 [DEBUG] subscription-manager @connection.py:450 - Making request: POST /subscription/consumers/8adac238-17e0-4689-b3fb-d999c90bc785/entitlements?pool=8a85f9823e3d5e43013e3ddd4e2a0977
2015-03-25 19:14:25,322 [ERROR] subscription-manager @managercli.py:156 - Unable to attach: timed out
2015-03-25 19:14:25,323 [ERROR] subscription-manager @managercli.py:157 - timed out
Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/managercli.py", line 1391, in _do_command
    ents = self.cp.bindByEntitlementPool(consumer_uuid, pool, self.options.quantity)
  File "/usr/lib64/python2.7/site-packages/rhsm/connection.py", line 925, in bindByEntitlementPool
    return self.conn.request_post(method)
  File "/usr/lib64/python2.7/site-packages/rhsm/connection.py", line 557, in request_post
    return self._request("POST", method, params)
  File "/usr/lib64/python2.7/site-packages/rhsm/connection.py", line 464, in _request
    response = conn.getresponse()
  File "/usr/lib64/python2.7/httplib.py", line 1045, in getresponse
    response.begin()
  File "/usr/lib64/python2.7/httplib.py", line 409, in begin
    version, status, reason = self._read_status()
  File "/usr/lib64/python2.7/httplib.py", line 365, in _read_status
    line = self.fp.readline(_MAXLINE + 1)
  File "/usr/lib64/python2.7/socket.py", line 476, in readline
    data = self._sock.recv(self._rbufsize)
  File "/usr/lib64/python2.7/site-packages/M2Crypto/SSL/Connection.py", line 228, in read
    return self._read_bio(size)
  File "/usr/lib64/python2.7/site-packages/M2Crypto/SSL/Connection.py", line 213, in _read_bio
    return m2.ssl_read(self.ssl, size, self._timeout)
SSLTimeoutError: timed out
Comment 9 Adrian Likins 2015-07-09 12:04:46 EDT
As long as client is handling this gracefully, it's mostly NOTABUG, but the exception message that gets shown on SSLError's isn't particularly accurate.

ie, "Unable to verify server's identity: _the_ssl_error_msg"


TODO:
  - add a more specific message for SSLTimeoutError
  - make the default "SSLError" message more generic
  - figure out where/why the current msg makes sense and hopefully
    hook it to a more specific exception
Comment 11 John Sefler 2015-09-02 15:41:46 EDT
Adrian, what do you want to do with this low severity bug?  Sounds like you have an idea to be implemented.
Comment 12 John Sefler 2015-09-25 10:52:17 EDT
After triage, we decided that the "Unable to verify server's identity: timed out
" message is sufficient.

Note You need to log in before you can comment on or make changes to this bug.