Bug 104876 - file(1) and magic(5) are missing &, <, and > characters
file(1) and magic(5) are missing &, <, and > characters
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: file (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-22 20:53 EDT by D. Hugh Redelmeier
Modified: 2007-04-18 12:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-16 18:07:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description D. Hugh Redelmeier 2003-09-22 20:53:34 EDT
The file(1) and magic(5) man pages' groff source makes references to undefined
strings: \*[Am], \*[Lt], and \*[Gt].  These are intended to display as &, <, and
> respectively.  These characters are critical in magic(5).

Additionally, in the synopsis of file(1), there is a line:
  \*[Am]...
that really should be:
  \&...
(preventing the elipsis from being interpreted as a command).

file(1) is maintained by Cristos Zoulas and is distributed from
<ftp://ftp.astron.com/pub/file/file-X.YY.tar.gz>.  There are currently two
versions there: 3.41 and 4.04.  3.41 still has the problems but 4.04 does not.

The following definitions, added near the top of each file, would solve the
first problem:
.ds Am &
.ds Lt <
.ds Gt >
Comment 1 Jeff Johnson 2003-12-16 18:07:13 EST
this should be fixed in file-4.06-1 packages in rawhide.

Note You need to log in before you can comment on or make changes to this bug.