Bug 1048811 - [gswauth] python traceback seen while using gswauth-clean-token with -v option
Summary: [gswauth] python traceback seen while using gswauth-clean-token with -v option
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gluster-swift
Version: 2.1
Hardware: x86_64
OS: Linux
high
medium
Target Milestone: ---
: RHGS 2.1.2
Assignee: crisbud@redhat.com
QA Contact: pushpesh sharma
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-06 11:30 UTC by pushpesh sharma
Modified: 2015-05-13 16:28 UTC (History)
4 users (show)

Fixed In Version: gluster-swift-plugin-1.10.0-4.el6rhs
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-25 08:14:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:0208 0 normal SHIPPED_LIVE Red Hat Storage 2.1 enhancement and bug fix update #2 2014-02-25 12:20:30 UTC

Description pushpesh sharma 2014-01-06 11:30:40 UTC
Description of problem:

Clone of upstream BZ:

https://bugs.launchpad.net/gluster-swift/+bug/1261677

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 pushpesh sharma 2014-01-06 13:21:01 UTC
Steps:

# gswauth-cleanup-tokens -v
GET .token_0?marker=None
Traceback (most recent call last):
  File "/usr/bin/gswauth-cleanup-tokens", line 105, in <module>
    objs = conn.get_container(container, marker=marker)[1]
  File "/usr/lib/python2.7/site-packages/swiftclient/client.py", line 1177, in get_container
    full_listing=full_listing)
  File "/usr/lib/python2.7/site-packages/swiftclient/client.py", line 1103, in _retry
    self.url, self.token = self.get_auth()
  File "/usr/lib/python2.7/site-packages/swiftclient/client.py", line 1079, in get_auth
    insecure=self.insecure)
  File "/usr/lib/python2.7/site-packages/swiftclient/client.py", line 273, in get_auth
    kwargs.get('snet'))
  File "/usr/lib/python2.7/site-packages/swiftclient/client.py", line 185, in get_auth_1_0
    {'X-Auth-User': user, 'X-Auth-Key': key})
  File "/usr/lib/python2.7/site-packages/swiftclient/client.py", line 164, in request_escaped
    validate_headers(headers)
  File "/usr/lib/python2.7/site-packages/swiftclient/client.py", line 99, in validate_headers
    if '\n' in value:
TypeError: argument of type 'NoneType' is not iterable

Version Info:

glusterfs-openstack-swift-1.10.0-1.31.fc19.noarch

Comment 3 crisbud@redhat.com 2014-01-08 19:08:27 UTC
http://review.gluster.org/#/c/6664/

Patch posted for Review

Comment 4 crisbud@redhat.com 2014-01-09 10:07:45 UTC
Fixed in gluster-swift-plugin-1.10.0-4.el6rhs. 

MOving ON_QA

Comment 5 pushpesh sharma 2014-01-16 06:26:54 UTC
[root@mater ~]# gswauth-cleanup-tokens -v -K gswauthkey
GET .token_0?marker=None
Container .token_0 not found. gswauth-prep needs to be rerun
[root@mater ~]# gswauth-cleanup-tokens -v
Usage: gswauth-cleanup-tokens [options]

Options:
  -h, --help            show this help message and exit
  -t TOKEN_LIFE, --token-life=TOKEN_LIFE
                        The expected life of tokens; token objects modified
                        more than this number of seconds ago will be checked
                        for expiration (default: 86400).
  -s SLEEP, --sleep=SLEEP
                        The number of seconds to sleep between token checks
                        (default: 0.1)
  -v, --verbose         Outputs everything done instead of just the deletions.
  -A ADMIN_URL, --admin-url=ADMIN_URL
                        The URL to the auth subsystem (default:
                        http://127.0.0.1:8080/auth/)
  -K ADMIN_KEY, --admin-key=ADMIN_KEY
                        The key for .super_admin is required.
  --purge=PURGE_ACCOUNT
                        Purges all tokens for a given account whether the
                        tokens have expired or not.
  --purge-all           Purges all tokens for all accounts and users whether
                        the tokens have expired or not.


Verified On:
[root@mater ~]# rpm -qa|grep gluster
gluster-swift-account-1.10.0-2.el6rhs.noarch
glusterfs-geo-replication-3.4.0.57rhs-1.el6rhs.x86_64
glusterfs-rdma-3.4.0.57rhs-1.el6rhs.x86_64
gluster-swift-1.10.0-2.el6rhs.noarch
glusterfs-3.4.0.57rhs-1.el6rhs.x86_64
glusterfs-fuse-3.4.0.57rhs-1.el6rhs.x86_64
gluster-swift-object-1.10.0-2.el6rhs.noarch
gluster-swift-container-1.10.0-2.el6rhs.noarch
samba-glusterfs-3.6.9-167.9.el6rhs.x86_64
vdsm-gluster-4.13.0-24.el6rhs.noarch
gluster-swift-plugin-1.10.0-5.el6rhs.noarch
glusterfs-server-3.4.0.57rhs-1.el6rhs.x86_64
gluster-swift-proxy-1.10.0-2.el6rhs.noarch
glusterfs-libs-3.4.0.57rhs-1.el6rhs.x86_64
glusterfs-api-3.4.0.57rhs-1.el6rhs.x86_64

Comment 7 errata-xmlrpc 2014-02-25 08:14:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html


Note You need to log in before you can comment on or make changes to this bug.