Bug 104884 - up2date --register at text console is wider than 80 columns (wider than the screen)
up2date --register at text console is wider than 80 columns (wider than the s...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Bret McMillan
Fanny Augustin
:
Depends On:
Blocks: 191074 191079
  Show dependency treegraph
 
Reported: 2003-09-23 05:00 EDT by Barry K. Nathan
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-21 12:30:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of text-mode rhn_register in a GNOME Terminal (43.77 KB, image/png)
2004-07-14 13:14 EDT, Barry K. Nathan
no flags Details
output of /proc/cpuinfo (402 bytes, text/plain)
2004-07-14 13:18 EDT, Barry K. Nathan
no flags Details

  None (edit)
Description Barry K. Nathan 2003-09-23 05:00:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030630

Description of problem:
The text (not GUI) up2date --register is wider than 80 columns on the screen
that asks permission for sending CPU info, etc. Thus I can't see all the
information.

Pay particular attention to the "Additional Information" part of this bug
report! It has more info that might help you reproduce or fix this.

Version-Release number of selected component (if applicable):
up2date 3.9.27-1 or 3.9.28-2 (happens with both)

How reproducible:
Always

Steps to Reproduce:
1. Install taroon. (Maybe severn works too, but I didn't try.)
2. Manually rpm -Uvh up2date and up2date-gnome (to avoid SSL problems)
3. Switch to a text console if you're in X, and become root.
4. up2date --register
5. Go past the privacy stuff
6. Enter your username, password, password again, and e-mail address.
7. You should now be at the screen that asks for the name you want for the
profile. This screen is too wide (on my system).

Actual Results:  Screen too wide

Expected Results:  Screen should fit

Additional info:

I'm guessing that the following bits of info might be triggering the wideness:

(a) In the left column, the hostname is "localhost.localdomain".
(b) In the right column, the CPU model is "Intel(R) Pentium(R) III CPU family  
   1400MHz". The last character to show up is the "1" in "1400MHz". That bunch
of spaces is not a typo -- it's also in /proc/cpuinfo.

This is happening with kernel 2.4.21-3.EL, although it happened with the
original taroon beta 2 kernel as well.
Comment 1 Barry K. Nathan 2004-07-14 13:09:11 EDT
This bug still exists, with kernel-2.4.21-15.EL (from Taroon Update 2)
and up2date-4.2.16 (from the latest Taroon errata), but it's not quite
as bad (the hostname is now "unknown", just leaving the horrendously
long "CPU model" to deal with). Later today I will attach some kind of
screenshot in one form or another to try to illustrate the problem.
Comment 2 Barry K. Nathan 2004-07-14 13:14:25 EDT
Created attachment 101908 [details]
screenshot of text-mode rhn_register in a GNOME Terminal

Notice how the left and right sides get cut off...
Comment 3 Barry K. Nathan 2004-07-14 13:18:42 EDT
Created attachment 101909 [details]
output of /proc/cpuinfo

I'm attaching it rather than pasting it in, since I really want to make sure
the whitespace doesn't get wrecked.

(BTW, since this is less severe than what I experienced with the Taroon public
beta and since most people probably use X or kickstart to register, I will
reduce the severity from Normal to Low.)
Comment 6 Fanny Augustin 2006-04-10 20:17:19 EDT
Blocking rhnupr4u4 and rhnupr3u8 to track the progress of the release
Comment 7 Fanny Augustin 2006-04-13 15:16:31 EDT
Moving bugs to the CanFix List
Comment 8 Fanny Augustin 2006-05-08 14:54:37 EDT
This bug did not make the code freeze and it will not be fiixed during this
release cycle.  Re-aligning bug to the next release
Comment 10 RHEL Product and Program Management 2006-07-21 12:30:50 EDT
Development Management has reviewed and declined this request.  You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.