Bug 104887 - Cannot rebuild SRPMS: undefined reference to `db_strerror'
Cannot rebuild SRPMS: undefined reference to `db_strerror'
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: cyrus-sasl (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-23 05:21 EDT by Peter Bieringer
Modified: 2007-04-18 12:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-19 16:23:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Bieringer 2003-09-23 05:21:32 EDT
Description of problem:
Cannot rebuild SRPMS of RHL9/SRPM on a RHL9 system:

gcc -Wall -W -Wall -O2 -g -march=i386 -mcpu=i686 -I/usr/kerberos/include
-Wl,-rpath -Wl,/usr/local/lib -o client client.o common.o  -L/usr/local/lib
-L/usr/kerberos/lib ../lib/.libs/libsasl2.a -ldl -lcrypto -lgssapi_krb5 -lkrb5
-lk5crypto -lcom_err -lpthread -lresolv -lcrypt
../lib/.libs/libsasl2.a(db_berkeley.o)(.text+0x5a): In function `berkeleydb_open':
/mnt/rpmbuild/BUILD/cyrus-sasl-2.1.10/cyrus-sasl-2.1.10/sasldb/db_berkeley.c:85:
undefined reference to `db_create'
../lib/.libs/libsasl2.a(db_berkeley.o)(.text+0x79):/mnt/rpmbuild/BUILD/cyrus-sasl-2.1.10/cyrus-sasl-2.1.10/sasldb/db_berkeley.c:102:
undefined reference to `db_strerror'
../lib/.libs/libsasl2.a(db_berkeley.o)(.text+0x1a6): In function `berkeleydb_close':
/mnt/rpmbuild/BUILD/cyrus-sasl-2.1.10/cyrus-sasl-2.1.10/sasldb/db_berkeley.c:122:
undefined reference to `db_strerror'
../lib/.libs/libsasl2.a(db_berkeley.o)(.text+0x39f): In function `_sasldb_getdata':
/mnt/rpmbuild/BUILD/cyrus-sasl-2.1.10/cyrus-sasl-2.1.10/sasldb/db_berkeley.c:198:
undefined reference to `db_strerror'
../lib/.libs/libsasl2.a(db_berkeley.o)(.text+0x60a): In function `_sasldb_putdata':
/mnt/rpmbuild/BUILD/cyrus-sasl-2.1.10/cyrus-sasl-2.1.10/sasldb/db_berkeley.c:284:
undefined reference to `db_strerror'
../lib/.libs/libsasl2.a(db_berkeley.o)(.text+0x67e):/mnt/rpmbuild/BUILD/cyrus-sasl-2.1.10/cyrus-sasl-2.1.10/sasldb/db_berkeley.c:296:
undefined reference to `db_strerror'
collect2: ld returned 1 exit status
make[2]: *** [client] Error 1
make[2]: Leaving directory
`/mnt/rpmbuild/BUILD/cyrus-sasl-2.1.10/cyrus-sasl-2.1.10/sample'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/mnt/rpmbuild/BUILD/cyrus-sasl-2.1.10/cyrus-sasl-2.1.10'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.5195 (%build)


Version-Release number of selected component (if applicable):
cyrus-sasl-2.1.10-4.src.rpm

How reproducible:
Always

Steps to Reproduce:
1. rebuild SRPMS on a RHL9 system
2.
3.
    

Actual Results:  Rebuild fails (no changes were done in spec file for now, but
would be done later to enable LDAP support).

Expected Results:  Rebuild on a RHL9/SRPMS should working on a RHL9 system...

Additional info:

Same after installing compat-db, doesn't help.

Rebuild of current rawhide/SRPMS cyrus-sasl-2.1.15-4.src.rpm works, after
creating a softlink:
ln -s /usr/kerberos/bin/krb5-config /usr/bin
(bug or feature of krb5-devel of RHL9?

BTW: build systems were different, perhaps here the problem is located:
$ rpm -q --queryformat "%{NAME}-%{VERSION}-%{RELEASE} %{BUILDTIME}
%{BUILDHOST}\n" cyrus-sasl db4
cyrus-sasl-2.1.10-4 1043542784 tweety.devel.redhat.com
db4-4.0.14-20 1044479381 porky.devel.redhat.com
Comment 1 Robert Scheck 2004-07-18 16:53:02 EDT
Peter, I only know that problem as I replaced db4 version 4.2.52 by 
the older 4.0.14 or if I did some linking changes against db4.

Maybe you've got a look to bug #120562, because I'm providing there 
a working spec file for RHL9 with cyrus-sasl-2.1.18 (working also for 
2.1.19) including a bundled libdb4 to work around NPTL problems at 
i586.
Comment 2 Peter Bieringer 2004-07-19 16:15:24 EDT
I have giving up the fight against the *Strange* Authentication
Security Layer short after I ran into that problems and created the
"simpleauth" patch for postfix.

Also RHL9 is no longer supported, therefore this bug can be closed imho.
Comment 3 Robert Scheck 2004-07-19 16:20:17 EDT
Yeah, okay...I only wanted to add this (maybe useful) information - 
maybe for people having the same problem and looking for a solution -
even if RHL9 is unsupported now ;-)

BTW: Sorry, I can't close that bug, only the reporter or the assigned 
person(s) (or higher of course) can do that.
Comment 4 Peter Bieringer 2004-07-19 16:23:33 EDT
Bug closed because no longer of interest.

Note You need to log in before you can comment on or make changes to this bug.